1 22 23 24 25 26 27 Previous Next 398 Replies Latest reply: Nov 26, 2012 9:13 AM by GingerHips Go to original post
  • 345. Re: Lion and Keynote Problems
    konstantin from CA Level 1 Level 1 (0 points)

    Just found this on another forum. Seems to work without downgrading Keynote.

     

     

    You can turn off Auto Save by going to: System Preferences -> General

    and unchecking “Restore windows when quitting and re-opening apps”.

    This disables saved states (versioning, auto-save) across the board.

    There’s no way to selectively exclude apps.

    You can turn off the equally annoying “All documents older than

    2 weeks are automatically locked” by going to: System Preferences

    -> Time Machine, then click Options and adjust the setting.

     

  • 346. Re: Lion and Keynote Problems
    GingerHips Level 1 Level 1 (0 points)

    I am going to try this out today. It will be great if it works, but also infuriating that Apple couldn't communicate such a simple temporary fix with us.

     

    Thanks

  • 347. Re: Lion and Keynote Problems
    fuzzydog Level 2 Level 2 (355 points)

    This post that advocates the following "solution" is false.

     

     

    You can turn off Auto Save by going to: System Preferences -> General

    and unchecking “Restore windows when quitting and re-opening apps”.

    This disables saved states (versioning, auto-save) across the board.

    There’s no way to selectively exclude apps.

    You can turn off the equally annoying “All documents older than

    2 weeks are automatically locked” by going to: System Preferences

    -> Time Machine, then click Options and adjust the setting.

     

     

     

     

     

    This purported solution does NOT solve the problem. Don't waste your time.

     

    Message was edited by: fuzzydog

  • 348. Re: Lion and Keynote Problems
    Psychobilly Bates Level 1 Level 1 (5 points)

    I've tried this also, all it does is not open all the apps you had open when you closed. Seems it shouldn't be such a big issue to give us the OPTION of using auto-save. Leave auto-save for Pages & Numbers, but please- Apple, let us turn off auto-save- we all know how to press [command-S].

  • 349. Re: Lion and Keynote Problems
    konstantin from CA Level 1 Level 1 (0 points)

    Works for me. I have 2.3G 400 slides Keynote file that was unmanageable before. Every time I selected another slide just to see or to edit it Keynote would start auto-save. And it is not the case now after turning off Auto-save feature. I can edit my presentation now without looking at the rolling beach ball every 20 seconds. I wish you to find solution that is suitable for you. The one I have posted here solved my Keynote-Lion problem.

  • 350. Re: Lion and Keynote Problems
    konstantin from CA Level 1 Level 1 (0 points)

    I'd like to add that I have another Keynote presentation created a wile ago under Snow Leopard. This one is 170 slides and 5.7G (bunch of small movies). Just tried to load it into Keynote under Lion (after turning Auto-Save off). Absolutely no problem. Yes it is slow to save, when I actually want to save it, but not when Lion wants to save it so often. So try some real world large Keynote file first please.

  • 351. Re: Lion and Keynote Problems
    Psychobilly Bates Level 1 Level 1 (5 points)

    I also have had some successs since the last OSX update, which prior I couldn't even open a presentation if any audio or video was in it. The last update helped with smaller video files, but big files/presentations are still a problem.

  • 352. Re: Lion and Keynote Problems
    William C. Level 1 Level 1 (115 points)

    I run several Macs, both desktop and laptop.  One of my iMacs runs iWork 9.1 on OS 10.7.2.  Yesterday I produced a quick Keynote presentation using the current software with no issues.  In fact, I have to admit that I found the ability to go back to a previous version handy at one point.  The file was small (20 MB) with a few builds but no videos. 

     

    Just for grins, I opened a much larger file (1.2 GB) with several embedded videos.  It quickly bogged down to the familiar beach ball of doom.  Moreover, and more troubling, it bogged down in "Rehearse Slideshow" mode.  This is not good, as the last thing one needs to see is a beach ball during a professional presentation.

     

    Conclusion:  Stick with iWork 9.0.5 until Apple comes clean.  I suspect that Apple is going to be stubborn about this Autosave/Versions feature.  This is the old Steve Jobs "our way or the highway" philosophy which hasn't been all that bad but occasionally comes back to bite.

     

    In the meantime, voice your frustrations here:  http://www.apple.com/feedback/keynote.html

     

    Be sure to Force Quit all stalls and send in a report.  I try to do this a few times a week, just for grins.

     

    And don't forget to go to the Apple Store or the App Store and write a stirring 1-star review detailing your frustrations.  Consumer pressure never hurts.

     

    Finally, do not forget to go manual on Software Updates or you will be one casual click away from going through the whole downgrade procedure all over again.  (I keep all the downgrade files in a special folder on all computers just in case.)

  • 353. Re: Lion and Keynote Problems
    dhwinston Level 1 Level 1 (0 points)

    There is a workaround for rehearsing and presenting - if the document is locked (you can't edit) it doesn't save - for obvious reasons, and you avoid the beachball.

  • 354. Re: Lion and Keynote Problems
    lesposen Level 1 Level 1 (45 points)

    There is a rather odd workaround for those for whom the Lion/Keynote problem persists... (I am experiencing it minimally but certainly not to the extent so are forcing them back to earlier versions or Powerpoint).

     

    VMware's latest update to its virtualization software, Fusion 4.1, allows Lion users to vitualise OS X images, thus enabling you to run previous versions of OS X within your Lion setup. You could of course merely set up a new partition and run Snow Leopard there, but the vitualization option means you don't have to reboot out of or into Lion.

     

    I haven't tried it, but suggest those interested search the usual Mac-oriented websites to investigate for themselves if this is a feasible option.

     

    Les Posen

    Melbourne, AU

  • 355. Re: Lion and Keynote Problems
    therivers Level 1 Level 1 (0 points)

    THIS POST CONTAINS A TRIED AND TESTED SOLUTION FOR THIS PROBLEM.

     

    --------------------------------------------------------

    WHAT IS THE PROBLEM?

    --------------------------------------------------------

    Once Lion is installed, Keynote becomes incredibly sluggish, showing the beach ball of doom frequently and for many minutes at a time. This happens during rehearsal and presentation, too. This seems to happen in presentations that contain video. For some users, even 1 slide with video on it seems to cause the problem.

     

    --------------------------------------------------------

    WHY IS IT HAPPENING?

    --------------------------------------------------------

    There seems to be a bug in Versioning which is handling videos in Keynote badly. Versioning does saving in the background, and somehow it seems to all the wrong things in presentations with video.

     

    --------------------------------------------------------

    IS THERE A FIX  FOR THIS PROBLEM?

    --------------------------------------------------------

    There is no official fix from Apple for this problem. There is an unofficial fix, which fuzzydog first suggested, which is to DOWNGRADE Keynote from version 9.1 to version 9.0.5. The difference between version 9.0.5 of Keynote and the  version 9.1 of Keynote is Versioning, and that's basically it. So downgrading will get rid of Versioning, and fix this problem. INSTRUCTIONS ARE BELOW.

     

    Some users have suggested several fixes which work for them but DID NOT WORK FOR ME and have not worked for other users, as well. These include:

     

    1) I tried unchecking the "Back up previous version" checkbox in Keynote  Preferences. While some people reported that this worked for them, it made no difference for me.

     

    2) I tried unchecking the "Lock documents 2 weeks after last edit" item in Time Machine Options. This also did not work for me.

     

    3) I tried duplicating the file and then opening it in Keynote. This would seem to work at first, then deteriorate. Why? My thought is that when you duplicate a file you get rid of it's "version history" that Lion and Keynote are using instead of save, but once you start actually going through the presentation it starts a new version history and has problems again. In theory if you don't change anything in the presentation it shoudn't happen, but this only helps if your goal is just presentation. I need Keynote to work so I can edit, too.

     

    4) I tried locking the file. This did work, and is fine for when you need to rehearse and present, but useless when editing a presentation. And Keynote is just unusable while editing, so I don't consider it a fix.

     

    5) Go back to Snow Leopard. You can certainly do this and it will fix the problem but YOU DON'T NEED TO. All you need to do is to go back to an older version of Keynote.

     

    6) Go to Powerpoint. Well, that's certainly an option. But if you're ready to make that big a change, I would suggest trying to downgrade Keynote first.

     

     

    --------------------------------------------------------

    SO WHAT IS THE FIX?

    --------------------------------------------------------

    Downgrade to the previous version of Keynote and this problem WILL GO AWAY. Instructions below:

     

     

    --------------------------------------------------------

    WHAT ARE THE STEPS TO FIX THIS PROBLEM?

    --------------------------------------------------------

    1. Find your iWork 9 DVD. If you downloaded iWork from the App store and do not have a disk, then you will need to find a disk. I don't know of any way to download an older version of iWork from the App store. Try eBay, try a friend, try going to the Apple store.

     

    If you really cannot get the iWork 9 DVD in your hands, then your best option is to go back to Snow Leopard. If you cannot figure out how to do that, go to an Apple store and ask for help. Take a printout of this message with you.

     

    2. Remove iWork 9.1 using the script supplied by Yvan Koenig. Just deleting iWork is NOT enough - you need to clean up all the iWork files or this won't work. The script found on this server:

     

    https://public.me.com/koenigyvan

     

    Look in the folder called "For_iWork", then "iWork '09" and then download the file called "uninstall iWork '09.zip". When that has downloaded and opened, click RUN. Wait several minutes while it gets rid of iWork. While it's working the button will say "Stop" and when it's done the "Run" button will reappear.

     

    The script does not remove your personal templates stored in your user/library/application support/iworks folder, so you don't have to worry about losing those.

     

    2. Reinstall iWork 9 from your disk.

     

    3. Next you'll want to update iWork to version 5.05. You can get this here. http://support.apple.com/downloads/#iwork.

     

    There are FOUR update packages:  9.0.1, 9.0.3, 9.0.4 and 9.0.5.  Download and install them one at a time, in order. Yes, I know these are version 9.0.1+ and we're upgrading to 5.05 - who knows what's with that. Just roll with it.

     

    4. The first time you open any iWork app (Numbers, Keynote or Pages) it will ask you to upgrade to 9.1. DO NOT DO THIS and check the box indicating NOT to be reminded again.

     

    EVERY time in the future that you do a software update it will offer to update iWork for you. Make sure that each time you DO NOT UPDATE iWork to version 9.1.

     

    --------------------------------------------------------

    I DID WHAT YOU SAID AND IT DIDN'T WORK

    --------------------------------------------------------

    If it did not work, check the version number on Keynote (go to Keynote > About Keynote). If it says version 5.1 then you didn't properly uninstall the old iWork. If it says version 5.0.5, then it should be working.

     

    If it's not, then this fix didn't work for you and you should definitely post a message to this forum because you would be the first person it didn't work for.

     

    --------------------------------------------------------

    WHY HASN'T APPLE RESPONDED TO THIS PROBLEM?

    --------------------------------------------------------

    There's a lot of posts expressing outrage over this problem and wondering why Apple hasn't resolved it. I have no idea. I do know that Apple DOES NOT READ these forums, so if you are having this problem you NEED to give Apple feedback.

     

    Visit the Keynote feedback page and provide information here:

     

    http://www.apple.com/feedback/keynote.html

     

    Or go to the Apple store and show a genius this entire post and have him register the problem. Or call Apple, if you've the patience.

  • 356. Re: Lion and Keynote Problems
    s.tash Level 1 Level 1 (0 points)

    Right, I figured that out after my post.  Just wishful thinking, I guess...

  • 357. Re: Lion and Keynote Problems
    jachojadad Level 1 Level 1 (0 points)

    I am so worried because of LION and Keynote, autosave is getting me crazy, I can´t work with this trouble, somebody know how to revert to Snow Leopard?

  • 358. Re: Lion and Keynote Problems
    ToothShooter Level 1 Level 1 (0 points)

    Have had the same problem as everyone else.  iMac i7 with 12 gigs of ram.  THANK YOU TO "therivers".  Followed Your post exactlly and I am back in business.  I was desperate as I have some very large Keynotes, 320 slides + that I was updating.  5 slides took me 20 minutes with all the saving going on.  Just finished doing the same fix to my Macbook Pro 17.  Thanks!!!!!  To Apple: get with the program, I left PC to have a peaceful enviorment, it was until Keynote issues.

  • 359. Re: Lion and Keynote Problems
    littlecolby Level 1 Level 1 (0 points)

    look at the above post by 'theriver' ... it will take you 30 minutes and should work.  I just did it.  I had the same problems as you and felt the same as you ... ready to panic but I think this really is the ticket.  Just tried it ... IT WORKS.!!  Take your time, do exactly what he says.  You'll be back in business.