8 Replies Latest reply: Sep 6, 2013 12:55 PM by RBbeachbum
jkizer Level 1 Level 1 (0 points)

Ever since I upgrade to iOS 5 I have had issues w/ certain albums now being "orphaned", meaning they are not showing up under the "Artists" that they belong to even though they do show up in the "Albums" section. I have visited an Apple store about this issue and got absolutely no help figuring out what the problem is. Also I have now had this same exact issue on three different iPhones (two iPhone 4 and one iPhone 4s) so the issue is not the phone. All that I can related it back to is the upgrade from iOS 4 to 5. Any help is greatly appreciated.

 

Thanks,

 

JK

  • 1. Re: Orphaned Albums
    JinKL Level 2 Level 2 (160 points)

    Its very hard to understand what your issue is by thiat description.

     

    See if the following does anything?

     

    On the iPhone

    Settings>Music>Group By Album Artist

    Try changing this setting to either on or off.

  • 2. Re: Orphaned Albums
    jkizer Level 1 Level 1 (0 points)

    I have tried that and that unfortunately doesn't solve the problem. An example should make this clear.

     

    Let's say I have four albums by Radiohead in ITunes and I tell iTunes to sync all of them to my iPhone. I then go to the "Music" app on my iPhone and go to the "Artists" section. What is happening is that (for example) three of those albums show up under Radiohead and the fourth is missing in action. However, if I go to the "Albums" section of the "Music" app I see all four albums there. So all four albums are on the iPhone it's just that one of them (again in this example) is not showing up under Radiohead in the "Artists" section of the "Music" app.

     

    For some reason the above example is exactly what is happening for some of my music catalogue. To be clear though this is not happening with every single artist. For most of them all the albums show up as they should under the correct artist. Also to reiterate I never had this issue prior to upgrading to iOS5.

  • 3. Re: Orphaned Albums
    JinKL Level 2 Level 2 (160 points)

    Make sure the artist name in Itunes is "Radiohead" and not "-radiohead-" "Songs by Radio head" or any other variant including spaces before the first letter.

  • 4. Re: Orphaned Albums
    jkizer Level 1 Level 1 (0 points)

    Thanks but all the artist names are as they should be. As I said I didn't have this issue until going from iOS4 to iOS5 and all the albums show up correctly on my iPod.

  • 5. Re: Orphaned Albums
    OS2Nutcase Level 1 Level 1 (0 points)

    I was having the same issue until a few moments ago when I found this other thread discussing making a change in the settings.

     

    http://forums.macrumors.com/showpost.php?p=13702843&postcount=5

     

    Sure enough it is there if you go to your iphone General Settings->Music then scroll down to the bottom and turn off "Group by Album Artist" and restart the music app after completely closing from the background also. According to other threads iOS5 uses the other field.

     

    The other option is to start filling in the "Album Artist" field and resync.

  • 6. Re: Orphaned Albums
    asdrubal76 Level 1 Level 1 (10 points)

    I've been trying to figure this problem out all day. I finally turned off "Group by Album Artist" in my iPhone "Music" setting (under "Settings"), as several people have suggested--and the orphaned albums finally re-appeared only after I turned off my iPhone and turned it back on.

     

    Clicking off "Part of a Compilation" in iTunes for every orphaned album also seems to work, but that is a much more time-consuming process, as you have to do this for EVERY album. Simply turning off "Group by Album Artist" and re-booting your phone solves the problem quickly.

     

    "Quickly" i.e. after tearing your hair out for three hours and scouring the internet for solutions.

  • 7. Re: Orphaned Albums
    jkizer Level 1 Level 1 (0 points)

    I want to thank everyone for their help. I have FINALLY been able to resolve this issue. As asdrubal76 and others noted the fix was turning off "Group by Album Artist" and restarting my iPhone 4S.

     

    Best,

     

    JK

  • 8. Re: Orphaned Albums
    RBbeachbum Level 1 Level 1 (0 points)

    I've had this problem for a while now and finally got around to searching the web for an answer.  Before I found this post, I tried filling in the Album Artist first in iTunes then syncing to my iPhone.  This did not work. 

     

    After finding this post, I tried turning off "Group by Album Artist".  This worked on my iPhone, but NOT my iPad.  It's perplexing that this problem still exists a couple of years after iOS 5 has been released.  I guess Apple doesn't think it a big enough deal to fix.  In the scheme of things, I suppose it's a small problem but very ANNOYING none the less.