Skip navigation

Some uploaded songs don't play on my iPhone

144799 Views 65 Replies Latest reply: Feb 9, 2014 6:37 PM by HelperAndLiker RSS
1 2 3 ... 5 Previous Next
Andrew Shalit Level 1 Level 1 (5 points)
Currently Being Moderated
Nov 23, 2011 1:01 PM

I've just set up iTunes Match and mostly it is working fine.  However, some of the songs that were Uploaded (as opposed to Matched) from my Macintosh do not play on my iPhone.  I see them on my iPhone; I can download them on my iPhone;  but when I go to play them nothing happens.  There are a few seconds of silence and then the Music app on my iPhone skips ahead to the next song.

 

This happens to individual songs.  Other songs on the same album will play fine.

 

If I take one of the problematic songs and load it directly onto my iPhone (not through iTunes Match), then it plays fine.  But when I switch back to iTunes Match and download the song from iCloud, once again the song won't play.

 

These songs were coded at 256 kbps AAC files.

 

Has anyone else run into this?  Does anyone have a workaround?  I would just as soon not rerip all my songs as MP3 files, but I guess I could.

MacBook Air 11-inch 1.6 GHz, Mac OS X (10.6.6)
  • Roman1 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 25, 2011 1:52 AM (in response to Andrew Shalit)

    Similar problem.

     

    1. Song (Stephane Grappelli concert) encoded into Apple Lossless is uploaded to iTunes Match.

    2. I delete the song from my Library, it becomes gray and I can re-download from iTunes Match.

    3. Download from iCloud fails with an error ^0

     

    PS: This is just one song from the whole album, all others will upload and re-download in lower 256 bitrate.

  • scottbrown Level 1 Level 1 (65 points)
    Currently Being Moderated
    Nov 25, 2011 6:39 AM (in response to Andrew Shalit)

    More than half of my uploaded songs won't play.  I'm on my computer at work right now, and most tracks I try to stream just skip right to the next song.  I've even re-uploaded the tracks and they still won't play. 

     

    These tracks are true VBR encoded by quicktime with a level of 88 or above (quicktime true vbr has a quaity scale of 0-127). In kbps, this translates to around 190kbps or above. 

     

    It's driving me crazy

  • Thecuno Calculating status...
    Currently Being Moderated
    Nov 28, 2011 5:44 PM (in response to Andrew Shalit)

    This same thing is happening to me. It will either freeze for an eternity, or skip ahead several songs. This happens even after I've redownloaded them, makes no sense. This is also happening with an album I just purchased off the iTunes store. I guess there's some hope, that several of us are having this issue so maybe a fix is on the way?

  • meteorallen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2011 4:07 PM (in response to Andrew Shalit)

    Ditto. I am looking for a solution and or explaination. Helloooooooo anyone from Apple out there?

  • Indenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2011 10:35 AM (in response to Andrew Shalit)

    In my case, the problem Match songs play fine from iCloud on my desktop and Apple TV but they won't play on iPhone. The appear in the song list kind of whited out but won't even start playing. There is no Cloud or download icon next to them. There are probably hundreds of these among my 10K-plus matched/uploaded songs.

  • Indenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2011 9:29 AM (in response to Indenter)

    Following up on my own comment ... After fiddling with the problem songs, I discovered that any change in the meta data will  cause an update in the song in Match / iCloud. That is quickly followed by a Match update on my iphone. We're talking maybe 10 seconds for the phone to show the update. I had 100 percent success making all my songs playable on the phone by making small meta data changes, such as a capitalization change in the album title or an extra space after the title. The problem was centered on certain albums in which several songs were uploaded instead of matched, so to save time I made the meta data change to the entire album.

  • Jeff Young4 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 4, 2011 9:41 AM (in response to Andrew Shalit)

    Sames here, hundreds of songs won't play on the iPhone 4 even though they play fine on my MacBook Pro. If I chose a playlist with 10 songs it may play 3 of them and it just skips all the rest. This is turning out to be a waste of money.

  • Indenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2011 9:44 AM (in response to Jeff Young4)

    did you try the metadata change I described above? Time consuming but should be a permanent fix.

  • Jeff Young4 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 4, 2011 10:10 AM (in response to Indenter)

    Thanks for the tip but I have 22,000 songs and I'd have to try them each on my iphone to figure out which ones to fix or I'd have to do some sort of batch change to all of them right?

  • Indenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2011 10:14 AM (in response to Jeff Young4)

    In my case the nonplayable songs were grayed out so easy to identify. If that's not the case for you I'm at a loss. I had hundreds of grayed-out songs in my 10,500-song list. Took about 90 minutes of batch-editing albums to fix them all.

  • Indenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2011 2:02 PM (in response to Jeff Young4)

    Jeff, it occurred to me that you might be trying to use Match on 3G. It's not really a streaming service (yet) and didn't work well on 3G for me either. Make sure "Cellular Data" turned off under Settings / Store.

  • Jeff Young4 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 4, 2011 6:40 PM (in response to Indenter)

    but if I can't use it with 3G then I might as well still with Audiogalaxy. It works just fine with 3G as long as my MAC is on at home.

     

    I can't believe that Apple would charge $25 buck a year and only be good enough to work in WiFi.

     

    I'll try a few more things and see if I can find a solution since Apple doesn't seem to want to offer one.

  • scottbrown Level 1 Level 1 (65 points)
    Currently Being Moderated
    Dec 4, 2011 7:26 PM (in response to Andrew Shalit)

    I'm not even trying to play songs on my iPhone.  I'm trying to play them on another computer at work.  More than half the Uploaded songs won't play.  They just skip to the next song (which also won't play, so it skips to the next, and the next, etc). 

     

    The songs are not grayed out.

     

     

    This is a real issue

1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.