Skip navigation

Disable Yahoo Sync after iCloud migration

6384 Views 26 Replies Latest reply: May 26, 2012 11:25 PM by Peterfleisch RSS
  • Tif Level 2 Level 2 (250 points)
    Currently Being Moderated
    Nov 22, 2011 9:42 AM (in response to TylerMc27)

    I have sort of a similar problem.   I tried to sync with yahoo... Big mistake.   Now, I want out of it, so I unchecked the box in Address book.   I see duplicate entries.   So I deleted all of the contacts and asked to resync through icloud.... And then come all the duplicates again.   But the thing is... It is only happenning in my macbook pro.  In my ipad there are no duplicates.   I could live with the duplicates, but hte problem is that every time that I try to input a new contact, it does so in the yahoo calendar, so it won't sync with icloud.  Any ideas?  I am going crazy here!

  • barito7 Calculating status...
    Currently Being Moderated
    Nov 22, 2011 2:20 PM (in response to Tif)

    Tif, best to back up what you have before you start to fix it - I had to rebuild the contacts database from scratch (linked in etc.).

     

    I seem to have got rid of a sync problem I had. See beginning of this thread for screen capture that was appearing all the time.

     

    According to a gent at Apple support I talked to, Yahoo sync doesn't work with iCloud (as you know!)

     

    1. Making sure syncing is unchecked in contacts (which I think you have done)

    2. I did make sure my mail accounts were set correctly and even deleted them and set them up again.

    3. Deleted any keychains that were to do with yahoo sync

    4. Deleted out any items in the Library that were yahoo sync. One was in Applicaiton Support, the other one I can't remember but it was in one of the library folders...I think someone stated this on this thread.

     

     

    As for the doubled up contacts, all I can suggest is that you attempt to delete these but please back them up first - I did try to do this and then half my contacts disappeared for some reasons as iCloud synced. The only other suggestion is back up first and then:

     

    1. Delete all duplicates and export vcards to your desktop.

    2. delete all your contacts in address book - this might affect groups you have set up..not sure.

    3. Check to see that iCloud has deleted all your contacts

    4. import you contacts file you exported and wait for iCloud to do it work again

     

     

    I also made sure that Yahoo wasn't syncing anything which I don't know how to do now but I just keep clicking things until I was confident that it was trying to sync anything.

     

    Good Luck

  • Tif Level 2 Level 2 (250 points)
    Currently Being Moderated
    Nov 22, 2011 2:50 PM (in response to barito7)

    Thank you very much for a long reply.  Unfortunately, that was not the problem! Thanks anyways

  • carl_sf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2011 5:13 PM (in response to Jennifer Marsh)

    This is also driving me crazy... will continue to click cancel until someone can generate a fix. 

  • Nyghtone Calculating status...
    Currently Being Moderated
    Nov 27, 2011 10:36 AM (in response to Jennifer Marsh)

    I am also having this problem, I have tried EVERYTHING in this thread.  I don't even use iCloud, MobileMe, iCal, OR Address Book.  I have deleted everything with the name Yahoo in it off of my entire computer, all the keychains, and I am STILL getting this alert.

     

    This is about to drive me insane!!

  • adamwade Calculating status...
    Currently Being Moderated
    Nov 27, 2011 11:13 PM (in response to Nyghtone)

    I seemed to have sorted this issue by deleting all my contacts in Yahoo and the allowing the sync to merge.  I haven't had an alert since.

  • Nyghtone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2011 5:22 AM (in response to adamwade)

    I dont' even have a yahoo account, I dont' use ical or address book at all, and I am NOT going to create a freakin yahoo account to get this allert to go away!!!

  • apple product enthusiast Calculating status...
    Currently Being Moderated
    Nov 28, 2011 7:40 PM (in response to Nyghtone)

    In your address book accounts, have you unchecked the sync option for on my Mac local?  I have also switched all contacts to be held only in iCloud.  Meaning, I don't have any contacts on my MacBook pro, only in iCloud.

  • apple product enthusiast Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2011 7:44 PM (in response to Jennifer Marsh)

    In your address book accounts, have you unchecked the sync option for on my Mac local?  I have also switched all contacts to be held only in iCloud.  Meaning, I don't have any contacts on my MacBook pro, only in iCloud.

  • ScotRaleigh Calculating status...
    Currently Being Moderated
    Nov 28, 2011 7:47 PM (in response to Jennifer Marsh)

    I finally got the Yahoo sync message gone from my MacBook Air.  First I logged out of Mobile Me.  This action alone stopped the Yahoo sync message.  I had tried this before, but when I logged back in to Mobile Me the Yahoo sync messages started back up.  After logging out of Mobile Me I then went into Keychain and deleted the item for Yahoo sync.  There were a few Yahoo items, but I deleted ONLY the one named Yahoo sync.  I was then able to log back in to Mobile Me and am able to stay logged in without receiving the Yahoo sync messages.

  • rezwits Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 4, 2012 5:45 PM (in response to Jennifer Marsh)

    This is how I fix this error on my machines.  This error usually occured after I updated a machine to Lion after "Sync Yahoo Contacts" and "Sync Google Contacts" were being used in Snow Leopard.

     

    Basically what I think is happening is that when you first login to your account (on your mac, after upgrading to lion) it ask you "Hey sign up for iCloud."  Most people do this right away, as do I.  Thing is I think iCloud does a bad job disabling these two syncs (well just one actually - Yahoo).

     

    What you need to do is goto Address Book, and PULL down File -> Preferences.  In Preferences click on Accounts.  At this point you probably have iCloud and On My Mac.  Depending on how you want to do a quick backup, you can go to the iCloud tab and turn off the iCloud check mark, you are not loosing your contacts you can enable it again and they will be right there.  It's just basically showing them and hiding them.  After you disable that, you should just have On My Mac (contacts).

     

    Click on a contact and then PULL down Edit -> Select All.  After that PULL down File -> Export Address Book.

     

    I ditched my Yahoo, and you can too.  You can re-import them later if you want (Apple does not recomend syncing with Yahoo and iCloud or anybody else as far as I know, but for now after I exported them, I PULL Edit -> Delete Cards.  This is AFTER BACKING THEM UP.

     

    Then Go back to the Preferences Tab -> On My Mac and click "Syncronize with Yahoo" basically renabling the sync again.  After you sign in, and are done the sync, the sync menu should show, (secret: you could goto Core Services if you want but...) .  It should spin a while and then they are Synced erasing them or not depending on how you feel about your Yahoo contacts.  Remeber you can do this over and over and re-import etc.

     

    After you are done syncing Go back and Turn off the Yahoo Sync again, in Preferences -> On My Mac, then goto the iCloud tab and click on "Enable this Account"

     

    To make a long story short (but you should read this tho for backup) You need to reenable sync then disable sync with Yahoo manually in Lion after a Snow Leopard upgrade.

     

    You should have all your contacts from iCloud right there now.  One extra thing.  PULL File -> Preferences -> General Tab, then click on Default account tab and make sure it is on iCloud.  This way whenever you make changes they will goto you iCloud account.

     

    This should get rid of it (the annoying pop up).  If you goto the sync menu it should say "No Devices Syncing" and stop the pop-up.  If you want you can Apple Key Click on the Sync Menu and Drag it away to trash it.

     

    Laters... and Lagers it's the Weekend with NBA even the games kinda suck...

  • Peterfleisch Calculating status...
    Currently Being Moderated
    May 26, 2012 11:25 PM (in response to rezwits)

    THANK YOU. I think it worked !

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.