Skip navigation

Contact Names & SMS missing after iOS5 upgrade?

9628 Views 29 Replies Latest reply: May 13, 2012 1:07 AM by andrewwynn RSS Branched to a new discussion.
  • Syd_y Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2011 1:19 AM (in response to Iujaz)

    I have rang applele care, unfortunately they have been no help. What is Apple doing about it... Any ideas.

  • MonsterUnderYourBed MUYB Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2011 3:52 AM (in response to Iujaz)

    There may be a bit more to it than just country numbers.  After the upgrade to iOS5, all contacts that are stored exclusively on the iPhone only (i.e. not sync-ed to anything) can only be accessed as long as you don't make the mistake of going into "groups" - there is no way to just select the internal addresses - Apple seems to have omitted a way to access them. 

     

    The only way you can use your internal addresses is by sending them an SMS (because you will still find the addresses there), at which point you have at least the "call" button..

     

    I've seen this for 2 weeks now and the person who this up somewhere else gets hammered as well, but so far nobody is paying attention.

  • V_RoDer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 14, 2011 4:04 AM (in response to Iujaz)

    What a disappointment! Apple obviously is not reading or listening, despite that it is users forum.

     

    I thought the problem will be fixed with the latest iOS 5.0.1, but it is not!

  • StrokerAce12 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 14, 2011 1:41 PM (in response to V_RoDer)

    I just tried a solution I found on this this thread: https://discussions.apple.com/thread/3388685?start=30&tstart=0 which seems to have worked so far for my phone.  All I did was the following:

     

    • Step 1: Call *228 and select option 1 to update your phone;
    • Step 2: After your phone is programmed, double-tap your home button which will show you the multi-tasking bar and kill the Phone App by holding down on the Phone App icon until you see the minus sign and then select the minus sign to close the Phone App (NOTE: I killed all of the apps that showed up so if you kill just the Phone App and it doesn't work, maybe repeat the above and kill all of the apps);
    • Step 3: Select the home button once which closes the multi-tasking bar and let your phone set a few minutes (it took about 3-5 minutes before my phone history and other items synced to show the Contact name instead of the phone numbers).

     

    Amazingly, this simple process seems to resolve the issue for instant messages and incoming phone calls.  I hope Apple resolves this very serious bug in their software as it appears this bug has existed ever since the iPhone 4 was released and I expect it will pop up again for me eventually (at leaset I will know how to fix it quickly). 

     

    I believe it is important for everyone to bring this issue to Apple's attention otherwise this bug will never get fixed and we will all continue the experience this problem.  In the meantime, I hope the above solution helps someone at least temporarily until Apple figures out this bug.

  • Azzan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2011 7:40 AM (in response to Iujaz)

    Same issue here, and it is ******* me off + iMaf ur solution seems very resonable but am still facing the same issue.

    though i have looked in the Internet it seems that there is an app in 'Cydia' that can solve this issue, though i dont know if its legal to talk about that in here, hope apple realizes the problem and fix it in their next software update.

  • Gobs Level 1 Level 1 (105 points)
    Currently Being Moderated
    Nov 24, 2011 7:49 AM (in response to Azzan)

    Did you try this ?   

     

    Settings > Phone > International Assist    -    switch to off

  • zombiefly13 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2011 7:52 AM (in response to Azzan)

    are your games still on there then u may have clicked restore by acedent if your games are still there then it was probably just an itunes error if your backed up your iphone to your computer then it should have them in the devices in prefrences then just restore it from the last back up and all of your items willl be back with the current iOS 5.0.1

  • ahmed_mh1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2011 10:05 AM (in response to Iujaz)

    I have resubmitted a bug report again to apple through the following link (www.apple.com/feedback/iphone.html). Please visit that link and submit a bug report describing that problem, and ask all the people you know who have the same problem to do the same. Maybe Apple will listen this time and solve this issue within their next update for ios 5.

  • V_RoDer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2011 6:28 PM (in response to Gobs)

    Gobs: there is no International Assist option under Settings>Phone?

  • Gobs Level 1 Level 1 (105 points)
    Currently Being Moderated
    Nov 24, 2011 9:30 PM (in response to V_RoDer)

    Well i have it there

    phone.PNG

  • Second MUYB Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 14, 2011 5:21 AM (in response to Gobs)

    Interesting - I don't even have that switch..

     

    I notice with interest that everything Apple now does is tied to using their iCloud services.  There are numerous problems with that approach, not the least of them that there are many, many people who do not want their private data to reside with a US based company (due to widespread abuse of such private information).  To be fair, Apple has to date not abused the information it gets (unlike other US organisations), but it has already prompted questions by forcing people to offer location information before the remote killswitch service is available - under EU privacy laws that is termed "coercion" and is not permitted.

     

    Anyway, back to topic - I fear that the iCloud focus has caused Apple to overlook those who like to keep a degree of control over their personal data by NOT using it, and their engineering has consequently not properly checked what happens to iPhones that do not use that service.  I cannot see any other reason for the problems - their engineering tends to be far better than this.  Let's hope they address this soon, I had to bounce my contacts off an Exchange server to make them work again..

  • eanushka Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2011 10:53 PM (in response to Iujaz)

    I am from Sri Lanka and I also have the same issue. I bought this from Singapore and saved all contacts with the country code. In text messages, i can see the contact name but not in incoming calls. This is very disturbing and need a solution immediately.

  • V_RoDer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 1, 2012 2:33 AM (in response to Iujaz)

    Follow up from Apple after reporting the bug:

     

    This is a follow up to Bug ID# 10440405.  After further investigation it has been determined that this is a known issue, which is currently being investigated by engineering. This issue has been filed in our bug database under the original Bug ID# 10288871. The original bug number being used to track this duplicate issue can be found in the State column, in this format: Duplicate/OrigBug#.

     

    Thank you for submitting this bug report. We truly appreciate your assistance in helping us discover and isolate bugs.

     

    Best Regards,

     

    Apple Developer Connection

    Worldwide Developer Relations

  • Hadi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 11, 2012 11:45 AM (in response to FirasAR)

    Until Apple decides to release the new update to fix the problem, try out this FREE iphone app which will solve the name issue the IOS 5 in Kuwait for now:)

    http://itunes.apple.com/us/app/ninesixfile-lite/id492457667?mt=8

  • andrewwynn Level 1 Level 1 (55 points)
    Currently Being Moderated
    May 13, 2012 1:07 AM (in response to Iujaz)

    I had this problem since i restored my iPhone 4 onto my iPhone 4s. turned out to be a corrupted address book database on the phone.

     

     

    deleting the database @ /Users/Library/AddressBook (all files starting with AddressBook) (while Addressbook NOT running and when iCloud sync and iTunes sync both off) and re-run address book to create empty database before re enable sync solved it!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.