Skip navigation

Aperture 3.2.1 crashing constantly

1570 Views 23 Replies Latest reply: Aug 3, 2012 2:25 PM by tscacro RSS
1 2 Previous Next
Rochester Karl Calculating status...
Currently Being Moderated
Nov 13, 2011 12:51 PM

I know version 3.2.1 wa supposed to solve crashing but instead it is causing it. I have done all the steps here http://support.apple.com/kb/HT3805 including deleting and re-installing Aperture itself and after being open for a few seconds it ALWAYS crashes. The error message I get is:

 

 

Untitled.png
I am at my wits end and at this point would love to just be able to open it long enough to export my pictures and go back to Lightroom if I have to. Any help would be greatly appreciated.
iMac, Mac OS X (10.7.2), 4GB RAM 2.4GHz Core 2 Duo
  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Nov 13, 2011 2:27 PM (in response to Rochester Karl)

    Post the first 50 line only of the crash report

  • SierraDragon Level 4 Level 4 (2,665 points)
    Currently Being Moderated
    Nov 13, 2011 3:50 PM (in response to Rochester Karl)

    If your Mac can take more RAM add it. Also make sure no drive is more than about 2/3  full.

     

    -Allen

  • specialk67 Calculating status...
    Currently Being Moderated
    Nov 13, 2011 5:06 PM (in response to Terence Devlin)

    Here is the beginning of the crash report

     

    Untitled.2png.png

  • tscacro Calculating status...
    Currently Being Moderated
    Nov 14, 2011 6:36 AM (in response to Rochester Karl)

    Karl,

    How much room do you have on your hard drive? I am having  similar problems (imac24 duo 10.6.8) and suspect my lack of space <5GB could contribute. I only have 3GB Ram as well. Using 3.2.1 Aperture.

  • specialk67 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 14, 2011 7:30 AM (in response to tscacro)

    Space is certainly not a problem-I have a 1TB drive with 857GB free. Overnight I deleted and re-installed it again with no luck, still crash city. I have also run all the various Drive Genius tools to check the integrity of my drive and everything checks out fine.

  • Mr_Shmelo Calculating status...
    Currently Being Moderated
    Nov 14, 2011 2:06 PM (in response to Rochester Karl)

    Same problem here!

     

    I have MBP 2011 and Aperture is crushing all the time.

     

    I tried reinstall Aperture and even reinstall OSX Lion!!!!! but still it's crush after 1-2 min.

     

    I can not eford spending so much time on this problem and i am thinking moving back to Lightroom...

     

    some one pleas help us, i am a student and in few days i must export some pic's for school.

     

    sorry for my bed english. Hope you all understand me.

  • Mr_Shmelo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2011 7:52 AM (in response to Mr_Shmelo)

    few things i understand whille tring to fix the problem:

     

    1. opening a new database solved the problem, but now i dont have my old pics.

    2. remove the last month projects didnt solve the problem.

    3. rebuild database didnt solve the problem.

     

    I dont think this is a database problem, allthow opening a new database solved the problem.

     

    pleas pleas help me. I am so disapointed from aperature but since it's an apple prodact now i cant go back to lightroom (cant exsport 20,000 pics and then arrange them and edit them again).

     

    thanks in advanced

  • tscacro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2011 10:15 AM (in response to Mr_Shmelo)

    Mr. Shmelo

    I am currently trying to get help on this from the Aperture feedback group. I have been giving data to them as requested. They are working this issue and I am sure that it will be resolved soon, in the meantime, we are stuck. I will let you know as soon as they give me a reasoned response for a solution.

  • tscacro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2011 10:19 AM (in response to specialk67)

    Specialk67

    I see that you are correct on the space issue, I freed up half or more of my drive and no effect at all. I am giving data to the Aperture feedback group as they request it and expect help to be on the way. Stay tuned!

  • Mr_Shmelo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2011 12:29 PM (in response to tscacro)

    thank u for the replay. if you need anything regarding to this problem from me, dont be afraid to ask.

     

    as for now we all waiting for apple to replay.

     

     

    thank u agian, i hope this problem will be fixed soon - before they will kick me out of school ;-)

  • Mr_Shmelo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2011 9:45 AM (in response to tscacro)

    Are there any news from Apple?

  • alice_srq Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 27, 2011 8:15 AM (in response to Mr_Shmelo)

    I was having this problem.  It started after I rebuilt permissions, database, and library because duplicate copies of pictures were showing up in projects for no apparent reason.  After rebuilding everything Aperture first would relentlessly process.  Then it began crashing and crashing and crashing.  I deleted the plist files to no avail.  What seems to have solved the problem for me was reinstalling the last upgrade (3.2.1).  Aperture has been quite stable now for a couple of hours and I hope I'm not jinxing things by sending this message.

  • tscacro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2011 2:55 PM (in response to alice_srq)

    Alice;

    All my problems began after I installed the last reccomended update for A3. Had no problems til that point in time. I am still waiting for a reply from Apple, as I have given all the data they have requested and the "engineers" now have possesion of such. I hope your A3 continues on the path to wellness, mine is suffering considerably.

  • tscacro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 8, 2011 6:17 PM (in response to Rochester Karl)

    Karl    http://support.apple.com/kb/DL1463   This link may help. It was posted Dec 8 as a fix to A3 and those crash problems. I have downloaded this "fix" but do not know yet if it solves all the problems. Here's hoping they got it right. This Makes A3 3.2.2 with this download.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.