Skip navigation

Wifi Constantly Dropping in Lion

522101 Views 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR RSS Branched to a new discussion.
  • cmaglio Calculating status...
    Currently Being Moderated
    Nov 27, 2011 7:12 PM (in response to lhale)

    Im having the exact same problem with 2011 11" MBA and Lion... except turning the WIFI "Off" and "On" does not fix the problem. I actually have to restart the computer for it to work again. If I turn the WIFI "Off", the computer will not let me turn the WIFI back "On" until I restart.

     

    It is the most annoying problem I have ever experienced with a computer. Restart every 10min to maintain an internet connection. And this is happening for months with no fix. Biggest waste of money... I don't even use the MBA because of it. Fix this Apple!

  • John Zuill1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 27, 2011 7:17 PM (in response to cmaglio)

    Open "Network diagnostics." Find the icon in your dock. Click and hold until the menu pops up. Select options and then "keep in dock." Now when ever you loose a connection, open network diag. and go through the process till it the network reconnects. I don't ever get the whole way through. The network comes back up fairly quickly. Annoying but easier than what you're doing.

  • Snoop Dogg Level 4 Level 4 (1,265 points)
    Currently Being Moderated
    Nov 27, 2011 7:24 PM (in response to ubermick)

    OK, the next time this happens, open the Terminal application in the Utilities folder and type or paste the following three commands and hit return and then post the results from those commands.

     

    ifconfig

    dig www.apple.com

    dns-sd -Q www.apple.com

  • cmaglio Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2011 7:35 PM (in response to John Zuill1)

    Go through what "process" to reconnect? I havent found anything that works other than completely restarting the computer...

     

    BTW this was the result of my ifconfig when the problem occurred (happens every 5-15min):

     

    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384

              options=3<RXCSUM,TXCSUM>

              inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1

              inet 127.0.0.1 netmask 0xff000000

              inet6 ::1 prefixlen 128

    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280

    stf0: flags=0<> mtu 1280

    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

              ether 28:37:37:1c:5b:2e

              inet6 fe80::2a37:37ff:fe1c:5b2e%en0 prefixlen 64 scopeid 0x4

              inet 192.168.1.254 netmask 0xffffff00 broadcast 192.168.1.255

              media: autoselect

              status: active

    p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304

              ether 0a:37:37:1c:5b:2e

              media: autoselect

              status: inactive

    utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380

              inet6 fe80::2a37:37ff:fe1c:5b2e%utun0 prefixlen 64 scopeid 0x6

              inet6 fd00:6587:52d7:851:2a37:37ff:fe1c:5b2e prefixlen 64

  • Snoop Dogg Level 4 Level 4 (1,265 points)
    Currently Being Moderated
    Nov 28, 2011 10:51 AM (in response to cmaglio)

    OK, but what about the results from the other two commands?

     

    dig www.apple.com

    dns-sd -Q www.apple.com

  • leeroyb Calculating status...
    Currently Being Moderated
    Nov 28, 2011 11:25 AM (in response to Snoop Dogg)

    I just searched for software updates and there was a firmware update.  Updated and now I don't have the issue.

  • cmaglio Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2011 5:27 PM (in response to Snoop Dogg)

    dig www.apple.com

    ; <<>> DiG 9.7.3-P3 <<>> www.apple.com

    ;; global options: +cmd

    ;; connection timed out; no servers could be reached

     

    dns-sd -Q www.apple.com

    Timestamp     A/R Flags if Name                             T   C Rdata

    20:17:41.997  Add     2  0 www.apple.com.                   1   1 184.86.45.15

  • cmaglio Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2011 5:31 PM (in response to cmaglio)

    It just took me 4 restarts to post that information. My WIFI connection kept dropping by the time I got to this website to post the information. This is extremely annoying.

     

    Sometimes I can go an hour without it dropping out, but most of the time it is within 10-15 minutes of booting. Rarely, as in the past few reboots, it drops within just a couple of minutes.

  • Snoop Dogg Level 4 Level 4 (1,265 points)
    Currently Being Moderated
    Nov 28, 2011 6:25 PM (in response to cmaglio)

    Bummer.  OK, can you open the Console application in the Utilites folder and select "All Messages" in the sidebar and then type "AirPort" in the search field in the upper right corner.  Then select all the logs and copy them, and then post them here.

  • _mc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 29, 2011 1:44 AM (in response to Snoop Dogg)

    29.11.11 10:17:56.000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).

    29.11.11 10:17:57.000 kernel: AirPort: Link Up on en1

    29.11.11 10:17:58.214 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:17:58.228 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:18:02.067 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:18:03.411 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:21:18.000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).

    29.11.11 10:21:25.000 kernel: AirPort: Link Up on en1

    29.11.11 10:21:26.133 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:21:26.148 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:24:05.000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).

    29.11.11 10:24:08.000 kernel: AirPort: Link Up on en1

    29.11.11 10:24:08.602 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:33:31.000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).

    29.11.11 10:33:33.000 kernel: AirPort: Link Up on en1

    29.11.11 10:33:33.769 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:35:42.000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).

    29.11.11 10:35:45.000 kernel: AirPort: Link Up on en1

    29.11.11 10:35:46.208 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:38:55.000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).

    29.11.11 10:39:04.000 kernel: AirPort: Link Up on en1

    29.11.11 10:39:04.665 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

    29.11.11 10:40:48.000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).

    29.11.11 10:40:52.000 kernel: AirPort: Link Up on en1

    29.11.11 10:40:52.450 airportd: _doAutoJoin: Already associated to “public-bfh”. Bailing on auto-join.

  • DrVenture Level 2 Level 2 (180 points)
    Currently Being Moderated
    Nov 30, 2011 11:19 AM (in response to _mc)

    Interesting. Can you make sure you are connected to your AP then open a terminal and copy and paste the following commands (one at a time)?

     

    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -s

    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -I

     

    Then post the output?

  • zeljkofromzupanja Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2011 12:36 PM (in response to lhale)

    I found the solution. I enter my router settings and in firewall options turned off ( unchecked ) IP Flood Detection . Really tried with it or without it and that seems to be the problem. I hope that this post will be seen by APPLE and will be fixxed in another update so i don't have to turn that off. Hope it's nothing dangerous turning it off.

  • PINKCANDY Calculating status...
    Currently Being Moderated
    Nov 30, 2011 3:40 PM (in response to lhale)

    Hello,

     

    I did search yeterday about a new upgrade from 10.7.2 to 10.7.3 and about what it will address.

     

    This 10.7.3 is already available for developpers and should go out eventually.

     

    It will address the wifi problem.  It is clearly writen.

     

     

    On my side, 10.7.1 was worst than 10.7.2, but I still lose all wifi connection and even worst I have to restart and not only the session but the computer, otherwise It does not recover.

     

    More, all sofware that need connection will not work.

     

    So on my side, I will not try the beta version of 10.7.3 and I will wait for it.

     

    Bye

  • torndownunit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2011 8:43 AM (in response to PINKCANDY)

    I am participating in another thread, but this seems to be the 'mother' of all Lion WiFi threads.

     

    I have tried a bunch of the fixes, but the most they do is help the signal drop a little less frequently.  EG every 20 minutes instead of every 10 minutes.

     

    Since I have today open to try to dedicate to this problem I have been experimenting.   I have my Macbook with Snow Leopard on it right beside me, and anytime the iMac with Lion goes down, I check the MacBook... no issues with it.  It's online and working fine each time.

     

    I have been happy with every Apple product I have purchased over 15 years.   This experience with this new iMac and Lion have been extremely dissapointing (bought it last week).

  • jimpal Level 1 Level 1 (35 points)
    Currently Being Moderated
    Dec 1, 2011 2:37 PM (in response to torndownunit)

    I've tried just about every fix on this thread, yet dropped wi-fi has persisted on my iMac. I don't understand why it should be so, but one thing seems to be working for me: turn off Time Machine and just activate it manually from time to time.

     

    I am using Time Machine wirelessly with a Time Capsule. My theory here is that when Time Machine automatically starts a backup, somehow this disturbs my wireless network in way that it causes this problem on my iMac.

     

    My wife has Lion installed on her MacBook, and wi-fi remains rock solid for her all the time. The only difference between her MacBook and my iMac is that I run Time Machine wirelessly on the iMac and she does not on her MacBook.

     

    Naturally this needs an Apple fix. Possibly this might work for you in the interim.

1 ... 64 65 66 67 68 ... 152 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (82)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.