1 2 Previous Next 22 Replies Latest reply: Dec 4, 2011 11:07 PM by A H1 Go to original post
  • 15. Re: Airport Extreme won't restart
    93fd3s Level 1 Level 1 (0 points)
    Thanks, Bob. I'm on a win7 PC so I don't see some of the things you mentioned such as the apple icon or an option key on my keyboard. However, your instructions caused me to THOROUGHLY explore all the menu items in the windows version of the airport utility and though there are at least three ways to bring up the "upload firmware" window only one of those ways displays the full list of firmware versions. Needless to say I am rolled back to 7.4.2 and enjoying smooth sailing once again, step-daughter's iPhone4 is now on my network...life is good!

    Again, thank you for your help!
  • 16. Re: Airport Extreme won't restart
    InZAX Level 1 Level 1 (0 points)
    Hi Jeffrey and others,
    Same rebooting problem here. Very frustrating! I bought my Airport Extreme with 7.4.2 on it, so downgrading from 7.5.2 requires the firmware file since I never downloaded it to my Mac. Can someone share the 7.4.2 firmware file if it's not too big? Maybe via dropbox?

    Thanks,
    Chris
  • 17. Re: Airport Extreme won't restart
    naql Level 1 Level 1 (0 points)
    I finally got around to doing as you suggested. I exported the config, reset the base unit back to default settings, connected directly via ethernet cable, restored the configuration, edited the MAC access tables by deleting several entries and modifying another, saved and restarted and, voila! My changes were there when the base station restarted.

    I then added another entry to the MAC access table and updated it again... and, the problem was still there: the airport base station light stayed green, eventually I got a dialog saying the base station could not be found. I pulled the plug and recycled the base station and it came back up minus my newly added entry.

    Just to get it over with, I repeated the first procedure and added the entry. The only oddity was that after restoring to defaults, the base station did not come back up until I cycled the power, but the defaults were indeed restored. I then restored my config settings again, added the final MAC access entry and restarted.

    So, there does indeed seem to be a problem with this version of the firmware. I don't think I'll have any more changes to make for a while, so I'll wait for Apple to drop a patch fix when they deem us worthy.
  • 18. Re: Airport Extreme won't restart
    InZAX Level 1 Level 1 (0 points)
    This firmware is junk, and no option to download the older (working!) firmware.

    As for another workaround, here is what I did. Since the first import of the config file actually works...

    1. Back up the config file
    2. Hard reset the device
    3. Edit the config file in TextEdit and add in the new MAC addresses that I wanted to give access (I use timed access control via MAC address)
    4. Import the file back into the Airport Extreme

    The crappy part is that if I ever want to add or remove a new MAC address, I have to hard reset the device, re-edit the config file, and re-import.
  • 19. Re: Airport Extreme won't restart
    colebg Level 1 Level 1 (0 points)
    Bob,

    Thanks for the info. I was having the same problem as everyone else and was able to successfully roll-back to 7.4.2 and it's working great again! Thanks for taking the time to post clear step-by-step details, it's much appreciated.

    Ben
  • 20. Re: Airport Extreme won't restart
    A H1 Level 1 Level 1 (40 points)

    Thanks Jeffrey,

    I ran into this problem, and was very glad to find this thread!  I thought I had accidentally broke something.  I was trying to debug one of client WiFi problem and was trying different configurations on my AEBS and restarting numerous times in 94F 55%RH environment---probably hotter since the AEBS is on the second floor and A/C was off and the base station was running really hot to begin with.  major heatwave here...), and all of a sudden it stopped updating new setups.. and I was starting to panic...

     

    I managed to roll back to 7.4.2, and voila.  back to normal function.  have just told everybody in our household to never update the firmware...  whew.

  • 21. Re: Airport Extreme won't restart
    J. Stein Level 1 Level 1 (0 points)

    I had this exact problem, and rolled back to 7.4.2 after reading this thread (very helpful btw)  so this week apple release 7.6 version of the firmware, anybody still doing Mac Address Access filtering upgrade yet and tried to add an address.  in other words does 7.6 still have the issue?

  • 22. Re: Airport Extreme won't restart
    A H1 Level 1 Level 1 (40 points)

    I don't know what v7.6 would add, but I think in this case, "if it ain't broke, don't fix it" applies. 

     

    Only way to know is to try, and since I'm pretty happy with the current firmware, I think i'm going to just keep it.

     

    but if you do decide to test the new firmware, make sure you (1) save your current configuration in a backup, (2) make sure you're ready to roll back to 7.4.2 quickly, and (3) don't do it if you need the network for some critical use in the immediate 24-48 hrs, just in case you run into problems...

1 2 Previous Next