Skip navigation

can't download apps over wifi at home on iPhone or iPad

14177 Views 21 Replies Latest reply: Jul 10, 2013 8:46 AM by jivesph RSS
1 2 Previous Next
adriandz Calculating status...
Currently Being Moderated
Nov 8, 2011 6:02 PM

On both my iPhone 4S and my iPad, I can no longer download apps from the App Store on either device on the wifi at my home, although at some point, doing so on my iPad worked fine.  I don't recall it ever working on the iPhone 4S, so maybe the commonality is IOS5, which I recently updated the iPad to.

 

However, I can download apps just fine on my iPhone over 3G, and I can download apps just fine on both my iPhone and my iPad using the wifi at my office.

 

Also, on both devices, I can surf the net, and I can also access the App Store itself - I just can't upgrade any existing apps, or download any new ones.  When I try to do so, I get a message that says "Unable to Download Application.  'App_Name' could not be downloaded at this time."  Basically, any net-dependent activity is fine, with the exception of downloading and upgrading apps, which as I'm sure you can understand, is extremely frustrating.

 

I have restarted the devices, restarted my modem, restarted my router, etc., to no avail.  I've googled around for other people with this problem but it does not appear to be common, and I really have no idea what to do next.  Any help would be appreciated.

iPhone 4S, iOS 5, Also, a first-generation iPad
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.