Skip navigation

version 2.2 hanging at Initializing MIDI

2578 Views 33 Replies Latest reply: Dec 15, 2011 12:26 PM by lschefman RSS
1 2 3 Previous Next
michaelhuisman Calculating status...
Currently Being Moderated
Dec 9, 2011 6:32 AM

I saved version 2.1.3 in the Applications folder just in case.

 

v2.2 has loaded twice, the twenty other times I've tried to start it, it hangs... 32-bit or 64-bit doesn't matter.

 

v9.1.6 of Logic Pro is not having a problem with my setup

 

strangely, neither is v2.1.3 of MainStage.

 

I've trashed the prefs, checked the setup in Audio/MIDI setup... all the usual stuff.

 

Anybody else seeing this?

  • Blueberry Level 4 Level 4 (2,825 points)
    Currently Being Moderated
    Dec 9, 2011 8:00 AM (in response to michaelhuisman)

    What MIDI Hardware do you have connected? Some driver issue?

  • Blueberry Level 4 Level 4 (2,825 points)
    Currently Being Moderated
    Dec 9, 2011 8:18 AM (in response to michaelhuisman)

    Did  you figure out which device/driver triggered that issue?

     

    Regarding MS 2.2: The table view for all active mappings (concert/set/patch level) is brand new. It also allows you to create a mapping/assignment without a screel control, which is what you ask for: control a plugin parameter without going through screen objects first.

  • aerol Level 3 Level 3 (500 points)
    Currently Being Moderated
    Dec 9, 2011 10:15 AM (in response to michaelhuisman)

    When you say you 'saved version 2.1.3' what do you mean.. or maybe, how did you save it?  Reason I ask this is that it seems that the App Store install will seek and update the app not by using the app name (as in the past when if you renamed the app it couldn't be found by the updater). So I'm just wondering if something happened during the upgrade process on the Mac Pro.

  • Blueberry Level 4 Level 4 (2,825 points)
    Currently Being Moderated
    Dec 10, 2011 9:18 AM (in response to michaelhuisman)

    Try contacting Apple via www.apple.com/feedback/mainstage.html - you should attach the spindump to it.

  • Blueberry Level 4 Level 4 (2,825 points)
    Currently Being Moderated
    Dec 10, 2011 10:13 AM (in response to michaelhuisman)

    I totally get your frustration, but you seem to be the only one with a hang at launch while initializing MIDI, so there must be something special to your setup. The trick is to find out what! Can you post the spindump here and reference to it in the feedback - I am sure the Apple guys will find it that way, too.

  • Bobfrompowell Calculating status...
    Currently Being Moderated
    Dec 10, 2011 5:19 PM (in response to Blueberry)

    I'm having the same problem. if my midi interface is turned off, Mainstage comes up ok. With the midi interface turned on the initialization hangs. Everything worked fine before the "update."

  • Blueberry Level 4 Level 4 (2,825 points)
    Currently Being Moderated
    Dec 10, 2011 5:43 PM (in response to Bobfrompowell)

    What MIDI interface do you have?

  • Bobfrompowell Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 10, 2011 5:53 PM (in response to Blueberry)

    I have a Midisport 8X8/s. it worked with Mainstage 2.1, and still works with Logic. Thanks

  • aerol Level 3 Level 3 (500 points)
    Currently Being Moderated
    Dec 10, 2011 6:01 PM (in response to Bobfrompowell)

    If you have Console app launched (Applications/Utlities) when you launch Mainstage does anything about MIDI get printed in there?

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.