1 2 Previous Next 23 Replies Latest reply: Oct 30, 2012 11:52 AM by patrickm1965 Go to original post
  • 15. Re: I have messed up/hidden tooltips
    shuttersp33d Level 4 Level 4 (1,540 points)

    Yes, should be empty. Was just checking to see if there was something in there causing the issue.

  • 16. Re: I have messed up/hidden tooltips
    yesinndeedy Level 1 Level 1 (0 points)

    Thanks for the suggestion. I just toggled the tooltips as you suggested and to no avail. Still wonky tooltips. I just ran Software Update and it delivered Aperture 3.2.2 which made me hopeful. But the problem still exits. I would re-install Aperture but, I doubtful about that as Aperture behaves as expect when using other user accounts on the same computer. It is a lengthy effort for sure. I get the same wonky behavior when using a new Aperture library w/o images. Must be something to do with my account but what? That is the question. Is this the kind of thing Apple Care could resolve? I have Aperture on another computer (i have an iMac and MBP) and everything works fine on the MBP. My user accounts are very similar on both, meaning I have similar things installed.

  • 17. Re: I have messed up/hidden tooltips
    Frank Caggiano Level 7 Level 7 (23,795 points)

    How desperate are you to fix this? Searching the web this problem for a very few people has been going on since at least 2009. I was not able to find any definitive resolutions but as you say the problem doesn't happen with a new user account but does happen with a new library your account does give us some place to look. However the process is going to be a long one (unless you get lucky) .

     

    So if you're interested in a nutshell here's what you do:

     

    First thing i you haven't already run Font Book and cleaned up your fonts do that first. Re-boot machine and run Aperture. Is it fixed? If so I'm a genius (who should have thought of that a while back) If not continue.

     

    Because it doesn't happen to a new user it would indicate a problem somewhere in your environment. The most likely place is somewhere in your preferences. Of course which one there a lot of files in the Preferences folder. You could make some logical guesses and remove those but that could take a really long time. So fist step is:

    • Remove ALL the files from your Preferences folder (remember we're troubleshooting so hang in  there)

     

    Now with the  Preferences folder empty re-boot the machine and log in. You'll be in a clean environment as if you just installed the OS. Now:

    • Run Aperture and (hopefully) the tool tips are OK

     

    If you wanted to recreate everything from scratch you could stop here and as you run programs just recreate their preferences. But if you want to figure out what happened (or have to many preferences to recreate) continue.

     

    • Add back half the files from the original Preferences. Make sure you keep track of the files you're adding back
    • Re-boot, run Aperture check tool tips.

     

    If they still work add in the second half, repeat as above (re-boot, run Aperture, results?)

     

    Hopefully they stopped working then its a question of removing half the just added files and seeing if the tool tips work, etc. I think you can see the general plan here. You're trying to get it down to that one preferences file.

     

    Now there are two ways this can fail (only two?!) One is if when you empty the Preference folder the first time and run Aperture the tool tips are still messed up. The other is if the problem is caused by an interaction between two (or more) preferences files.  Lets be optimistic for the time being and assume the problem is caused by a single preference file in your Preferences folder.

     

    let me know if you decide to do this. Really would love to know what's casuing it.

     

    regards

  • 18. Re: I have messed up/hidden tooltips
    yesinndeedy Level 1 Level 1 (0 points)

    Bravo Frank, tooltips are back. And my machine is chugging away building new plist files. I'll check after they are all rebuilt and provide a report if tooltips go wonky again.

     

    Not sure which is easier - the binary search for the offending plist file(s) or just redo my preferences as I use the applications from this point forward. I may just add the ones that I care about the most, one at a time and see how that goes. Do you see anything wrong with that strategy. After pondering this I am thinking that the problem started after I installed Lion from the app store. I installed Lion a few weeks (not exactly an earlier adopter) ago and I don't think I've used Aperture since the "upgrade". I know Aperture was working properly when I was using SL.

    Thanks for you help. I did not realize plist files could have such an impact on application rendering.

     

    Cheers

  • 19. Re: I have messed up/hidden tooltips
    Frank Caggiano Level 7 Level 7 (23,795 points)

    Glad you got it working finally. Nothing wrong with recreating the preferences as you need them, just keep an eye on Aperture as you do it to make sure it doesn't go out again. Of course I would love to know what is causing this but I can understand you're wanting to get on with it.

     

    I don't think Lion had anything directly to do with this, as I wrote there are reports of this at least back to 2009.

    If you do mangabe to narrow it down let us know.

     

    regards

  • 20. Re: I have messed up/hidden tooltips
    yesinndeedy Level 1 Level 1 (0 points)

    Well not such smooth sailing in the Preference recovery department. I got this message hundreds (at least they would not go away) of times:

     

    Screen Shot 2011-12-09.png

    and no my disk was not even close to full. I managed to restart the computer and these messages went away. I ran plutil -s *.plist on my old preferences and found one plist that was bad. Nothing related to Aperture. I restored a bunch of the perference files for things that I care about ... mail, safari, ical, address book, etc... All is fine with Aperture now. Thanks. I am keeping my old preferences folder on the Desktop for awhile incase i encounter some unhappiness.

    Thanks Frank for your suggestions!

    Cheers

  • 21. Re: I have messed up/hidden tooltips
    youngjm Level 1 Level 1 (0 points)

    I was having the same issue and was able to find the offending entry and file.   The file that has the error is in the ~\Library\preferences\ folder it is ".GlobalPreferences"  It is a hidden file and in my case, It did not get deleted/moved when I tried clearing out my prefernces.  The specific entry that is the issue is "NSToolTipAutoWrappingDisabled"  This needs to be set to True. 

     

    I use a prefpane "Secrets" and found the "Enable Tooltip Auto Wrapping" under the System/Tooltips options.  I must have unchecked this by accident in the past.  Checking it then resarting Aperture caused all my tooltips to reapear.

     

    Hopefully this helps someone else.

  • 22. Re: I have messed up/hidden tooltips
    pimsnel Level 1 Level 1 (0 points)

    Thanks for this exact solution. I also have Secrets and must have disabled this setting. This bug annoyed my for more then a year now. Kuddo's.

    Pim

  • 23. Re: I have messed up/hidden tooltips
    patrickm1965 Level 1 Level 1 (10 points)

    This solved my problem! It's a Halloween miracle! Thanks for that tooltip tip!

1 2 Previous Next