Skip navigation

Disable iTunes Autoplay After Importing a Song

31794 Views 40 Replies Latest reply: Apr 3, 2014 1:06 PM by Chris CA RSS
1 2 3 Previous Next
pinkluxe Calculating status...
Currently Being Moderated
Feb 21, 2011 9:07 PM
Every time I drag and drop a song into iTunes to import it, it automatically plays the songs. Is there any way to disable this feature? All I want to do is import the song, not have it play after importing.

I know there were preferences to enable/disable this option is previous iTunes versions, but I have searched far and wide for a way to disable it and the few methods I found all seem to ENABLE it (which is seems to already be the default setting for me). Any way to turn this feature OFF?
Mac OS X (10.6.6)
  • nveer Calculating status...
    Currently Being Moderated
    Feb 22, 2011 4:52 PM (in response to pinkluxe)
    I would love to know how to do this too. I thought there used to be an option in prefs. but can't find it anymore. Is there a terminal command to turn this on and off?
    Mac Pro 8 Core, Mac OS X (10.5.6), FCS 3
  • nveer Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 10, 2011 4:22 AM (in response to pinkluxe)
    Same thing here. I downloaded the script but it only has an option to enable it, not to disable it. Anyone have a solution?
    Mac Pro 8 Core, Mac OS X (10.5.6), FCS 3
  • alibearo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2011 4:49 PM (in response to nveer)
    This has been driving me absolutely bonkers for 3 months. I have googled and read every thread I could relating to this issue. Doug's AppleScripts did not work for me either.
    Macbook Air, Mac OS X (10.6.6)
  • I.V.A. Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2011 8:36 AM (in response to pinkluxe)

    I have the same problem. Also with movies. I add movie to iTunes not to watch it right there, cause I can do it in QuickTime without adding to iTunes. I add movie to iTunes to sync it to iPad/iPhone to watch later. And I get really anoyed with iTunes autoplaying every movie I add.

    How can't Apple understand that we need the option to disable autoplay.

  • SilentMountain Calculating status...
    Currently Being Moderated
    Aug 9, 2011 12:18 PM (in response to pinkluxe)

    Ok, so this is super hack-ey, but I stumbled across this by accident.

     

    If you leave iTunes' preferences open, iTunes it won't auto-play (because Importing will be temporarily suspended while the Preferences dialog is open).

     

    However, once you close the iTunes Preferences dialog, all the items that had been downloading in the background will suddenly start importing themselves.

     

    Of course auto-play starts at this point, but if you are queueing up a bunch of downloads, at least they won't all play one by one as they are downloaded...

     

    I imagine if you were to batch drop a bunch of songs on iTunes, you could pop up the Preferences before the first track gets imported and get the same result.

     

    Like I said, a hack, but it works...

  • BrennanBones Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 9, 2011 12:06 PM (in response to pinkluxe)

    I had been wondering the same thing.  I get iTunes Season passes, but I put the episodes on an external harddrive afterwards.  As my music still resides on the computer, but the movies/tv shows reside elsewhere, once I've moved the episodes to the external drive, I need to drag them back in iTunes for them to appear.  Lately, I've had the same problem; they'd start playing automatically when I did that, which was annoying the heck out of me.

     

    And I did notice that I had been doing something different when importing.  Something that if I didn't do, it worked without autoplaying what I imported.

     

    Tell me, those of you that have this problem, when you import music or videos into iTunes, do you drag and drop on the icon in the dock?  If so, that might be the problem.  When I dragged it to the dock, it started playing automatically.  When I had iTunes open and dragged the songs/videos into the iTunes window itself, it didn't start playing automatically.

     

    I have no idea why it does that, and if it'll work for any of you, but try dragging and dropping directly in iTunes instead of on it's dock icon. 

     

    I know I was getting extremely annoyed of having to stop the video every time just to import a few more and having to stop them all.  Maybe this will save someone else from being annoyed about it.

     

     

    what do you try to import that has it autoplay, and how do you import it when it does autoplay?  I dragged a few songs on my Windows iTunes, and it didn't autoplay.  (though I do have Windows 7 and not XP, if that can make a difference). 

  • lachnessmonster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2011 2:18 PM (in response to pinkluxe)

    One way you can get around this is by typing something into the search bar before you add the music. Itunes will add the music without playing it.

  • murphmocha Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 3, 2011 9:42 PM (in response to pinkluxe)

    If you're using a Mac, open Safari go to Preferences under the Safari menu. On the General tab, uncheck "Open safe files after downloading". Seems crazy but it works! This was also driving me crazy when I imported both music and videos.

  • korifromsouth elgin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2011 7:30 PM (in response to pinkluxe)

    The most consistent way I've found to solve this is to drop your files into the "Automatically add to iTunes folder."

     

    How I do it on a Mac:

     

    1. Navigate to Music/iTunes/iTunes Media/
    2. Seconday click on "Automatically Add to iTunes"
    3. Select "create alias." - this makes a shortcut, for those who didn't know
    4. Click and drag the new shortcut you just made to your desktop or launchbar or somewhere else where it is more convenient for you.
    5. Drag any new files that you want to add to iTunes onto that from now on, if you don't want them to autoplay.

     

    Good luck!

  • itunesistotalgarbage Level 1 Level 1 (0 points)

    korifromsouthelgin, not everyone wants or can have their music collection in the itunes media folder. I have over 100gb of music spread across multiple folders and hard drives. The drive with itunes on it has only 3 gb free. Do you propose I rearrange my entire organizational structure around itunes?

     

    My issue is even worse. I try to import a folder (which has 13000 tracks) and it starts playing one track, then skips to another after a second, and so on. Every 1-2 seconds IT SKIPS TO ANOTHER TRACK. This is beyond frustrating, it's unacceptible. It's like someone changing the channel over and over again for hours. I cannot even pause or stop it! I have to cancel the importing.

     

    And it's not a bug, but an intentional problem. I did some research on this; prior to verion 8, itunes had an option in the Preferences menu to "Play songs while importing or converting", which you could uncheck. Now this is no longer optional. Worse yet, it's unresolved. There are literally dozens of unanswered discussions about this dating back to 2008, with thousands of readers. How do you think Apple could ignore such a large, obvious problem that thousands of users are complaining about, year after year after year? It's on purpose.

     

    They want everyone to let itunes manage their music libraries. Putting all your music into one stupid folder just for itunes is apparently the only way to stop the glitch. Openness and transparency are for the competitors. Apple doesn't play that way.

     

    It's not a conspiracy, just business. It could and would have been solved years ago if it was supposed to be.

  • BrennanBones Level 1 Level 1 (10 points)

    itunesistotalgarbage, does it do it if you drag the folder to an open iTunes window, like I mentioned above?  I don't keep my collection in the itunes media folder, but rather on an external drive, and so have to import back everything.  But since I've been dragging to the iTunes window instead of the icon in the dock, I haven't had the problem.  But I have to have an iTunes window open, and I have to drag the folder/files from finder to the open window for it to work. The minute I forget and drag it to the iTunes icon in the dock, I'm doomed for it to start playing automatically.

  • itunesistotalgarbage Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2011 9:25 AM (in response to BrennanBones)

    BrennanBones - yes, it happens no matter how I import it. I should mention that I'm using Windows XP, not a Mac. The bug is probably much less aggravating on a Mac, for obvious reasons.

     

    Anyway, problem SOLVED! After much trial and error over several days, I figured out that iTunes 10.3.1 is the last version that will not autoplay! It may have been a problem in older versions as well but I know on my computer, that's the most recent one that works.

     

    Of course, it would be fantastic if you could actually use the controls to play music while it's importing but I guess that's a mighty tall order and I should be happy with what I got.

     

    To downgrade (upgrade), first uninstall your iTunes using these instructions: http://support.apple.com/kb/ht1923. Then, use ByeTunes to clean up all the extra iTunes droppings this spoiled baby left all over your computer, which you can get here: http://remove-it.org/tools/byetunes. Then, get the older, better version of iTunes here: http://www.oldapps.com/itunes.php?old_itunes=82 .

    After you install, make sure to tell it NOT to download the most recent version (which it will ask) and check the "Don't ask me again" box. Voila.

     

    Again, this fix and the links above apply to iTunes for Windows. The process and exact version number may be different on a Mac.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.