Skip navigation

AFP File corruption when copying from Share A to B

3473 Views 30 Replies Latest reply: Aug 8, 2013 7:56 AM by berlindude RSS
1 2 3 Previous Next
berlindude Calculating status...
Currently Being Moderated
Aug 15, 2011 7:15 AM



I've got a MacPro working as Fileserver (10.6.8 Server) for about 10 Clients (all on OS X 10.6.7 and .8) with Adressbook, AFP, DNS, iCal, OD and SMB running.

The Server is connected over 3 bonded GbE NICs to the Network and has a Promise RAID5 SCSI-320 Storage for the Files.


We need to push a lot of big Images (PSD, Tiff, etc.) around over the Network, so this Configuration seemd pretty fast and not too complex. Right now it was working well for over a year (except for minor problems).


Two weeks ago I accidentally found a TIFF-Picture with some 108 x 1 px fields on it where the colors were messed up.


The only thing i've done with it was to copy it from one AFP-Share to another from my MacPro Client. The original File was still there, so I copied it again and got the same result just on other parts of the Picture (no message, nothing in the Logs). Than I tried to copy a PSD File with some Layers in it (about 800 MB) and the result was some kind of Van Gogh painting (means interesting collors, but the whole picture was messed up).


So I started a Testing-Marathon where I checked all the funny stuff like ACLs, POSIX, Cables, Switch, RAM, HDDs, with/without RAID, OSs, OS-Settings, other Clients, direct connetions between the Clients, NIC-Settings, change the … … … I tested a lot different stuff.


Now I can say that the File-Corruption occurs when you use AFP, the two NICs which are communicating send and receive Data at the same time (copy paste between 2 shares) and the Ethernet speed (in activity monitor) is higher than 40 MB/s.

I'm able to reproduce the Corruption with 10.5.7 / 10.6.3, .7, .8 and with Lion.


Most tests i've done with a direct connection MBP5,2 - MP5,1 (to reach the speed) but sometimes it worked even with an iMac8,1 - MBP Connection.

No Problem with SMB-Shares, but they are much slower (max. 20 - 30 MB/s).


Did I miss something?

Can anybody confirm this behavior?

I'm very grateful for Ideas, I don't have any more and I woldn't like to switch to SMB.

Mac Pro, Mac OS X (10.6.8)
  • flyingcactus1 Calculating status...

    I am having a very similar issue - Have you found any other solutions to this issue?

  • flyingcactus1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2011 11:47 AM (in response to berlindude)

    We have cisco switches, but not something that I can change the QOS settings on for my departmental server.


    The exact issues I am having is when the server has a lot of traffic going to it, (I have not verified an exact value, but it looks like over 40MB/s) there will be file corruption on the files being copied. The servers hosts video and image files for our graphics dept, so every once in a while we will find a video or picture file that looks like parts of the image is missing. 


    Since I saw your post, I have tried looking into using ipfw to limit the bandwidth that AFP can use, but no matter what setting I put in, AFP still uses the max bandwidth.


    Also I have to have spotlight searching, so switching to SMB is not an option.


    Have you tried any 3rd party network cards?  I have one that I might be able to throw in and try out over the next week or two.

  • pellefri Calculating status...

    Hi Berlindude and Flyingcactus!


    I'm in a similar situation as you, having a MacPro server 10.6.8 that is used as mailserver (Kerio) and file server using afp.


    Just wanted to hear what has happened and if you have found a solution (better with newer server os...?)


    I'm working at a designcompany with about 45 users/coworkers.

    The company has expanded with more people and recently the disk used for the fileserver (about 3 Tb) started getting corrupted (Promise DS4600 as raid5). All disks are fine, the filesystem gets messed up.


    Switched to another disk (tried a Synology NAS using iSCSI), same thing happens after a while...


    Best regards,


    Pelle Fridell

  • cygnusx Calculating status...

    berlindube, we appear to be experiencing a very similar issue image file corruption (pixels changing in psd files). This happens when copying files from one AFP share to another AFP share, using a client machine, it does not happen if the file copy is made directly using the Server.


    What is very worrying is that all copies complete without any error notification from OSX. The dates and file sizes are all correct no indication the copy is not completely the same as the original. I never thought a file could be damaged this way, either it copied or did not, no gray areas of complete copies but the content of the file may have been changed.


    We have a small setup, a Mac Mini OSX Server, with Promise Pegasus R4 RAID 6 via Thunderbolt, sharing with 5 client Mac's. Our initial thoughts were Thunderbolt was causing the problems but the direct server copies are fine. So it must be dropped packets via the gigabit ethernet?


    The problem appears to get worse if we are using a Mac client which is further away from the Server. The image pixel corruption is more evident than using a Mac client which is closer. Is our ethernet switch not producing enough power to supply the data transfer on these longer lengths of Cat6 cable?

    Its only Netgear desktop switch as its only a small network of machines.


    berlindube, you say its an AFP bug so what was your solution?

  • cygnusx Level 1 Level 1 (5 points)

    Hi berlindude,


    Thanks for the reply, yesterday I also did exhaustive testing and like yourself reproduced the AFP problem using two Mac's connected directly. I have reported the problem to Apple who have taken reports from our Mac Mini Server, I'm hoping to receive some positive feedback in the next day or so.


    If you have issues with a MacPro and we have a Mac Mini then it is not hardware specific. Are you still running OSX Server 10.6.8 as we run OSX 10.8.3 with the Server app, so that must mean the AFP problems have been around for several OSX versions.


    I can't understand why more people have not experienced it. Something must trigger this AFP issue because we did not experience the problem with our old Server a PowerMac G5 running OSX Server 10.5 which we replaced with the Mac Mini thunderbolt RAID setup around 6 months ago.


    Please can you expand on your workaround, how to achieve this and do the combined shares still appear as separate hard drives on the client Mac's?


    put all the shares, where clients have to copy data between, in one share together

            when a client copies a file within a share, the data is not tranfered to the client and back. AFP just sends the signal and the copy is done local on the server – so no problem.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.