Skip navigation

Server error: "The attempt to read data from the server '(null)' failed"

19351 Views 15 Replies Latest reply: Dec 13, 2012 9:06 PM by Benevolent Dictator RSS
1 2 Previous Next
Demetrios Level 2 Level 2 (200 points)
Currently Being Moderated
Jul 23, 2010 12:52 PM
Multiple times during each day my client (Mail.app) puts up a little exclamation mark "!" next to the mail account hosted on our Leopard Server. Clicking on this little alert icon pops up a message that reads:

+There may be a problem with the mail server or network. Verify the settings for account “Leopard Server Account” or try again.+

+The server returned the error: The attempt to read data from the server “(null)” failed.+

I can make the "!" go away by choosing Mailbox>Synchronize>Leopard Server Account. And everything seems peachy but it inevitably pops up again in another hour or two. It's annoying because I'm not sure if mail is getting through or not when the "!" is up.

Any ideas why this is happening?
MB Pro, PowerMac, mini, iPhone, TV, Mac OS X (10.6.4), Leopard Server 10.5.8
  • MrHoffman Level 6 Level 6 (11,745 points)
    You're going to want to describe how you have your mail client configured in (far!) more detail, imap or pop, whether you're using authenticated (you should be), what your network connection looks like, whether this is on-LAN or remote, etc., and you'll also be checking your server logs in parallel.

    That "(null)" as the name of the server is particularly interesting. Odd. In addition to the topology, what does your local DNS look like here?
  • MrHoffman Level 6 Level 6 (11,745 points)
    On no specific evidence, I'd move off Kerberos (for testing purposes), and you'll want to review the server logs around the time of the errors.
  • David Fee1 Level 1 Level 1 (5 points)
    I'm getting the same problem as described above. Not getting any mail through either. It is a pop account, authenticated by password. I'm not sure about the answers to the other questions that MrHoffman asks because I don't understand them.

    Any help appreciated.
  • David Fee1 Level 1 Level 1 (5 points)
    Um, my own problem seemed to be that the password had somehow been removed from the mail accounts settings.
  • Expr3ss! Level 1 Level 1 (0 points)
    Most likely this is a limit on the maximum number of concurrent connections allowed to your mailserver.

    Mail.app makes a lot of simultaneous connections (open the activity window and see). So you will need to set up your mailserver to accommodate this.

    Also, when collecting mail on its regular schedule, mail.app attempts to access all your email accounts simultaneously. So every email address generates multiple connections to the server. So the problem multiplies.

    If you are able to set the maximum number of connections (total) and the maximum number of connections per ip address to larger numbers, then the problem should disappear. The numbers will depend upon the the number of people who are accessing those email address, the number of email addresses and the number of unique IP addresses in use.

    I needed 200 (max) and 50 (max per ip).

    Hope this helps.
    MBP "17" Intel Core i7 8GB, Mac OS X (10.6.4)
  • Tony K Level 1 Level 1 (15 points)
    Expr3ss! how many mail accounts do you have? I've tried bumping my my connections up to seemingly insane numbers (600 daemons, 300 maxperip). I only have 9 mail accounts.

    This hasn't made any difference. If I hit "get mail" quickly I'm able to get all the mail eventually, but I can't be needing to click get mail 20 times each time I want to check all.

    These problems all surfaced when upgrading to snow leopard and ilife 11.
    Macbook Pro 17, 2 mac minis, Macbook, iPhone 3G, iPad 32 and so on..., Mac OS X (10.5.1)
  • Tony K Level 1 Level 1 (15 points)
    MY SOLUTION REPOSTED FROM ANOTHER THREAD:

    I've just solved a similar issue.

    I have a dedicated server running Plesk 9.5 and when I upgraded to iLife 11 and Snow Leopard this error appeared. I could quickly click "get mail" and I'd get all my mail, but only 3-4 of my 9 mail accounts would connect. Theo others would have the error:

    "The server error encountered was: The attempt to read data from the server..."

    I found solutions for those using IMAP mail:

    modify the /etc/courier-imap/imapd configuration file and change MAXDAEMONS from 40 to 80 and MAXPERIP from 4 to 40. This allows all the machines behind my home firewall to connect to multiple accounts on the e-mail server with mailbox caching enabled.

    I'd made this change on my server but it didn't seem to have any effect. It dawned on me that I'm using POP, not IMAP. So I found in /etc/courier-imap/pop3d the same settings. I changed the MAXDAEMONS from 40 to 80 and MAXPERIP from 4 to 40 and voila, all my connections concurrently worked.

    This has taken me more than two days to fix and I hope posting this helps someone else with the same issue.
    Macbook Pro 17, 2 mac minis, Macbook, iPhone 3G, iPad 32 and so on..., Mac OS X (10.5.1)
  • tillathenun Level 1 Level 1 (0 points)
    Tony -

    Thank you, thank you, thank you.

    This solution to IMAP issues has saved my sanity. I've been battling with irritating alert symbols in Mail and spotty connections for a year now and by chance I found this post of yours. I've logged into my server, changed the values, and all seems good so far.

    All the best,

    Andrew
    MacBook Pro and iPhone, Mac OS X (10.6.5)
  • chopstik |/ Level 1 Level 1 (0 points)
    You rock 'Tony K'. I've several IMAP accounts setup on MediaTemple (dv) servers and have struck this issue for too long to remember. Editing '/etc/courier-imap/imapd' as you described and re-starting the IMAP service using Plesk worked a treat and solved the problem. Genius, thanks for the post.
    MacBook Pro, Mac OS X (10.6.6), http://chopstik.net
  • Leon McKee Level 1 Level 1 (0 points)
    We had the same type of errors with a dedicated server running WHM. We adjusted the Mailserver Configuration settings for IMAP and the issue was solved.
    iMac 2.93 11,3 8GB ATI Radeon HD 5750 2TB Windows 7, Mac OS X (10.6.6), MacBook Pro 2.6 4,1 4GB 8600M GT 500GB Windows 7 Mac OS X (10.6.6)
  • stillLogan Level 1 Level 1 (0 points)

    much appreciated, TonyK!

  • stevie8abes Level 1 Level 1 (0 points)

    This sounds like the very same issue I'm having. Mail works fine until I add accounts 5, 6, and 7.

     

    I'm also both a novice to the more technical side of computing and new to Mac's so can anyone point me in the right direction of where and how I change these settings?

  • siamless Level 1 Level 1 (0 points)

    modify the /etc/courier-imap/imapd configuration file and change MAXDAEMONS from 40 to 80 and MAXPERIP from 4 to 40...

     

    Can you please be more specific - modify using which tool?

     

    The server I am trying to connect to always gives me this error message:

    http://cl.ly/243A171A362f2h1a3E2c

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.