Skip navigation

DNS doesn't work?

476 Views 3 Replies Latest reply: Dec 14, 2011 4:48 PM by sfatula RSS
GreatGeek Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 13, 2011 7:41 AM

Ok, I'm new to Mac but not new to DNS. I have it configured and running and have all of my workstations pointing to the server IP for primary DNS. It doesn't work locally. I used a .com for the local server name. Is this the problem? When I ping server.domain.com (correctly input, of course) it says it can't find the name. Is there a document from Apple (NOT some website that isn't official!) that explains how to setup DNS on Lion from scratch? Any help would be appreciated.

  • sfatula Calculating status...
    Currently Being Moderated
    Dec 13, 2011 10:48 AM (in response to GreatGeek)

    .com, or any other name is fine. So, you have downloaded Server Admin (which manages DNS via the GUI)? If not, download it.

     

    What happens when you do:

     

    dig server.domain.com from the Lion server?

     

    What happens when you do the same form a client who has DNS pointed to the server?

     

    What happens when you:

     

    dig @192.168.1.3 server.domain.com from a client where 192.168.1.3 is the local IP of the server?

     

    You sure you didn't enable the firewall on the Lion server and not allow DNS in?

  • sfatula Level 2 Level 2 (150 points)
    Currently Being Moderated
    Dec 14, 2011 4:48 PM (in response to GreatGeek)

    Ok, so, given the limited information, hard to help. But I use a .com also, works fine. DNS works fine on Lion server, postfix works fine, and so does dovecot, all top notch products. It's just named (Bind) under the hood (dns), so, nothing unusual, any bind guide would be appropriate. I find sendmail inferior, but, it probably comes down to what you personally like the most. I like postfix, someone else may like another system. Both are popular. Dovercot has been used a long time on Apple server. I love that product as well, very flexible and fast.

     

    The only "how to" would be the install guide for correctly setting up Lion server in the first place, there are some key prompts that are more difficult to change later. DNS worked as soon as the install was done, for me, there really wasn't anything to do. You manage DNS via Server Admin (download it). It took all of a minute or so to get it to work. Since it's not working for you, obviously, something has gone wrong. Would have to have way more info. Download server admin here:

     

    http://support.apple.com/kb/DL1457

     

    Some minimal doc can be found here specifically for DNS:

     

    https://help.apple.com/advancedserveradmin/mac/10.7/

     

    Good luck!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.