Skip navigation

How do I find the valid IP address for the base station?

2677 Views 12 Replies Latest reply: Dec 31, 2013 10:55 AM by Johst RSS
TarakK Calculating status...
Currently Being Moderated
Nov 3, 2011 9:08 PM

I am trying to install he Airport Extreme but I am receiving this message:  The wi-fi base station does not have a valid IP address. How do I find the valid IP address for the base station?

Mac OS X (10.7.2)
  • Bob Timmons Level 9 Level 9 (75,570 points)

    It is the modem that must supply a valid IP address to the AirPort Extreme.


    You are receving this error message because the modem is not communicating correctly with the AirPort Extreme.


    If you can provide the make and model number of your modem, we may be able to provide more help.

  • matthairy Calculating status...

    Hi Bob Timmons.

    I'm having exactly the same problem with my Time Capsule. Could you kindly help me out please. My modem is a Cisco DPQ3212. Link below. Do I need to chnage any setting on the Time Capsule such as changing the DHCP settings?



  • Bob Timmons Level 9 Level 9 (75,570 points)

    Can we get a bit more information, please?


    Is this a case where the modem and Time Capsule have been working....and are now having problems?


    Or, are you perhaps trying to add a new device to the network,,,either the modem or Time Capsule?


    If you have a new modem, do you remember or still have some info about your old modem....make and model number?

  • matthairy Level 1 Level 1 (0 points)

    Some very good questions.


    I've just moved back home to Australia from the UK. In the UK, the Time Capsule (TC) was working perfectly with the modem however I don't know what the make and model was.

    I'm now attempting to setup the (TC) for the first time using a new modem and ISP in Australia and create a new network.

    I have run an ethernet cable from the modem to my Mac and I do have internet connection. But when I connect that ethernet to the TC and run Airport Utility to set it up I get the error about no valid IP address.

    I saw on another forum a suggestion about doing full rest of the TC which I have done, however it didn't fix the problem.


    Guy here at work was saying something about accessing the modem settings to get it to create the IP address for the TC. And then going into the TC setting and removing DHCP setting so that the TC didn't try to create an IP. But not sure really how to do this.


    Does this info help at all?

  • Bob Timmons Level 9 Level 9 (75,570 points)
    I have run an ethernet cable from the modem to my Mac and I do have internet connection. But when I connect that ethernet to the TC and run Airport Utility to set it up I get the error about no valid IP address.

    This tells us that the modem has associated with your computer. The modem "remembers" the settings for your computer and "looks" for it when you connect the TC. It does not "see" the computer, so it does not associate with the TC.


    The modem needs to be reset so that it will not remember the computer. Then it will associate with the next device that connects.


    Look for a reset button on the modem, and if present, push it for a second or two. Then power off the modem and leave it off for at least 30 minutes. Power off everything else as well.


    After the wait period, power up the modem and let it run for 4-5 minutes by itself. Then power up the TC and let it run a few minutes. Power up each other device one at a time about a minute apart.


    Check to see if the modem is now associating with the TC so that the TC will get a valid IP address.

  • Plizard Calculating status...

    Hi Bob Timmons,


    I am trying to set up an AirPort Extreme that was just purchased today that is connect to the internet via Motorola Surfboard Cable Modem SB5100.  I am attempting to do all of my setup through AirPort Utility for Windows as I do not own a Mac.  If I allow the Base Station to automatically detect the IP Address using DHCP, I end up with this error, that is, "Your Apple Wi-Fi base station does not have a valid IP address."  If I enter in IPv4 settings manually, I can get it to green light, but there is still no internet connectivity.  The modem and connection itself is fine, as I am connected to the internet directly through it as I type out this message, so clearly there is a problem with the interaction between the modem and the AirPort Extreme.  I have also tried doing a factory reset, to no avail. 


    Any guidance would be much appreciated, as I am quite frustrated right now.  Thanks.

  • Bob Timmons Level 9 Level 9 (75,570 points)

    Did you perform a full modem reset as I outlined in the previous post?

  • Plizard Level 1 Level 1 (0 points)

    Err, never mind.  Right after I submitted the previous post, it started to spontaneously work.  Go figure.  Goes to show that things don't like to work until you start complaining about them.


    Edit:  Yes, I had performed several full modem resets already.  This time around it just started working without the reset.  Odd.

  • matthairy Level 1 Level 1 (0 points)

    Hi Bob,

    Yeah I did and unfortunately I’ve lost internet connection. Seems as though my ISP provider had some settings that I’ve lost now. I’’ve decided to buy a $40 access point and back up to normal external hard drives. Appreciate your help.

  • jphinsf Calculating status...

    Bob, Thank you!  I was having trouble connecting my Time Capsule to the internet, and despite lots of powering down, nothing was working.  The reset button on the modem did the trick!  Much appreciate you advice.

  • captenaj Calculating status...


    I know this is an old discussion but I wanted to tell you that your explanation of the TC getting the IP address from the modem solved my problem.  Once I realized that I was able to figure out what I was doing wrong and finally fix the problems that had sucked up my entire weekend.  Thank you.

  • Johst Calculating status...

    I had the same problem with my new AE (gen 2) and Cisco DPQ3212 modem. After a lot of trying diffrent things, resetting modem, pulling battery etc I found a very simple method that worked. First start the AE without data cable connected and then start your iOS or Mac OS WIFI app. The device will automatically find the new AE wifi network and launch a connection wizard with step by step instructions for when to connect cables, reset the modem etc. After all trying I was surprized how easy this was.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.