1 2 Previous Next 28 Replies Latest reply: Mar 19, 2014 3:15 AM by Deipnosophista
vidarnordnes Level 1 Level 1 (0 points)

I've listened, and watched, podcasts for many years now, and been very happy with the iPhone for that, but the last couple of days, some episodes have started being greyed out. This only happens on the iPhone though. It works fine in iTunes on my mac.

The greyed out episodes all are from (or after) August 22nd. The episodes before that works fine.

 

I've got 8 different podcasts at the time. Total of 26 episodes, where 18 of them are greyed out. What to do?

Only solution I can find on google is related to Parental Preferences. They've been off since I bought the mac. Double checked now, and all the settings in that tab in preferences is turned off.


iPhone 4, Mac OS X (10.7.1)
  • 1. Re: Podcasts greyed out
    wjosten Level 10 Level 10 (93,295 points)

    On your phone: Settings>General>Restrictions...are yours on? Allowed Content...any restrictions here?

  • 2. Re: Podcasts greyed out
    vidarnordnes Level 1 Level 1 (0 points)

    Thanks for the quick answer!

    Those are off. I tried deleting the iPod Photo Cache from the Aperture folder. That helped for some weird reason, but now it won't sync the photos

  • 3. Re: Podcasts greyed out
    vidarnordnes Level 1 Level 1 (0 points)

    Now, one week later, still the same problem. Now everything after the 25th is greyed out. Do I really have to keep deleting the iPod Photo cache every time I want to sync new podcasts?

  • 4. Re: Podcasts greyed out
    campbellcj Level 1 Level 1 (0 points)

    I have the same problem and it's driving me crazy!  Brand new 4S will not play podcasts that are fine on my PC and previous iPhone 4. They seem to synch but are greyed-out and cannot be played.

     

    Ideas?

  • 5. Re: Podcasts greyed out
    Rroskey Level 1 Level 1 (0 points)

    I had this problem also. When I got home on my lunch break I resynced my iPhone via wifi and every thing poped up. It seems to me that there is some type of interruption during the sync process it will save the partial files on the phone for completion later. I don't know if this is cause by the Mac going to sleep or what. Because mine was on the wifi and plugged in to the wall the entire time.

  • 6. Re: Podcasts greyed out
    campbellcj Level 1 Level 1 (0 points)

    I was able to resolve this issue by turning-off Podcast synching in iTunes, synching the phone, and then turning it back on and re-synching again.  All is well now. It is weird IMO to have video podcasts filed under the Videos app but both audio and video podcasts are working for me again.

  • 7. Re: Podcasts greyed out
    lemsx1 Level 1 Level 1 (0 points)

    I have the exact same problem. my guess is that when i did "restore" for my new 4S, the metadata for the podcast was copied but not the actual files. iTunes can't send the files because the phone thinks the data is there.... so obvious solution is to uncheck the "sync podcasts" on iTunes and allow it to clean up the db. Then resync everything. (I haven't try this yet but I saw somebody reported this worked).

     

    Apple should definitely fix this glitch on the next bug release (minor version) of iOS 5.

  • 8. Re: Podcasts greyed out
    davesens Level 1 Level 1 (0 points)

    I too have the same problem on my iPhone after upgrading.  I cleared the issue by restoring the iPhone to factory settings.  I hadn't found anything simpler that worked.  Turning off and on podcast syncing does not work for me.

     

    Where is the Photo Cache clearing setting done?

  • 9. Re: Podcasts greyed out
    davesens Level 1 Level 1 (0 points)

    More info:

     

    I am syncing from Windows Vista over USB.

     

    Had tried rebooting and toggling podcasts as listened/watched and then back.

     

    The podcasts play successfully on my PC.

  • 10. Re: Podcasts greyed out
    GaryB97 Level 1 Level 1 (0 points)

    Is there a definitive answer to this? Just venting: how can you guys do Siri but have trouble with podcasts?  Is this more complicated that it looks?

  • 11. Re: Podcasts greyed out
    carolynfromauckland Level 1 Level 1 (0 points)

    I am having this problem too. I'm glad I'm not alone but would be very glad to get it fixed.  For me it's not just podcasts but also audiobooks from audible.com.

     

    I'm using an iPhone 4, iOS5.0.1, and using latest version of iTunes on XP Home, syncing via USB.

     

    I subscribe to about twenty podcasts, and all of the episodes after 29 October 2011 are greyed out on my iPhone. They play just fine on my PC. 

     

    I've been buying audibooks from audible.com for over a year, and currently have ten on my iPhone. The seven I bought before October are fine, but the three I bought last week are greyed out and I can't play them - that's 60USD worth of audiobooks I can't listen to on my phone!  Again, they play fine on my PC. 

     

    I appear to have iTunes Wi-Fi Sync turned on on my phone... not sure how I did that, but would it have any effect? It's showing the last Wi-Fi sync as having been on 31 October, which is awfully close to the 29 October date I started having problems.

  • 12. Re: Podcasts greyed out
    campbellcj Level 1 Level 1 (0 points)

    Carolyn,

     

    Audible posted some info about the issue with their audiobooks, at least with regard to using their iOS app (which I do) versus using audiobooks via iTunes.  Apparently iOS 5.0 required some changes in file locations etc. which caused existing content on the phone to be lost or corrupted.  The 'solution' is to delete the audiobooks from the device and re-download them. This worked fine for me, but had the unfortunate side-effect of losing my current place in each book.

     

    I have had a similar recurring issue with the MotionX GPS app as well, where I have had to re-download the voice guidance packages 2 or 3 times now.  I suspect it is a similar issue as with podcasts and audiobooks. Something is causing data to be deleted or corrupted on the devices and it is quite irritating!

     

    Cheers,

     

    Chris C

  • 13. Re: Podcasts greyed out
    carolynfromauckland Level 1 Level 1 (0 points)

    Chris, all,

     

    Success!  I've just spent a frustrating two hours with iTunes, but in the end I have my audiobooks and podcasts working again and I haven't lost my place in any books :-)

     

    What worked, in the end, was this laborious process:

     

    * delete all the audiobooks from iTunes (not from the device or from my PC, just iTunes)

    * sync to my device - voila no audiobooks on device

    * re-import all the audiobooks into iTunes, and reselect them to sync to my device

    * sync to my device - hm, all audibooks there but now ALL TEN are grey. A low point in my day.

    * bored with waiting half an hour for each sync, uncheck nearly all my photos from synching

    * sync again just for the heck of it.  Watch open-mouthed as all audiobooks and podcasts merrily sync properly.

     

    I am not sure whether it was the delete/re-import, or the unchecking of most of my photos, that did the trick.

     

    Since vidarnordnes above had success by deleting the photo cache, maybe it's got something to do with the number of photos being synched?  Is anyone else willing to try unchecking most of their photos?

  • 14. Re: Podcasts greyed out
    paulfromhere Level 1 Level 1 (0 points)

    Similar problem just happened to me.

     

    In my case I tried unchecking podcasts, syncing to erase them, rechecking podcasts and syncing, and then different podcasts were greyed. Therefore, I suspect greyed out means it was corrupted during transfer.

     

    After powering off / on the iphone and re-syncing, they now are normal.

     

    A radio-geek friend of mine claims it's all caused by sunspot activity and the reboot fixes the corrupted program that was causing the problem. I guess sunspot activity varies with your location on the planet .. maybe that's why only a small number of us have this problem.

     

    In the future, reboot and ask questions later ...

1 2 Previous Next