Skip navigation

Inaccurate information for printer supply levels in Sys Prefs

4607 Views 12 Replies Latest reply: Apr 10, 2012 2:49 PM by darkera RSS
Derryl S Level 2 Level 2 (185 points)
Currently Being Moderated
Dec 9, 2011 10:16 PM

I am getting the information (a yellow caution triangle) in print dialogs and the printer supply levels in the system prefs that the Maintenance Kit for my Lexmark laser printer (E460dn) needs to be replaced and the barline shows that it is down to about 10%. The kit needs to be replaced after 120,000 copies. Yet, if I run a report direcly from the printer, it says I have printed just a little over 17,000 total pages and that the kit is at 90% which is about right for the number of copies.

 

The toner and fuser levels in the sys prefs for the printer seem to always be accurate. The Maintenance kit bar line was always nearly full scale until recently. The toner cartridge was running out and it has been changed. I thought the caution was for the toner cartridge, but the triangle symbol was still there after replacement so I investigated further.

 

Is there something that can reset or correct the information the system printer prefs pane that is totally inaccurate. There is on that window a message that the levels shown are approximate, but 80% in error is a long way from approximate! Fortunately I checked the printer's report before I spent $150 unnecessarily.


Any suggestions?

Mac Pro, Mac OS X (10.7.2), 2.8 GHz Quad core, 6 GB ram
  • sig Level 8 Level 8 (35,770 points)

    Contact Lexmark.

  • Michel Mommaerts Level 1 Level 1 (15 points)

    I to am having this issue with 10.6.8 and an e120n printer. I'd love to get rid of the Low Supplies warning. I've reset the printer system and reloaded the driver etc without any luck.

     

    Mitch

  • Cattus Thraex Level 4 Level 4 (1,715 points)

    Many printers have the same problem, especially (in my experience) when connected to a wl router.

    I have no solution than to accustom to these false messages, you can live with them just as I have been living with them (HP printers)

  • Cattus Thraex Level 4 Level 4 (1,715 points)

    I rephrase: ... misguiding ink level in both wl and wiered networks.

  • PAHU Level 6 Level 6 (14,400 points)

    As you mention, this issue first appeared with 10.6.8 due to changes made to CUPS where a function "backend SNMPsupplies" reported warnings rather than errors. For certain brands of printers this call resulted in the incorrect information being reported back to the Mac. While the CUPS organization released a patch to resolve this it seemed that Apple did not do the same and relied on the vendors to change their drivers.

     

    One common workaround at the time was to modify the PPD for the printer so that the SNMP calls were not made. This is done by adding the line "*cupsSNMPSupplies: False" to the printers ppd file located in the /etc/cups/ppd. Note that you will need administrative privileges to perform this workaround.

     

    Before showing the workaround I have to say that I have not heard this issue happening with Lion, but then the printers I support that had this issue on 10.6.8 have no official Lion drivers yet. Given that it only just started recently you would have to question what has changed for this to appear. Does System Preferences > Software Update > Installed Updates show any update around this time?

     

     

    The following steps for 10.6.8 were posted by EFI in their Tech Ticker Alert, posted June 27, 2011.

     

    For this example we will use ColorPrinter as the name of the printer affected by the 10.6.8 update.

     

    1. From the Finder menu choose Go, then Go to Folder...
    2. Enter /etc/cups/ppd in the Go to Folder dialog box and choose Go.
    3. Find the ppd named ColorPrinter.ppd. (This is the same name as the ColorPrinter in Print and Fax with a .ppd extension. )
    4. Drag the ColorPrinter.ppd to the Desktop.
    5. Open the ColorPrinter.ppd with TextEdit.
    6. At the end of the PPD add the following line exactly as written: *cupsSNMPSupplies: False
    7. Save the modified ColorPrinter.ppd to the Desktop.
    8. From the /etc/cups/ppd folder, move the original ColorPrinter.ppd to the trash. Authenticate when prompted.
    9. Drag the modified ColorPrinter.ppd from the Desktop to the /etc/cups/ppd folder. Authenticate when prompted.

     

    Printing should now work as expected.

  • Cattus Thraex Level 4 Level 4 (1,715 points)

    That is good. I would need that for HP 2460

  • darkera Calculating status...

    Derryl,

    thank you for this last message!

    I had a very similar issue with a T630 Lexmark printer.

    It would always say "Unable to query ink levels" or "Unable to query toner level".

    The very competent Lexmark support rep confirmed that a firmware upgrade is useful for OPC errors.
    In my case however, I was directed towards the PPD file 1.08, which is available for download for Windows 2000 (but works well with Mac OS X 10.6 and 10.7).

    Once that PPD was in place, the printer resumed working under 10.6 just as it did before under previous versions of Mac OS X 10.4.

    Of course, the best would be if Lexmark incorporated that 1.08 PPD file into the Lexmark printer driver for the T630 (which still has version 1.07, which won't work on Snow Leopard or Lion).

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.