10 Replies Latest reply: Mar 9, 2012 10:36 AM by charkee
ParisBob Level 1 Level 1 (0 points)

I've read through the various threads for Lion users having problems with duplicate Contacts entries, but did not find anyone who has the same problem that has recently appeared for me.

 

I have an iCloud account where Contacts appear only once.

 

I have an iPhone running iOS 5.0.1 with Contacts syncing turned ON in iCloud.  Contacts appear there only once.

 

On my MacBook Pro running OS 10.7.2, all my Contacts entries have suddenly appeared in duplicate.  In iTunes (10.5), I have syncing turned off for Contacts.

 

I just did a USB sync of the iPhone which had no effect on this issue, as expected.

 

Any suggestions to resolve this problem would be greatly appreciated.  I went through a different duplication problem with iCal where the duplicates appeared in iCloud, the iPhone and the Mac, and I had to delete hundreds of duplicate entries on iCloud to solve that problem.  I don't want to do the same with hundreds of contacts.

 

Thanks in advance,

Bob


MacBook Pro, Mac OS X (10.7.2)
  • 1. Re: Another Lion contacts duplication problem
    ParisBob Level 1 Level 1 (0 points)

    Well I searched further and found a solution proposed by Russell on another thread.  I've copied it below (didn't know how to link to it).  Thanks, Russell!!!

     

     

     

     

    I posted this in another thread on Address Book duplicates and iCloud. Did this start after the iCloud hoopla? After I tried iCloud, I ended up with duplicate contacts on my computer. The "Look for Duplicates" command in Address Book gave me soemthing to the effect, "No duplicates found," which raised my blood pressure as I could see them right there.

     

    Going to System Preferences did the trick for me. Click on iCloud underInternet & Wireless. Untick the checkbox for Contacts. You'll then be given a choice of keeping your iCloud contacts on your computer, with the options of Delete from Mac or Keep Contacts. No, you don't want to delete the contacts from your box, so choose Keep Contacts. Let it do its thing, then re-tick the Contacts checkbox.

     

    Like I said, at least for me this solved the problem with no more duplicate entries on my box or my iPhone.

     

  • 2. Re: Another Lion contacts duplication problem
    shadrach343 Level 1 Level 1 (45 points)

    It may appear resolved, but is not resolved correctly.  You should not have to do that to prevent Cloud from duping contacts.  Something else is causing that.  Make sure you check that if you have a MobileMe account, it's not syncing anymore by signing out of that preference pane in System Preferences.

  • 3. Re: Another Lion contacts duplication problem
    ParisBob Level 1 Level 1 (0 points)

    Thanks for your response.  I have never had a MobileMe account.  I have only a single iCloud account.

  • 4. Re: Another Lion contacts duplication problem
    peterholly Level 1 Level 1 (0 points)

    Shadrach343, thanks to you and also to ParisBob. I had the same issue and your combined advice seems to have solved it. Staggering that Apple could let this happen though. What with this and the fact that my entire email history was wiped without notice when I installed Lion (I had been using Outlook for email) I am starting to fall out of love with Apple...

  • 5. Re: Another Lion contacts duplication problem
    Toyworks11 Level 1 Level 1 (10 points)

    I just upgraded to Lion today, and I just noticed my contacts on my iPad are duplicated now. This pizzes me off. What is the problem here? Now I have to spend hours deleting duplicates. Is there an easier way to do this? I tried the above and I still have duplicates.

  • 6. Re: Another Lion contacts duplication problem
    peterholly Level 1 Level 1 (0 points)

    Clicking on the "Card" tab with Address Book open gives you the option of finding duplicates. Unfortunately, it then asks if you want to merge the duplicates. It will then tell you you have x duplicate cards and y duplicate entries and ask if you want to merge them. The obvious response is "yes" right? WRONG! You will find that most of the duplicate entries disappear but each address card will then contain duplicate adressess....

     

    This is frankly a pathetic state of affairs for Apple not to have fixed it yet and introduce a proper de-dupe facility. Spread the word and Apple may finally get round to offering a solution.

  • 7. Re: Another Lion contacts duplication problem
    Toyworks11 Level 1 Level 1 (10 points)

    Do you mean the "Edit Card" tab. There is no tab in mine that says "Card" Darn, sounds like they need to get an update out to fix this. How the **** did Steve Jobs ever let this problem slip by? What's more astonishing is that Lion has been out this long and they still haven't fixed it.

  • 8. Re: Another Lion contacts duplication problem
    peterholly Level 1 Level 1 (0 points)

    Absolutely. This is what you might expect from Microsoft, not Apple. Steve must be turning in his grave. Anyway, on my computer I get a "Card" tab when Address Book is open. Not sure what else I can say.

  • 9. Re: Another Lion contacts duplication problem
    peterholly Level 1 Level 1 (0 points)

    Well, I have duplicate contacts again. Anyone know if Apple are doing anything about this? Message for anyone from Apple monitoring this forum: "What the **** is going on?

  • 10. Re: Another Lion contacts duplication problem
    charkee Level 1 Level 1 (0 points)

    So hopefully this will help everyone. I just upgraded to Lion and I had a Mobile Me account.

     

    To solve the issue of the duplicate contacts, I went did the following and it worked:

     

    1.  Go to System Preferences

    2. Click on the Mail, Contacts, and Calendars Icon beneath the Internet and Wireless header.

    3. Once that opens, a list of your e-mail accounts will appear (including iCloud).

         Your iCloud account is now your old MobileMe account - the e-mail should be the same

    4. Remove the e-mail address under the MobileMe icon by clicking on the icon and selecting the "minus" at the bottom left corner.


    This should fix the duplication. It worked for me.

    Hope it helps.