Skip navigation

Reconnect for referenced files not working

1696 Views 15 Replies Latest reply: Dec 29, 2013 2:45 PM by Mhrob RSS
1 2 Previous Next
macuser222222 Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 18, 2011 12:47 PM

Hi *,

 

I got a problem reconnecting to my masters.

 

After I moved the masters to another external hard disk I tried to reconnect them. After choosing a project and selecting all versions within it "Locate referenced files" gives me a list of list of referenced files that could not be found. Selecting a file and pointing it to the right master file will usually result in the buttons "Reconnect" and "Reconnect All" to be selectable. After a "Reconnect All" not all referenced files could be reconnected.

Going through the process once more does not work since it is not possible to reconnect the files. Both reconnect buttons are greyed out although the right files have been selected.

Does anybody know what the problem is or what criteria Aperture uses to determine which files are reconnectable or not ?

 

Deleting the project and all version and re-importing the pics  is not really a solution since will result in the loss of all metadata, stacks, ratings, and so on.

 

Thanks for  your help

Rob

Aperture 3, Mac OS X (10.7.2)
  • léonie Level 8 Level 8 (46,760 points)
    Currently Being Moderated
    Dec 18, 2011 1:18 PM (in response to macuser222222)

    Does anybody know what the problem is or what criteria Aperture uses to determine which files are reconnectable or not ?

    Aperture insists on the exact file size to allow to reconnect a master. This article expains how to fix the data in the Aperture Library to make it possible to connect a master file after editing it:

    Recover From Broken References to Edited Files: http://archive.bagelturf.com/aparticles/ref/refrec/index.php

     

    Regards

    Léonie

  • Frank Caggiano Level 7 Level 7 (22,905 points)
    Currently Being Moderated
    Dec 18, 2011 2:12 PM (in response to macuser222222)

    if you are positive the images you are trying to reconnect are in fact the correct ones try holding the option key when in the locate reference files window. This use to force Aperture to make the reconnect buttons active but its been a while since I used it so can;t say for sure if it still works.

     

    Let us know if it works,

     

    regards

  • léonie Level 8 Level 8 (46,760 points)
    Currently Being Moderated
    Dec 18, 2011 3:21 PM (in response to macuser222222)
    I was going through the description in the link you posted but could not find a correspondig .apfile . Actually I did not find any apfile. The format might have changed with version 3.2.2

    O yes, there are indeed some changes: sorry for sending you on a wild goose chase

     

    When you open the Aperture Library with ctrl-click - "Show Package Contents" you will see a file ApertureData.xml. That file is the index to all images in your Library. To open it you need a texteditor, that can read XML, like Xcode or TextWrangler.

    I just opened my Library with Textwrangler and searched for a filename for one of my images "Lange Anna"

    I found the following representation of the tags:

    <key>zrFXA1HHS0Gns45bMVeGMA</key>

                        <dict>

                                  <key>Caption</key>

                                  <string>Lange Anna, Helgoland</string>

                                  <key>Comment</key>

                                  <string>Lange Anna, Helgoland 2008</string>

                                  <key>ImagePath</key>

                                  <string>/Users/dreschle/Pictures/ApertureScreensaverAuswahl.aplibrary/Previews/ 2010/02/17/20100217-200045/zrFXA1HHS0Gns45bMVeGMA/Lange Anna, Helgoland.jpg</string>

                                  <key>MediaType</key>

                                  <string>Image</string>

                                  <key>ModDateAsTimerInterval</key>

                                  <real>288130088.69</real>

                                  <key>ThumbPath</key>

                                  <string>/Users/dreschle/Pictures/ApertureScreensaverAuswahl.aplibrary/Previews/ 2010/02/17/20100217-200045/zrFXA1HHS0Gns45bMVeGMA/thumb_Lange Anna, Helgoland.jpg</string>

                                  <key>latitude</key><real>54.18828203</real>

                                  <key>longitude</key><real>7.86990167</real>

                        </dict>

     

    This file does not contain references to the Masters, only to the Previews and Thumbs.

    These cryptic codes are folder names: zrFXA1HHS0Gns45bMVeGMA, you can find them in the package, and these Folders contain the Previews and Thumbs.

     

    References to the Versions and Masters are now inside the Database/Versions folder, one folder for each Master/Versions set, containing files named Master.apmaster and Version-0.apversion, Version-1.apversion, etc.

     

    But these are now binary files and I would not dare to patch those files, unless you are really desperate. Maybe you can reimport your missing Master, let Aperture recreate the Master.apfile and then replace the old Master.apfile with it. But it seems to be safer by far to follow Frank Caggiano's route.

     

    Regards

  • léonie Level 8 Level 8 (46,760 points)
    Currently Being Moderated
    Dec 19, 2011 7:30 AM (in response to macuser222222)

    The *.apmaster, *.apversion files are actually binary property list files. They can be converted into a readable form using the following command: plutil -convert xml1 Master.apmaster

    This will generate an xml file that holds a few keys less (30) than the RKMaster database table. After editing the xml file you can convert it back into a binary file again.

     

    Indeed, you always are learning something, thank you for sharing that information - very useful to know!

     

    It turned out that the previous master had a spotlight comment (full filename and the aperture project name) attached to it. The real i.e. the original master did not.

    That is an interesting discovery - I think you solved the puzzle

     

    But if you are sure that you did not add the spotlight comments yourself, we now have an even bigger mistery!

    Post back if you can discover something.

     

    Cheers

    Léonie

  • Aniolek7 Calculating status...
    Currently Being Moderated
    Oct 9, 2012 8:01 PM (in response to léonie)

    Hey : ) i saw this and i have a question ¡¡ long ago i erased a photos and saved it, in a external hard drive now the hard drive dont work and i need that files again , so i need the files and they still that appears in iphoto preview display but dont in all screen of Iphoto i search in finder and i dont find nothing but a lot of time searching i find folders that have the date of the fotos like name and inside there is files with .apmaster and version files like you say up there ... so there is a way to Read that files and recover the images ? ... or iphoto get its from another place?¿'

  • Aniolek7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2012 2:24 PM (in response to macuser222222)

    Hey , i try what you tell me but i find the folders Originals and previews , but the image arent in any folder i check all the folders that appears in 2011 and 2012 .... I let you some screenshots of how looks iphoto to give you and idea of my problem ... here the pics dont appear.

    dasdsa.png

    wqe.png

    And in this screenshot the pics appear in mini preview .... but i dont really know how iphoto get its ..... i search in the folders that you say but nothing happen and originals dont exist ... but the only chance i have its that tiny image that are in somewhere ..... I hope this give you a better idea of my problem ... when i erased this photos i do it really well cuz i need space in disk ... but Mac are really great ,the computer still have the pics and i want it ... are like 40 pics so are a lot i dont know why they hide really well or where search : / i try search in finder by name or date and nothing ... i hope this helps   arent easy to find but i know that they are in some place of my hard drive cuz iphoto have the previews ....

  • Aniolek7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2012 8:08 PM (in response to macuser222222)

    Hi again ...  i search the Thumbnails and i find it the language its different but folders are the same naming ... so i search in 2011 ( thats the day of the pics ) and then open a Month folder that was 08 (August) and then the folder 26 ( day ) ... and finally appears this folder 20110826 and varius folders with this and more numbers but they have nothing inside ... all the other folders have pics that i still have in Iphoto some ones are just faces and Complete photo too ... but the folder that suposse to have the pics inside have nothing :S of thumbnails i search in all folders and subfolders and the image just dont appear .. i try to open the file you mention albumdata.xml and opens dreamweaver Cs5 but i dont understand that part .. appears like Html codes ... somekind of codes  im not sure thats the only thing i dont understand .. and i dont do it that  : /  ... i let you screenshot to see what happen and if i did it rigth  

     

    fotos.png

    sfasf.pngdasda.pngfasfa.pngdasda123.png

    And a Example of the first empty folder

    dqweq.png

    Now thats the problem the iphoto gets the image from dont know where :S i been searching a lot of time : / cuz i want to erased all info and install again the software but i can do it until i find that images

    By the way thanks for all the help, i dont know much about the software and its really hard to find it by myself , so all the help work .. im aproaching to the images i know it ..i just have to keep trying more things , i hope you can give me more ways to searching or explain me about the Xml that i dont try it ....Thanks Macuser222222

  • Aniolek7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 11, 2012 3:20 PM (in response to macuser222222)

    Yes i know its not easy stuff , Now im trying what you say me to do , but Xml show me the path to image and are the same you say me to follow to get in thumbnails and master photos .....and nothing else appear ... im trying with terminal and it show me more results but still havent find them .. its weard but i think the photos appear when I install Picasa Of google ... now picasa its searching all the image that i have .. i hope picasa find thems and im gonna still searching with terminal   .. if nothing of this works im gonna contact apple support cuz i have to find them .. and saw what happen or where are they ... if i find them I let you know  what is it and what i make to get that files .... i really aprecciate the help that you gave me ¡¡ its hard to comunicate in English and so far away.... but thanks im gonna keep in this thanks Macuser222222 ¡¡¡

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.