Skip navigation

British English Mail spell check

11971 Views 50 Replies Latest reply: Nov 15, 2013 9:39 AM by David Neale1 RSS
  • noondaywitch Level 6 Level 6 (8,130 points)
    Currently Being Moderated
    Jul 31, 2011 2:33 PM (in response to Shoogles)

    Had the same problem for ages. What finally worked was to remove all languages other than British English in Language and Text > Language.

     

    However I was still getting seriously aggravated by many apps defaulting to 'check spelling as I type' after closing and re-opening them, so I've now disabled spellcheck completely.

  • Aurel Griesser Calculating status...
    Currently Being Moderated
    Aug 14, 2011 6:01 PM (in response to Shoogles)

    Hi,

     

    I also am constantly getting told that "colour" is incorrect. I have set the System Pref's options as you have (except Aussie instead of British (are there any differences I wonder)). In TextEdit and Pages, I manually set the language to Australian English in the spelling palette window and it STILL says that "colour" is wrong.

     

    I don't have the latest MacOS X version, I'll try doing an update when I can. I did not see, however, any mention of language or spelling fixes in the 10.6.6, the 10.6.7, nor the 10.6.8 updates.

     

    Cheers,

    A.

  • Tom Gewecke Level 9 Level 9 (70,920 points)
    Currently Being Moderated
    Aug 15, 2011 3:05 AM (in response to Aurel Griesser)

    Aurel Griesser wrote:

     

    I don't have the latest MacOS X version, I'll try doing an update when I can. I did not see, however, any mention of language or spelling fixes in the 10.6.6, the 10.6.7, nor the 10.6.8 updates.

     

     

    I think I remember a bug where the British dictionary did not work right in some early updates of 10.6, but not sure which one any more.

  • owf Calculating status...
    Currently Being Moderated
    Dec 20, 2011 7:25 AM (in response to atomicluck1)

    The system is basically broken (Apple doesn't really understand internationalisation).

     

    If you set everything to British English (in System Preferences/Language & Text/Language+Text) and via Edit->Spelling and Grammar in apps, the system does use British English, but it doesn't "correct" Americanisms (traveler, organize etc.) the way it corrects Britishisms when set to US English.

     

    What's more, if you set spelling to "Automatic by Language" OS X simply will not use British English. Even removing "English" from the language list makes no difference.

     

    Why is this a problem?

     

    Because I, like the majority of the world's population (really), speak more than one language and like my spell checker to recognise whether I'm writing English or German and use the appropriate dictionary.

     

    If you regularly write in different languages, you have three choices:

     

    1. Put up with the fact that your Mac only does American English and will "correct" Britishisms.
    2. Set the language to a specific language and turn off auto-correct (it actively works against you when you try to write in the "wrong" language). Probably turn off live spell checking, too (it will be very annoying when you're using the "wrong" language).
    3. Change the language by hand every time (a lot of work).

     

    Hardly a fatal flaw, but it is something that grates literally every time I write anything in English in apps that use the system spellchecker/auto-correct, which is most of the time.

     

    In the end, I turned off auto-correct. Now I just have lots of correctly-spelled words with squiggly red lines.

  • noondaywitch Level 6 Level 6 (8,130 points)
    Currently Being Moderated
    Dec 20, 2011 9:51 AM (in response to owf)

    More drastic solution - I can't remember who originally posted this, but thanks to them anyway.

     

    Disable spellcheck universally;

     

    sudo mv /System/Library/Services/AppleSpell.service/Contents/Resources /System/Library/Services/AppleSpell.service/Contents/Resources.disabled

     

    Copy and paste into terminal. (all one line)

    Press return, exit terminal and restart.

    iMac 24, Mac OS X (10.6.4)
  • owf Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 20, 2011 10:21 AM (in response to noondaywitch)

    Turning spellcheck off in System Preferences doesn't work for you?

  • noondaywitch Level 6 Level 6 (8,130 points)
    Currently Being Moderated
    Dec 20, 2011 10:41 AM (in response to owf)

    Not in all applications, no. (Stickies being a particularly irritating example).

  • fane_j Level 4 Level 4 (3,655 points)
    Currently Being Moderated
    Dec 20, 2011 9:28 PM (in response to owf)

    > The system is basically broken (Apple doesn't really

    > understand internationalisation).

     

    Perhaps you're right, but isn't the sample size rather small for such a sweeping conclusion?

     

    > I, like the majority of the world's population (really), speak

    > more than one language

     

    Really?

     

    > it doesn't "correct" Americanisms

     

    Colour me confused.

     

    Because on my 10.6.8, it works mostly as advertised. I tried TextEdit, Mail, and Stickies, as mentioned in this thread. I say "mostly", because I did find a few possible bugs.

     

    For instance, spell dicts I added in <~/Library/Spelling> (eg, Latin) seem to work erratically when doing Automatic by Language. (Otherwise, they seem to work as expected.) Also in Automatic by Language, having deselected all versions of English other than British, "color" is, indeed, flagged, but not if it is among the first words in the paragraph. I'm not sure how consistent this behaviour is, but it probably has to do with the algorithm used to determine the language.

     

    OTOH, Automatic by Language seems to work fine for me with English, French, and, contrary to your experience, German, as long as they are not mixed in the same paragraph. It seems to me that the spell checker language recognition algorithm works paragraph by paragraph.

     

    It is possible that I have fewer expectations from this feature; indeed, given the difficulties of recognising different languages, I'm surprised it works this well. (Also, keep in mind that a linguist would probably not regard American and British English as different languages, or even different dialects of the same language).

     

    One issue that hasn't been mentioned is that, after changing spelling settings in System Preferences > Language & Text > Text, one has to quit and restart open applications, otherwise they will continue to use the previous settings. Also, keep in mind that some apps (eg, TextEdit), even if they use the system-wide Cocoa spell checker, may have their own settings, which over-ride those in System Preferences. So you're not necessarily limited to the same setting in all apps.

     

    Oh, and as to Stickies, I don't understand the necessity of bringing up the big guns (sudo mv). Edit > Spelling and Grammar > Check Spelling While Typing does the job as expected.

  • noondaywitch Level 6 Level 6 (8,130 points)
    Currently Being Moderated
    Dec 21, 2011 3:08 AM (in response to fane_j)

    "Oh, and as to Stickies, I don't understand the necessity of bringing up the big guns (sudo mv). Edit > Spelling and Grammar > Check Spelling While Typing does the job as expected".

     

    1 - the 'check spelling while typing' is enabled by default (regardless of System Prefs) and will be re-enabled after log-out/in.

    2 - It has to be disabled not once, but for every individual note.

     

    That of course is only one application that ignores the Sys pref - there are others, but I use Stickies daily.

     

    Interesting note; Stickies still uses the OS9 window layout, including the 'windowshade-to-minimise' behaviour.

  • owf Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 21, 2011 4:32 AM (in response to fane_j)

    > Perhaps you're right, but isn't the sample size rather small for such a sweeping conclusion?

     

    I'm not basing that statement on a broken dictionary but on several years of working with Apple software. In particular, iOS conflates other locale settings (currency, formats, search engine) with language, making it impossible for me to set up my iPhone how I'd like (English language, euro currency, google.com search engine). Either I have to deal with most apps using the wrong currency symbol or (what I actually do) use google.ie.

     

    Far worse is Numbers' inability to open two different language documents at the same time: to get, say, German number formats, you have to restart Numbers after changing your preferred formats to German in System Preferences.

     

    That's why I say Apple doesn't understand internationalisation. That's not to say they're worse than anyone else. They're not: Google *really* doesn't get it. But bad is still bad, even if the competition is worse...

     

    That said, I *love* Apple's way of entering accented characters, both on OS X and iOS. Light years ahead of Windows' silly Alt+num combinations and BlackBerry's complicated method. WebOS's method makes me want to punch the people that made it.

     

    > Colour me confused.

     

    I would expect that when you've managed to successfully selected British English, the OS would change "traveling" to "travelling". It certainly does the reverse when its using US English.

     

    > OTOH, Automatic by Language seems to work fine for me with English, French, and, contrary to your experience, German, as long as they are not mixed in the same paragraph. It seems to me that the spell checker language recognition algorithm works paragraph by paragraph.

     

    Sorry, I perhaps wasn't clear. German works fine for me. Just British English doesn't when I have "Automatically by Language" set, which is necessary to get the German support in the first place.

     

    > It is possible that I have fewer expectations from this feature; indeed, given the difficulties of recognising different languages, I'm surprised it works this well.

     

    Actually, it's a pretty straightforward thing to do (a bit of statistical analysis). But the algorithm  doesn't seem to be aware of the varieties available in the OS. It would be far from difficult to have the algorithm check the language list for a preferred variety once it's identified the language being used, and to load the dictionary for that variety instead.

     

    > (Also, keep in mind that a linguist would probably not regard American and British English as different languages, or even different dialects of the same language).

     

    That's entirely irrelevant. Whether US English is a dialect, variety or whatever of British English, this has zero bearing on the fact that differences in spelling are so common that spellcheck becomes an irritation and autocorrect an obstacle to writing British English in OS X.

  • fane_j Level 4 Level 4 (3,655 points)
    Currently Being Moderated
    Dec 21, 2011 5:14 AM (in response to noondaywitch)

    noondaywitch wrote:

     

    2 - It has to be disabled not once, but for every individual note.

    I guess you can tell I don't use Stickies. But could you do me a favour and try this rather awkward workaround. Open a new note, set up fonts and colour as you like, disable Check Spelling While Typing, then choose Note > Use as Default. Quit, log out, log in, open Stickies, new note. Is Check Spelling While Typing re-enabled?

  • noondaywitch Level 6 Level 6 (8,130 points)
    Currently Being Moderated
    Dec 21, 2011 6:15 AM (in response to fane_j)

    Sorry fane, too much hassle. I'd have to enable global spellcheck again and I have no intention of playing with it. I'm perfectly happy not to be assailed by squiggles at the whim of some whiz-kid who thinks he knows better than me what I want.

  • fane_j Level 4 Level 4 (3,655 points)
    Currently Being Moderated
    Dec 21, 2011 6:38 AM (in response to owf)

    > iOS conflates other locale settings

     

    But my Mac OS X doesn't. So your thesis seems to totter upon a single leg.

     

    > Far worse is Numbers' inability to open two different language

    > documents

     

    Are we talking here language or decimal separator? They're not quite the same thing. And, AFAICT, Excel is no different from Numbers in this respect. It seems to me that you want per document localisation settings. Fair enough, but the fact that Mac OS X lacks this feature does not mean that "internationalisation" is not understood. If I don't drive a Porsche Carrera it's not because I don't understand driving!

     

    > I would expect that when you've managed to successfully selected

    > British English, the OS would change "traveling" to

    > "travelling".

     

    So would I. But the fact that the spell checker doesn't flag 'traveling' even when British English is selected suggests to me that there is a bug or omission in the British English spelling dict, not that the "system is basically broken". The omission suggestion is reinforced by the fact that 'modeling' and 'marvelous' are flagged.

     

    > Actually, it's a pretty straightforward thing to do (a bit of

    > statistical analysis).

     

    Really? No more than a bit of statistical analysis?

     

    Then could you please employ the respective bit of statistical analysis and tell me if the underlined passage is in American English, Australian English, British English, or Canadian English?

     

    > That's entirely irrelevant. Whether US English is a dialect,

    > variety or whatever of British English

     

    Possibly. Or perhaps not. You're talking about "more than one language", of "regularly writing in different languages". Yet, you say it works when dealing with German and English, but not so much when dealing with British and American English… Do you begin to see a glimmer of relevance now?

  • David Neale1 Level 1 Level 1 (70 points)
    Currently Being Moderated
    Dec 21, 2011 7:02 AM (in response to fane_j)

    Glad to see this thread has become active again!

     

    It is a bind that "traveling" and other such Americanisms are not flagged as spelling errors when British English has been selected as the language of choice. Whether the error is at the dictionary level or the system level is fairly mute, as it remains an bug and should be corrected so that texts can be flagged appropriately.

  • fane_j Level 4 Level 4 (3,655 points)
    Currently Being Moderated
    Dec 21, 2011 7:21 AM (in response to David Neale1)

    David Neale1 wrote:

     

    "traveling" and other such Americanisms are not flagged as spelling errors when British English has been selected

    Which other Americanisms? Let's make a list. We could submit it as a bug to Apple, although I suspect they won't pay a blind bit of notice; but, more importantly, it would be useful to any Brit spell checker user.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.