1 2 3 4 Previous Next 56 Replies Latest reply: Dec 9, 2013 1:39 AM by DarthVictor Go to original post Branched to a new discussion.
  • 30. Re: Card Reader is not working
    mosidee Level 1 Level 1 (0 points)

    Fast Tapping Technique work for me too!

  • 31. Re: Card Reader is not working
    donmr Level 1 Level 1 (0 points)

    Fast tap worked for me too!  It was all okay until Lion upgrade. This is too weird!!

    Apple should release a fix for this ASAP!

    Kind of lame/shonky having to fast tap the card like this!

  • 32. Re: Card Reader is not working
    HenkoSch Level 1 Level 1 (0 points)

    I just had this issue today with my MacBook Pro that I updated to Lion.

    Pushing the card quickly into the reader really worked. This seems very strange...

  • 33. Re: Card Reader is not working
    bluryfusion Level 1 Level 1 (0 points)

    Well, i found another workaround comming from another post, related with the "read onlyness" of all my cards...

    The problem of not mounting is probably related with some cotton dust inside the drive, the quick tap technique (I mentioned before) solves it, because its so fast that the cotton doesn't cause short circuit inside the card reader (that's mine theory).

     

    To solve, you just need to use some pressured air and remove all the dust inside the reader, this should solve the problem and start to mount normally the cards. It worked in my case.

     

    If someone has the same problem of mounting on read only mode on every SD cards (not related to the lock button), you could visit this other post (also mentioned above) and follow the steps.

  • 34. Re: Card Reader is not working
    Luis Flores Level 1 Level 1 (0 points)

    OK, I had the same problem and I found a solution. What I do is to insert the card slightly slanted, pushing it from the right corner only (viewing the card from the top).

    I hope it helps.

  • 35. Re: Card Reader is not working
    jibrito Level 1 Level 1 (0 points)

    Awesome! Worked on Macbook Pro 15" 2010 mid!

  • 36. Re: Card Reader is not working
    Gavin4077 Level 1 Level 1 (0 points)

    Having looked in the slot on my 2011 Macbook Pro with a torch, I noticed quite a lot of dust in there. Used an aerosol air duster, inserted a card and it works perfectly!

     

    I think a lot of you might find the same. The slot is going to pick up dust and debris and it's causing a bad contact with the SD card.

     

    If you've cleaned the dust away and it still doesn't work, try gently wiggling it around too.

  • 37. Re: Card Reader is not working
    peter reg Level 1 Level 1 (0 points)

    Possible solutions:

    I bought a cheap Multi card reader but it would not mount my CF card. The LED lit up but it wouldn't mount. System Profiler show the card reader+CF was recognized but OS X 10.6.8 wouldn't mount it. After trying to reinsert it, tap it, check for dust, crooked pins etc. I thought I'd give it one more drastic try. I remember that some CF readers require to insert the CF bottom side facing the top of the reader. I also know that there is a groove in the CF card that is supposed to prevent you from inserting it upside down. I didn't want to damage the circuit or the pins so I carefully flipped the CF card upside down and gently reinserted it. It was a bit snug but I eventually got it to go all the way in. Voila'!! the CF card was recognized and worked perfectly.

     

    It turns out that the Multi reader was manufactured poorly, thus allowing the CF card to be inserted the wrong way. That combined with the unintuitive need to insert the card upside down made it seem like it was not working. But some readers for manufacturing purposes mount the CF or SD card slots upside down so all the electronics can fit on one circuit board and into a small package. Simple crappy design. So after trying everything else out you might want to check if the card is inserted the correct way.

  • 38. Re: Card Reader is not working
    BjornenP Level 1 Level 1 (0 points)

    I have the same problem on MBP os MacOS 10.6.8. A few weeks back the readers stopped working with all cards.

     

    Does not seem like anyone has found the solution for this problem.

  • 39. Re: Card Reader is not working
    Logicalsky Level 1 Level 1 (0 points)

    Thanks guys!

    The tap in works!

     

    I will get some air to cleen it out when I get the chance =D

     

    THANKS!

  • 40. Re: Card Reader is not working
    Mario Abanto Level 1 Level 1 (5 points)

    Ha! This inserting the card slanted method worked for me.

    So as you are inserting the card, push from the corner closest to you.

    I am still taking it to a Genius to get it working properly (thank goodness still under warranty).

    Thanks for this short term solution!

  • 41. Re: Card Reader is not working
    cibin Level 1 Level 1 (0 points)

    Try with new user account

  • 42. Re: Card Reader is not working
    TheAnimaster Level 1 Level 1 (0 points)

    Dag nab it.... it ~~IS~~ a problem with dust! The 'quick tap' 'push at right' etc. thing worked... but what worked best was *wait for it* BLOWING OUT THE DUST FROM THE SLOT.

     

    Who would have knew????

     

    Now I'm just WAITING for SOME manufacturer to produce some nice, stylish caps for the card reader.. SERIOUSLY!

     

    Hey, maybe we can go the way of the v1. iPhone 4 -- but instead of 'bumpers', get Apple to give us free caps for the port. Christ!

  • 43. Re: Card Reader is not working
    eww Level 9 Level 9 (52,975 points)

    Every roll of Scotch Tape contains hundreds of nearly-free airtight "caps" for the card slot — and for any other ports that you don't want to leave open to the dusty world. Use the "magic" tape with the matte finish, and no one will even know your ports are covered but you.

  • 44. Re: Card Reader is not working
    Manuelntu Level 1 Level 1 (25 points)

    This might sound stupid but is the SD card switch on the side one "lock"? It used to sometimes slide to the lock position for me and it wouldn't read. However i am using Snow Leopard so not sure if its a lion issue. cheers!

    -Manuel