Skip navigation

Lion Wi-fi Connection Timeout, Help!

13962 Views 15 Replies Latest reply: Jun 12, 2013 7:33 AM by *nickMcC* RSS
1 2 Previous Next
gagneana000 Calculating status...
Currently Being Moderated
Aug 6, 2011 5:41 PM

After intsalling Lion I can not connect to my Wi-Fi at all. When I try to connect it just says. "Could not join <name>, a connection timeout occured" I even did a clean install of Snow Leopard and then installed Lion. Its not a problem with my router because my iPhone, iPad, MBP, and other computers still connect to it fine. The MBP also has Lion and works great. I am using a 21.5in iMac from January 2011. I have attached my system info. Any help would be greatly appreciated. Right now I'm using an ethernet cable and its working fine.

Screen Shot 2011-08-06 at 5.27.24 PM.png

Heres a link to my system report: http://db.tt/dWki32z

  • Dr Barry Howarth Calculating status...
    Currently Being Moderated
    Aug 7, 2011 5:55 AM (in response to gagneana000)

    I had this problem. I had my iMac & macbook both connected fine for a couple of weeks. Then the imac wouldnt connect. A day or so later, the macbook wouldnt connect.

     

    It was the router.

     

    I reset the router, connected to it directly to my imac using an ethernet cable, changed the ssid & password to something new, deleted my old router info from the imac, connected to my routers new name , used new password, its now connected. Worked for macbook too.

     

    Hope this helps.

  • Monkeybo99 Calculating status...
    Currently Being Moderated
    Aug 9, 2011 7:25 AM (in response to gagneana000)

    Same problem here.

     

    I bought a 2011 MBP 15" and ran it on Snow Lepoard fine. Then upgraded to lion and it worked fine for a few weeks.

     

    Then Wifi just stopped working. I can see wireless networks, at the office, at home, at my parents house, or anywhere else i go, (both new and existing networks) but when i come to connect, i get the exact time out message.

     

    When plugged in to any of these routers with a cable, it works fine.

     

    Its driving me nuts.

  • thaanu Calculating status...
    Currently Being Moderated
    Aug 11, 2011 8:26 AM (in response to gagneana000)

    I also had the same problem just now.

     

    First tried restarting the router and it worked.

     

    Later again it happened, this time I wasn't able to restart the router because my friends were downloading files.

     

    So I removed Wi-Fi from System Preferences > Network. Then re-created the Wi-Fi.

     

    Yet Its working.

  • chicowales Calculating status...
    Currently Being Moderated
    Oct 11, 2011 2:19 AM (in response to gagneana000)

    Hi,

     

    Did you get this fixed as I am having exactly the same problem.

  • adamshand Calculating status...
    Currently Being Moderated
    Dec 14, 2011 9:30 PM (in response to gagneana000)

    I was having this exact same problem and none of the hints listed here (or anywhere else on the internet) were resolving the problem for me.

     

    Eventually I figured out that the problem was a corrupt entry in my keychain.  To fix this I opened up "Keychain Access" (in "Applications/Utilities") and searched for the entry which matched the name of of wifi network.  I then selected all the matching entries (there were two in my case) and deleted them.

     

    After this I was able to connect to the wireless network without any problems.

     

    Hope this helps some other people out there with this problem!!

     

    Adam.

  • charlesfromchevychase Calculating status...
    Currently Being Moderated
    Dec 27, 2011 1:12 PM (in response to adamshand)

    Thanks adamshand.  I had the exact same problem and your fix worked perfectly!  Thanks for sharing

  • nyeates1 Calculating status...
    Currently Being Moderated
    Mar 9, 2012 6:04 AM (in response to adamshand)

    Keychain deletion totally worked for me! Thanks adamshand.

    Screen Shot 2012-03-09 at 8.46.45 AM.png

    For those not understanding how to do it, here are some more details:

    1. Open the 'Keychain Access' application on the computer having the connection issues
      • How to do this?
      • Apple (command)+space bar, then type "keychain", then press 'Enter' when you see the "Keychain Access" application highlighted
    2. In the 'Keychain Access' app, search for the name of the wifi point you are having issues with
      • In the upper right of the window, there is a search box. See screenshot.
    3. Delete the entries you find
      • Highlight the entries that match exactly to the wifi point (no others). You can use shift button + clicking or apple (command)+click to select more than one.
      • Once highlighted, Hit the delete button on your keyboard and confirm the deletion.
    4. Quit the keychain app and try reconnecting to your wifi point
  • adamshand Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2012 12:08 PM (in response to nyeates1)

    Great, glad it worked for you!  As a side note, I haven't had this problem since I upgraded to 10.7.3 … so hopefully this Lion bug is fixed (and I noticed in the release notes they mention fixing a wifi connection bug)!

     

    As an other side note, I realy like having Keychain in my menu bar. Makes it easy to open up and fix things and is also the only way I've ever found to have a menu bar shortcut for locking my laptop. You'll find the option in Keychain's Preferences.

  • fstltna Calculating status...
    Currently Being Moderated
    Mar 20, 2012 9:16 PM (in response to adamshand)

    I'm having the same issue and none of these tips has helped... I was on 10.6.5 and everything was fine. Upgraded to 10.7 and then 10.7.3 and in both versions the wifi would not connect. I tried all the tips in this thread and none helped.

     

    Tried changing the channel number to one not being used, no luck. I have three wifi networks here and my Mac can only see them, not connect to them. On my iPad and other computers things are working fine. So it must be specific to changes in going from 10.6.5 to 10.7. Are there other possibilities like ssid too long?

     

    Please help! I took it into a apple store but the genious who handled it was able to get it working eventually, but the fix didnt last :(

     

    Marisa

  • fstltna Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2012 9:33 PM (in response to fstltna)

    Add-on note: I was using an older Mac with wifi by a USB thumb drive, which I am not using now that I have the Mac mini. Can the old driver be the cause? Anyone know how to check what driver is being used?

  • *nickMcC* Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 3, 2012 8:04 AM (in response to gagneana000)

    For me on Lion it was a firewall issue (seems to be buggy). I enabled the firewall and disabled it. I tried removing all airport (alf) plist files and deleting the connections with no fix in site. Then I stumbled upon this when I started adding "firewall" to google with the same issues.

     

    http://www.dslreports.com/forum/r26129052-OS-X-Needing-to-flush-the-Firewall-rul es-before-Lion-will-conn

     

    Bottom line blow away all .plist in /Library/LaunchDaemon/* .

     

    The following steps worked for me.

     

    • Delete all airport .plis in /Library/Preferences/com.apple.alf*.plist
    • Delete all network connections from network settings
    • Delete all *.plist in /Library/LaunchDaemon

     

    Finally fixed... 3 days wasted.

  • MarMel197 Calculating status...
    Currently Being Moderated
    Apr 8, 2012 12:11 AM (in response to nyeates1)

    Thanks worked a treat!

  • Ca-Bob Calculating status...
    Currently Being Moderated
    Apr 10, 2012 11:27 PM (in response to gagneana000)

    The same problem is happening to me! Every time, I restart my computer, or if it goes to sleep I lose my connection! I get around it by going to System Preferences > Network > Assist me... > Assistant... and then select my network, type in the password, and even though I type in the right password it tells me it's wrong, and afterwards I connect... I am getting very frustrated with this tedious routine. Somone please help me!

  • DorianJ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2012 2:29 PM (in response to Ca-Bob)

    It's evident that there's a serious flaw somewhere when different solutions are working for different users. I tried nickmcc's and adamshand's solutions and neither worked. The one from Ca-bob is what worked for me. Frustrating for everyone, nontheless!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.