Skip navigation

Problem with Samsung SSD 830 in MacBook Pro 5,3

49863 Views 66 Replies Latest reply: Nov 4, 2013 4:15 AM by xirb RSS
1 2 3 ... 5 Previous Next
Rune Jensen Calculating status...
Currently Being Moderated
Dec 26, 2011 8:50 AM

Hi all

 

I just bought a Samsung 830 SSD for my MacBook Pro 5,3 to speed it up a bit. Unfortunally, I am not able to get it working at all. I have tried everything, but nothing seems to work.

 

First I used SuperDuper! to clone my HD and installed the SDD in my MacBook Pro. After clearing the PRAM/NVRAM, the system booted up, I logged in, but the Mac OS X Lion system was extremely unstable. Sometimes I could open a file using textedit, other times textedit simply closed before showing the window. I got a lot of other pretty weird problems, did a lot of reboots because of system failures, and finally I could not even log in to the system any more.

 

Then I decide to boot the MacBook Pro on a Mac OS X Lion startup disk, here I was not even able to delete the partion on the SDD using Disk Utility. I tried a lot of other things to get it working, I even installing the Mac OS X Lion from scratch using another MacBook Pro and then installing the SDD in the MacBook, this did not work either.

 

Finally I gave up and installed the SDD in my MacBook Pro 5,1, here everything works like a charm and I am having no problems at all.

 

My question is now, why is the SSD working in my MacBook Pro 5,1 but not in my never MacBook Pro 5,3?

Has anyone got the Samsung 830 SSD up and running on the MacBook Pro 5,3 and did you something special to get it working?

 

Cheers

Rune Jensen

MacBook Pro, Mac OS X (10.7.2)
  • Expirobo Calculating status...
    Currently Being Moderated
    Dec 28, 2011 1:01 PM (in response to Rune Jensen)

    Please further describe the macbook you are using. Size, hardware, sata port the SSD is on. What does the system profiler say the established SATA connection is? Such as SATA II/III, link speed, and established speed?

     

    Also, what firmware are you using on the SSD? Have you enabled any SSD support such as TRIM, etc?

     

    Also, you said you installed Lion via another MBP and inserted it into yours. Could you explain the other system and how it handled the SSD?

     

    Thanks,

     

    Tim

     

    P.S. SSD's are really finicky in the MBP and take some configuration adjustments to get working. This is due to Apple playing around with their SATA controller voltages to increase battery life.

  • Expirobo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 28, 2011 1:07 PM (in response to Rune Jensen)

    Also, a few forums have help with this issue. Here is one that may help. Make sure you format the drive before installing. A good idea if you can do it, connect via the included USB cable to a windows machine and Secure Erase the drive first. Then check that all firmware is up to date. Then do a clean in stall of OSX Lion with it in the MBP Port 0..

     

    http://forums.macrumors.com/showthread.php?t=1269973

  • CMCSK Level 6 Level 6 (10,220 points)
    Currently Being Moderated
    Dec 28, 2011 1:10 PM (in response to Rune Jensen)
    I have tried everything, but nothing seems to work.

    Have you contacted Samsung?  What did they have you do if you did?

     

     

     

     

     

     

     

     

    Image Hosting by PicVault.info

  • Expirobo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 28, 2011 1:13 PM (in response to CMCSK)

    Man forget about the manufacturer. They will only have you contact Apple and Apple will have you contact them. Please list what I mentioned earlier. Cannot help you without the information. Many people have been able to get the 830 working in a lot of different Macbooks. It's a great drive due to its in house design, where Samsung created all the parts and logic boards themselves. This gives way to great firmware.

     

    Please post all related system information. I'm telling you, without that no one can help.

  • ahersh77 Calculating status...
    Currently Being Moderated
    Dec 28, 2011 2:00 PM (in response to Rune Jensen)

    I feel your pain. I bought a 128GB Samsung 830 Series SSD the week it came out and installed it in my Early 2011 Macbook Pro 13". It worked for about two months. Then, one day Microsoft Word stopped working while I was using it, and my computer crashed. From that point on I was unable to reinstall Mac OS X Lion on that SSD no matter what I did, even though I could install Windows 7 on it with no problems. So then I contacted Samsung who gave me an RMA number. I recieved the replacement, refurbished SSD in the mail today, and I've now spent 6 hours of my day trying to get it working. I've tried everything from formatting it with different programs to formatting it externally and so on. Nothing seems to work, just like you're describing. This SSD has been the most frustrating electronic product I have ever owned. It makes me feel better now though since I've found someone else with the same problem. My advice: Don't waste your time because it will never work. I'm just going to buy another Intel drive, which I have never experienced a problem with.

     

    Good Luck.

  • Expirobo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2011 10:22 AM (in response to Rune Jensen)

    Rune,

     

    Try this. If possible, swap out the sata cables between the two Macbooks. Some of the SATA cables aren't shielded properly from Apple and caused intereference issues. With the SSD being slightly noisy (high frequency noise) and high throughput on the SATA interface, swapping cables with the other Macbook could isolate the issue. If this fixes the problem, iFixit has a replacement cable for a few dollars that is heavily shielded. I'm not sure the compatibility but it's worth a shot.

     

    I think you're having interference and are losing communication with the SATA bus intermittently. Good luck and let us know if it works.

  • Expirobo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2011 10:30 AM (in response to Expirobo)

    Some have reported adding aluminum foil around the SATA cable shields it. I don't believe this as metal, including aluminum, is actually really good at increasing RF signals. BUT, some people have said it works. Check MacRumors and other sites for help. It won't hurt to try it so long as you make absolutely sure you don't let it touch the logic board or and metal contacts on it.

  • fikoko Calculating status...
    Currently Being Moderated
    Jun 19, 2012 3:18 AM (in response to Rune Jensen)

    Hi,

     

    I have a MacBook Pro, mid-2011,8,1.

    I had a Crucial SSD M4, 512 Go that today seems to be dead IO/Error, not recognized anywhere, so I bought a new SSD.

     

    I just got a Samsung SSD 830, 256Gb, (7PC256) and it is not recognize as internal disk on my MBP.

     

    I tried :

    - as external drive of the macbook pro : worked

    - as internal on two computers (sata 2 & sata 3) : worked

    - as external computer disk (usb 2) : worked

    - boot from internal harddisk with MacOSX Lion and try to detect SSD as external worked.

    - boot from external disk with MacOSX Lion and try to detect internal SSD : failed

     

    The SSD seems to worked everywhere, but not as internal of my MBP 8.1, with SSD as internal disk, tried too :

    - reset PRAM/NVRAM : failed

    - change RAM (from 8Gb to 4Gb (Kingston, 1333Mhz)) : failed

    - boot from Ubuntu : failed

     

    The disk is not recognized = not seen in system profiler, not seen in fdisk (Ubuntu); not seen in diskutil, not seen in boot device chooser (option key pressed during boot).

     

    The problem is : the SSD worked, so the vendor do not want to echange it, and the MBP worked with others SSD and HDD, and Apple cannot supply maintenance for third party SSD.

     

    What should I do ?

  • clintonfrombirmingham Level 7 Level 7 (26,755 points)
    Currently Being Moderated
    Jun 19, 2012 3:42 AM (in response to fikoko)

    From the hype that I've read on Amazon about the Samsung 830, even Mac users (2011 models) love it. I have a Crucial m4 512GB that I love, too. The problem might be using the drives in older notebooks, even though they might be SATA as well.

     

    Here's what I did to get mine up and running:

     

    1. Downloaded the "Install Mac OS X Lion.app" from the App Store.

    2. Used Lion DiskMaker to make a bootable USB flash drive.

    3. Installed the SSD.

    4. Booted from the flash drive to erase the drive and create one partition, HFS+ Journaled.

    5. Rebooted and installed Lion.

    6. Rebooted from flash drive again and did a Time Machine restore onto the SSD.

    7. Booted from the SSD and had no trouble with it.

     

    Some people recommend Carbon Copy Cloner and some SuperDuper. And some get a transfer kit. I just used this method and it worked perfectly.

     

    BTW - I'm an 8,2 (late 2011) but I see no reason that this method wouldn't work on an 8,1 (early 2011) as well.

     

    Clinton

  • fikoko Level 1 Level 1 (0 points)

    Thank you, your fast reply :

    Here is what failed :

     

    1. Downloaded the "Install Mac OS X Lion.app" from the App Store : OK, write is very fast

    2. Used Lion DiskMaker to make a bootable USB flash drive : OK, Recovery partition created

    3. Installed the SSD : The SSD replace the original harddisk

    4. Booted from the flash drive to erase the drive and create one partition, HFS+ Journaled : NO, only Internet Recovery is available

    5. Rebooted and installed Lion : NO, no disk detected

  • clintonfrombirmingham Level 7 Level 7 (26,775 points)
    Currently Being Moderated
    Jun 19, 2012 4:38 AM (in response to fikoko)

    Maybe I should have made myself clearer - you need to download Lion DiskMaker and have the "Install Mac OS X Lion.app" on your hard drive so that it can create a bootable USB flash drive (4GB minimum but anything larger will do as well) or burn a bootable DVD (either one but flash will be faster).

     

    Using your 'new' flash drive or DVD boot to same.

     

    Format SSD using Disk Utility (one of four options that will be displayed).

     

    Reboot to USB flash drive (or DVD). Install Lion. Very fast. Your Recovery partition will be installed.

     

    Reboot to flash drive again. Use Time Machine to restore drive.

     

    Everything should work at that point. Just let the SSD boot and put the flash drive aside for emergencies.

     

    Make sense?

     

    Clinton

  • fikoko Level 1 Level 1 (0 points)

    When I boot to USB key, SSD is not visible while it is install inside, even if OSX is installed on it.

  • fikoko Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 19, 2012 2:22 PM (in response to fikoko)

    I finally sold the SSD to someony who needed for his computer, and buy a tested SSD on place : OCZ Vertex 4, 256Go which did not work until firmware update (1.3 to 1.4.1.3).

    After that the SSD work perfectly.

    So, **I think** (i'm not sure !) there is a problem on latest Samsung 830's SSD firmware.

1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.