Skip navigation

Siri doesn't know my home address

52914 Views 77 Replies Latest reply: Aug 20, 2013 4:38 AM by Charismaladyn RSS
  • Colin Martin Level 1 Level 1 (75 points)
    Currently Being Moderated
    Nov 16, 2011 1:41 AM (in response to merrick777)

    Mine worked when I set the label for the dropped pin address to 'Home'. I had another home address as the dropped pin was not a correct postal address, I labelled this 'Address'.

  • merrick777 Calculating status...
    Currently Being Moderated
    Nov 16, 2011 3:28 AM (in response to Colin Martin)

    Thx Colin. Did that. The original address was labeled as 'Home' and the pin drop auto-set itself to 'Other', so I deleted the 'Home' and relabeled 'Other' to 'Home'.

     

    Further, had a long talk with AppleCare yesterday. They swear that NO ONE has ever called in with this issue. When I explained the pin drop idea, he called it "absolute genius". No help frm them.

  • Richard Olpin Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 17, 2011 4:48 PM (in response to Torshen)

    Getting totally fed up with this now. Doesn't matter how I enter my home address, Siri always complains "i don't know where your home is"

     

    I've tried changing the format to remove the house name and just leaving the house number, tried finding our house on the maps app, dropping a pin and storing that to my contact card etc.  Nothing seems to work, it just can't find us.

     

    If I use the desktop google maps it finds me just fine with the exact same address but as it stands Siri on the phone is useless as one of the main reasons I upgraded was for the location reminders which just plain don't work.

  • MyklReinhart Calculating status...
    Currently Being Moderated
    Nov 19, 2011 2:22 PM (in response to Torshen)

    I had this problem and fixed it. Here's my story:

     

    The "home" address in my contact record looked like this:

     

    12345-123 Street

     

    I deleted that entry, and re-entered it with spaces on either side of the hyphen-- like this:

     

    12345 - 123 Street

     

    Maybe this will work for someone else too...

     

    m

  • merrick777 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2011 4:22 PM (in response to merrick777)

    After a lot of frustration, I'm thrilled to finally have this working - It works just as shown on the commercials, and it's VERY cool. Here's a compilation of info I learned... somethng here should get it working for almost everyone (I'll include the obvious things as well):

     

    - Make sure 'Location Services' is turned ON (Settings -> Location Services)

    - Make sure you have yourself set up as a Contact with your address, and (IMPORTANT...) NOT via Exchange Server.  It's fine to use Exchange Server for all your contacts, but NOT for yourself. If this is your problem, go Contacts -> Groups -> All on My iPhone. Set your card up there (so it's actually on the iPhone and not just on Exchange.  If you (like me) have yourself on Exchange and you cannot delete it (because that would remove you from your company data), then just create a second entry for yourself on iPhone and 'link' it to the other Exchange entry. 

    - Just to double check all is cool so far, look up your contact card, tap the address, and Maps should show and drop a pin on your house.

    - Go Settings -> General -> Siri and make sure your contact card is set for 'My Info'.

    - HERE'S A BIG ONE (this one should solve the problem for a lot of people...): Go Settings -> Mail, Contacts, Calendars. Scroll all the way to the bottom, to 'Reminders'. For 'Sync' set 'All Reminders' and for 'Default List' set 'Reminders' (NOT 'TASKS'). Here's the reason..... 'Tasks' cannot be associated with a location, but 'Reminders' can! By changing the 'Default List', you are basically saying to not use 'Tasks' but to use 'Reminders' instead. Note: Reminders basically are the same as Tasks, except that reminders can also have a location associated.

    - Go Settings -> iCloud and make sure that 'Reminders' are ON. (This is another big one!)

     

    Now try a test. If it's working properly, you will see the Location icon (arrow looking thing) on top of the home screen once a location reminder has been set - this means the phone is monitoring your location in order to alert you once you reach the place you set the reminder for.

     

    As far as the actual wording of instructions - it works for me when I say ANY of:

    - remind me when i get home to take the steak from the freezer

    - when i get home, remind me to take the steak from the freezer

    - when I arrive at home, remind me to take the steak from the freezer

    - when i leave home, remind me hook up my bluetooth

    - when i leave my house, remind me to hook up the bluetooth

     

    If you want to do a test, try saying "Reminder" and it will ask "Tell me what u want to be reminded about'. Say "Prepare dinner", and it will ask "When do you want me to remind you?". Say "when i get home". Note: Look at the screen - the text should be labeled as a REMINDER, not a TASK.

     

    Hope this helps anyone...

  • Notintune Calculating status...
    Currently Being Moderated
    Dec 7, 2011 9:51 PM (in response to merrick777)

    Thank you Merrick 777 -- very good post.  One change, however.  You have to do the "Go Settings" item you list before you do the "HERE'S A BIG ONE".  If you do them in the order you listed, the Reminder setting will not show. 

  • merrick777 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2011 9:59 PM (in response to Notintune)

    Yep... that makes sense. Thanks

  • djdarwinnyc Calculating status...
    Currently Being Moderated
    Dec 19, 2011 4:34 PM (in response to Torshen)

    i had the same problem but I fix it changing the label "Address " to home

    go to you contact card

    edit

    on the addres field change the label

    home

    work

    or create your own label

    i hope it works for you

  • rsailer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 23, 2011 9:02 PM (in response to merrick777)

    merrick777 wrote:

     

    and for 'Default List' set 'Reminders' (NOT 'TASKS')

    I couldn't see where to set "Default List". it was not where I told Siri to sync "all reminders.

     

    Thanks,

     

     

    Randy

  • rsailer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 23, 2011 9:19 PM (in response to rsailer)

    figured it out. the list is in the reminders app and I only get the choice if I set up more then one list (which I did). That gave me the choice in the settings>mail, contacts, calenders screen at the bottom for a default screen. When I made the choice, things started to work better.

     

    I need to use the phrase "Remind me" to create a task with either a date or location associated with it. If I use the word "Remember" to start the item, Siri creates a generic item without time or location associated with it.

     

     

    rsailer wrote:

     

    merrick777 wrote:

     

    and for 'Default List' set 'Reminders' (NOT 'TASKS')

    I couldn't see where to set "Default List". it was not where I told Siri to sync "all reminders.

     

    Thanks,

     

     

    Randy

  • dilipc Calculating status...
    Currently Being Moderated
    Dec 30, 2011 2:45 AM (in response to Torshen)

    I think the problem is they way we write out our address in our Contact card. If Google maps doesn't recognize it the way we write it in the contact card, Siri can't find it.

    What worked for me was:

    I wrote my home address in a way that when I clicked on it, Google maps would place the pin on the correct spot on the map. Then I asked Siri what my home address was, and it showed it up from my contacts. I did the same for my work address.

    Since, then, it's stopped saying "I don't know where your home is" etc.

  • ChrisHGS Calculating status...
    Currently Being Moderated
    Jan 10, 2012 2:32 PM (in response to Torshen)

    I tried everything you guys said and Siri is still not reminding me when I get home. I say remind me to ".........." when i get home and she says she will remind me to"............" when I get home.The arrow in the top bar is even there after I say it. When I get home she never reminds me. what do I do?

  • JmzMc Calculating status...
    Currently Being Moderated
    Jan 12, 2012 5:02 AM (in response to Torshen)

    Hi I have just figured it out, incase im late and you have all figured it out im sorry - I didnt read all the posts lol

     

    I changed my Contact address details to

     

    Street - The Number and Street!

    City - BLANK

    County - BLANK

    Post Code - Postcode

     

    So Basically it was 53 Lincoln Park

                                 Eh299DO

                                 United Kingdom

     

    And I dont the same for my work address too and it works fine

     

    Hope this helps if you havent already worked it out lol as I said I didnt read the other posts!

     

    @JmzMc

  • DTM-73 Calculating status...
    Currently Being Moderated
    Jan 16, 2012 12:01 PM (in response to Torshen)

    I was also suffering the same problem with my home address. Based in a previous rely my address already had United Kingdom in the country field but I edited the address and selected United Kingdom again. Only then did Siri know where I lived.

     

    Go ahead and try it, even if your address contains United Kingdom, edit the contact and select United Kingdom again. It seems that selecting it the second time make an update somewhere that allows Siri to work.

  • kevnash Calculating status...
    Currently Being Moderated
    Mar 4, 2012 2:03 PM (in response to Torshen)

    I have had the same problem, but I have solved it,

     

    I went to maps, clicked on the blue circle (current location)

    clicked on the blue arrow next to it

    It showed my address with a number range I.e. 1-5 road name

    I then clicked add to existing contact

    Added it to my contact and changed the number to my house number

     

    Interestingly it set my county to England

     

    Anyway it now works for me!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.