Skip navigation

AirPrint Activator to work with iOs 5?

18202 Views 35 Replies Latest reply: Apr 1, 2014 1:53 AM by David Wilkinson6 RSS
1 2 3 Previous Next
LossAngeles Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 13, 2011 7:34 PM

I've checked out everything and the service for Windows is handling iOs 4x devices fine. The iOs 5 devices can't find my printer now.

Thx for any tips or solutions.

-Greg

 

 

 



iPhone 4, iOS 5
  • Groverwood Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 17, 2011 4:07 AM (in response to LossAngeles)

    I ran into the same problem. I was using Airprint.exe to print from my Ipad and Iphone, and IOS5 just plain broke it. I found a new utility called "Fingerprint" and this solved the problem quickly and easily...  I'm not affiliated with this company at all, just a satisfied user wanting to spread the word.

     

    http://www.collobos.com/

  • paulfromhere Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2011 5:46 AM (in response to Groverwood)

    It's possible to use free software (Virtualbox and Ubuntu) to fix the broken iOS 5 Airprint printing with non supported printers.  Here's a fix that works on my imac, but should also work on even a windows pc.

    My setup is a lion imac with 2 non-airprint supported usb printers attached, a belkin wifi router that provides network connectivity for my imac, ipad, and iphone.

    Install ubuntu 11.10 in a virtualbox vm.  Specify to use the "Bridged Adapter" with "en1: WiFi (AirPort)" for the network hardware.  Make sure the imac's usb printers are setup with sharing.  On ubuntu, select System Settings > Printers and add your imac's shared printers to the list.  Then start ubuntu's firefox and set "localhost:631" in the address. On the administration tab, under the Server section, check "Share printers connected to this system" and hit Change Settings button to activate it.  Go back to ubuntu's printer setup, and right click on each printer and check that the properties Policies tab does not have any messages about it being unshared. If so, then go back to firefox and make sure the Server sharing checkbox is enabled. It may help to reboot.

    Fire up virtualbox to be able to use AirPort printing to your imac's usb printers, when you want to print from the iphone or ipad. This also works on iOS 5.

    Only problem is error message from iphone to check the printer for errors, even though it actually prints ok.

     

  • Guimon Calculating status...
    Currently Being Moderated
    Dec 14, 2011 8:20 PM (in response to LossAngeles)

    I was able to make Airprint work with IOS 5 !!! here is what you need to do :

    First , if you had installed Airprint before and if the Airprint Service is still in your Service list ( you can check by running the command: services.msc ) you need to unregister it .

    to do so type at the command Prompt  ( Make sure your run the command line as an administrator ) :

     

    sc.exe delete Airprint

     

    Now we are going to re-register the Airprint service but with a slight different Command option:

    At the command line type the following 2 commands:

     

    sc.exe create AirPrint binPath= "C:\Program Files\AirPrint\airprint.exe -R _ipp._tcp,_universal -s" depend= "Bonjour Service" start= auto

     

    sc.exe start Airprint

     

    at this point , you should now be able to see a list of your shared printers from your IOS 5 Device !

     

    If you don't see your Printer, make sure your firewall is not blocking port 631.

     

    If you don't see any lock icon next to your printer name, then you're good to go !

    If you see a lock icon next to the printer name, make sure you enable the guest account in windows

    Once you enable the guest account , restart the Airprint service and Voila ! you now can print from your IOS 5 Device !

     

    Want to thank Takelei for finding the solution to this issue !

     

    Guimon

  • jordi girona Calculating status...
    Currently Being Moderated
    Dec 29, 2011 2:39 PM (in response to Guimon)

    Thanks!

     

    This solve the print problem on my ipad 2.

  • Newstech Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 30, 2011 5:02 AM (in response to Guimon)

    This was exciting to read but it's not happening for me on an iPad 1. Has anyone else made it work on a 1? I've tried various log-on settings, restarted Bonjour, rebooted iPad, etc.

  • Newstech Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 30, 2011 6:36 AM (in response to Newstech)

    Update: I'm playing peek-a-boo with my printer. After a PC reboot I saw it available on the iPad briefly, with the lock. I reenabled my guest account. After that, it was there, but didn't print. When I clicked again, it had gone away. I'm on Windows 7 Home Premium. Looking for tips on permissions, etc. Should I run the Airprint service under my own (administrative) logon, or Local System? This is nuts -- so near, but yet so far.

  • Peter Gillespie Level 6 Level 6 (10,760 points)
    Currently Being Moderated
    Dec 30, 2011 6:49 AM (in response to Guimon)

    Excellent now working again on iPad and iP4 thanks for posting solution

  • Newstech Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 2, 2012 5:29 AM (in response to LossAngeles)

    This has changed from previous functionality. It will not prompt for the password. That's why you need to enable the guest account.

  • Newstech Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 2, 2012 5:31 AM (in response to Newstech)

    Update 2: Still playing peek-a-boo. Had it working like a champ for a while, but printer then goes invisible and restarting services doesn't bring it back. Would love to find a method short of rebooting PC.

  • Newstech Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 3, 2012 9:00 AM (in response to LossAngeles)

    For what it's worth, I just went through three cycles where my Canon shared printer was not visible via Airprint, and I reset my router, and the printer immediately popped up on the iPad as the router restart finished. I have a Rosewill RNX-EasyN400, which I think is still only draft-n compliant. Dang! Looking for possibly relevant settings in the router, but this might be my incentive to buy an n-compliant router. Again, Windows 7 Home Premium 64-bit, Canon i860 printer, iPad 1, airprint.exe with the new startup commands.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.