Skip navigation

"Reply All" re-sends to me! So annoying!

62911 Views 42 Replies Latest reply: Nov 18, 2013 10:50 AM by Nick Johnson7 RSS
  • joseph281 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2012 7:52 AM (in response to pieceolease)

    I'm having this same problem on Outlook 2011, Exchange 2010 and only since moving to Lion on a new system. My email usually ends up in the "To:" field, not the "CC:" field.

     

    The main Mail account in Systems Prefs was for my @me.com account, but i changed that to my work email. Problem still exists.

     

    For my work email, i have two alias. Full.name@ and <4letter-short-form>@ - in Outlook prefs i have only ever had my work email in the short-form associated with the account.

     

    any real fix, or are we waiting on MS or Apple to fix this?

  • bacole Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2012 7:25 AM (in response to joseph281)

    its the same (generally) as the mac mail users.  i was having the same problem with an exchange server account after switching from mac mail to outlook (still not sure that was a good idea).  never the less, go to outlook/preferences/accounts and make sure the email in the address field is the email people are emailing you to.  for example - at our company i have three aliases, but pretty much everyone uses one of those for me consistantly because of the area in which i work.  however, when the account was set up, the umbrella company email was used.  i switched it to what i get emailed to the most and it was fixed immediately!

  • joseph281 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2012 7:28 AM (in response to bacole)

    GENIUS! that worked...

  • sallyatwood Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 25, 2012 3:46 PM (in response to relativitydrive)

    This was SO helpful. I also didn't used to have this problem, and then it started happening and was driving me CRAZY. Turns out that at some point the address is my preferences got changed, and it wasn't matching the one in the emails.

     

    It is now FIXED. I can't thank you enough!!!

  • mozartd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 9, 2012 10:23 AM (in response to pieceolease)

    I had the same problem reinstalling Lion, everytime I replied all I was recopied. I do have an alias. Solution: found this in another thread and wanted to share.

     

    In OS LION Mac Mail program, add additional email (alias)addresses in Preferences -> Accounts -> "Account Information" tab -> "Email Address" entry, separated by one comma and a space each. This prevents Mail from replying to myself.

     

    example:  joe@gmail.com, joesalias@gmail.com 

     

    this resolved my issue and no more reply alls yay!!

     

    good luck!

  • tedmacwpg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 10, 2012 7:00 AM (in response to jarrob)

    That worked for me on both the Mac and the iPhone -- each had suddenly started including me in replies to all.  Think it may have changed with iOS 5.1 & the associated Lion update?  In any case, it worked for me.  Thanks!

  • 7heavens Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 17, 2012 1:25 AM (in response to pieceolease)

    I had similar problem when I did a clean install of Lion and had to set up Manually my emails again, but I was able to fix it.

     

    I started to see my email included in the CC when I was using "Reply to All". After checking this discussion, I went and double-checked the information I entered on my email on Preference -> Accounts, and realized that there was a typo in the field "Email Address", which was not preventing the email from working (it seems that the system rather uses the Email address defined in "Use Name" just below "Incoming Mail Server" on IMAP settings). When I fixed the Typo, I stopped being in the CCed of the "Reply All".

  • esqalade Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 20, 2012 12:50 PM (in response to 7heavens)

    I had the same problem with my iPhone 4 when using my Gmail account via IMAP.

     

    It came out of nowhere, no change in settings or account info, just started adding me to the CC line when I hit Reply All to an email. I deleted the IMAP account and then immediately added it back onto my iPhone and problem solved.  Cant explain it but wanted to put it down in case it helped someone else.

  • rodneyjays Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2012 6:40 AM (in response to relativitydrive)

    @ relativitydrive: I had the same issue but after reading your post, I checked my account and realized that I was using an alias address (firstnamelastinitial@company.com) in Mail instead of the address that is listed in our company directory (firstnamelastname@company.com). So when someone in the company sent me an email, it would go to firstnamelastname@company.com and when I hit reply all, I would get the CC. I changed the address in Mail account settings and voila, no more CC's from myself.  Thanks!

  • davidfromgulf breeze Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2012 8:09 AM (in response to rodneyjays)

    I have just tested this aginst Outlook 2011 and Mac Mail and i cannot get it to add my email address when i "reply to all"..

     

    I do not know if this is now fixed in 10.8.2 or not, but i can not get it to have the issue you guys are having.

     

     

    This is using my Exchange server and like i said,i tested with Outlook 2011 and Mac mail

     

    OSX 10.8.2

  • rodneyjays Level 1 Level 1 (0 points)

    See images. This is the best way I can explain the issue. ** You must have an alias email address that delivers to the same mailbox.

     

    The Exchange account email address is rodneystevens@company.com. rodneys@company.com is the alias. If I reply-all on a message that comes to rodneystevens@company.com, Mac Mail includes me in the reply since rodneystevens@company.com doesn't match rodneys@company.com which is in mail preferences.

    alias address.png

     

    By changing the email address in Mac Mail preferences to rodneystevens@company.com, I no longer am included in the recipients when I click reply-all.

    account address.png

     

    It should be understood, though, that if someone sends an email to rodneys@company.com when it's setup as rodneystevens@company.com, I would again be included in the reply-all recipients.

  • imperio-latino Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2012 8:35 PM (in response to pieceolease)

    you cann't use this vercion of mail with this vercion of mac os x is the messege do i have in my computer.can you help me please.?

  • codfi.sh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 6, 2013 6:44 AM (in response to bacole)

    That's awesome, thanks! It was so very annoying, once I switched over to Outlook (definitely not regretting, Mac Mail is decent at best) and it continued to happen, I knew it was just Mac Mail sucking.

  • moleswm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 7, 2013 6:17 AM (in response to pieceolease)

    I used the above fix (changed the email address in preferences to the correct alias) in Outlook for Mac 2011 and it worked, thanks for the solution!

  • Andy Guss Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 4, 2013 7:34 AM (in response to Beavis2084)

    This is NOT true. Neither Outlook nor Entourage does this by default. Not even FREE email services, like Homail or Yahoo, do this. Moreover, and this is the inexcusable part, they all have settings to automatically include yourself as a cc:. What MORON designed it this way? You give me the opportunity to automically include myself as a cc: and then send it to me anyway? What the frick? It's a moronic design and a valid gripe. Apple should at the very least include a setting to control this.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.