Skip navigation

"Netflix is currently unavailable. Please try again later."

142747 Views 222 Replies Latest reply: Dec 6, 2013 6:45 PM by DCanadian RSS
  • Johnne25 Level 1 Level 1 (0 points)

    The problem still happens for me.  I have been watching others tv shows all week, my problem seems to be with the show TopGear UK.    Probably other shows as well, but that is the one I want to see.

     

    Of course apple says the problem is not there's since other shows work.  Of course NEtFlix says it works good at there end so it must be an apple issue.

     

    When I told netflix apple said it wasnt their issue Netflix quick changed there blame to my service provider and I must be getting slow throughput.  Odd only one tv series is effected by it.

     

    I still can't watch TopGear on my Apple TV.  At least it still works on my phone.

  • xerenthar Calculating status...

    South Park was my trouble spot too. Working free and clear now!

  • Earnest Rutherford Level 1 Level 1 (0 points)

    Bottom line, no matter what you do on your end, this IS an issue that Apple needs to own.

    Just follow the facts:

     

    I am working, then the ONLY change that takes place before it breaks is a firmware update to 4.4.3

    Switching back to 4.4.2 fixes the problem instantly.

     

    All of the DNS crap, etc is merely trying to expose WHAT they changed in the firmware update that broke it's ability to play various netflix titles.

     

    fact, no other devices are suffering this issue. roku=fine, blue ray player=fine, ps3=fine, ipad=fine.etc.

     

    You can safely conclude that it's indigenous to the apple tv(2) and that the changes the firmware 4.4.3 update made (WHAT changes we have yet to discover) are what breaks the playability of certain titles.

     

    Based on what I've read in this thread, if we were to make a list of titles I bet we could get a common factor from that.

    If we all cooperate and post what would NOT play perhaps it would shed some light.

     

    for instance,

    I can't play star trek tng. maybe you never tried. it would be nice to know if you DID try, whether or not YOU can play it. if you CAN but I cannot then that would suggest ISP. If we both cannot then DEFINITELY with conclusion, the firmware change has modified something in how it''s netflix client retrieves streams.

     

    If all devices were having this problem THEN it would suggest that netflix made some booboo with their ""shortcut" that you click to play that selected title which is broken or pointing to a media streaming server which is no longer at that IP.

     

    So with what we have so far, fair conclusion is Apple fockered it up with their firmware update.

    Rather than dodge blame, why not keep your consumers happy with:

     

    "We apologize for this inconvenience and are workng around the clock to get this problem resolved. you may check here: http://www.apple.com/netflixrepair to view the status of the resolution. We apprciate your business and hope you will be understanding in working with us until a solution is in place.  While you are waiting, please go to http://www.apple.com/netflixworkaround  for full instructions and downloads to downgrade your firmware so you may begin immediately enjoying your titles again. Please note this temporary fix requires a mac or pc running itunes."

     

    Mac gets bashed so much because they really crap on their consumer base quite a bit.

    Microsoft does the same thing but they don't charge top dolllar.  When you are a minimum of 40% above the entire market's cost, you are then required to support your paying staff.  Ruth's Chris would NEVER get away with charging $60 a person if they said "Sorry Charlie" to miscooked steaks... they'd flat be out of business for it too...

     

    I have been in I.T. since the CPM/Punchcard days and grew up via vmx,unix,windows and now linux.  I never desired apple products because they were always overpriced.  Apple has majorly improved it's product line and has surpassed almost every major manufacturer in the last 7 years.  As a consumer/home product they OWN the market today.

    They make an iphone, all of the suddent there's a smartphone boom and droid is born.

    they make an ipad and all of the sudden there's a new need for tablets.

    hp NEVER made a single unti screen system.......until the imac did...

    they are no longer competing, they are leading... NOW I have chosen to buy a lot of their products because they are NOT overpriced. Just like a ruth's chris steak isn't. IF and only IF they back that steak up with free replacements on miscooked, and provide their stellar table service. if they neglect those points then it's just an overpriced steak.

     

    APPLE, monitor this thread. learn that you can't reply on image and marketing alone. eventually you have to deliver the image you project.

     

    So far I am very pleased, but let's not get compacant and use the buyer as a wanton test bed and leave the first gen buyers miffed and empty handed.  This is a tiny issue but it shows something I hope doesn't become a trend in your customer support model... be better than HP and dell with their "india remote service model" and show you are the pro USA commpany you pay Bono to promote you as.

  • RobertJ Level 4 Level 4 (1,190 points)

    That is the the longest and most incoherent tome I've ever read on a forum and I moderate two forums (not Apple).

     

    The fact remains that I had trouble with a couple of TV shows around the holiday. I still have the same two versions of ATV firmware and now have no problems.

     

    Netfix, support supervisor, told me they had server configuration issues during the holidays and wasn't sure they had them all fixed yet.

     

    Note: Apple uses a different set of messaging protocols than roku which is why the ATV UI is much easier to use than the rudimentary roku UI. Netflix failed to update some of it's servers.

  • _Skull Level 1 Level 1 (5 points)

    @robertj

     

    You put blame on Netflix but I never had this issue until the update to 4.4.3 and many have switched back to 4.4.2 and everything works fine. No matter how hard yo try to explain how it is a Netflix problem the fact is that 4.4.2 does not have the problems disscussed here but 4.4.3 and 4.4.4 both do.

     

    I am on 4.4.4 and am still having problems. When I try to watch Staragate SG1 I may have to select it several time before the season and episode menu will load I get the Netflix is currently unaviable and after selecting and then going back several times I finally get to the episode menu. Then after watching an episode when it has ended it will almost always go to the Netflix is currently unaviable screen instead of the episode menu and again after selecting it several times it will finally go to the menu. I also have problems with it going to the next episode to watch in the series and sometimes it will go back to season 1 episode 1.

     

    This is an APPLE problem and they need to address it instead of blaming Netflix. Something in the menu system is screwed up in the last two updates. If nobody is having this in version 4.4.2 and everything was working fine, as it was for me then all of a sudded after upgrading to 4.4.3 everybody is having all these menu problems that is proof enough that APPLE bears some if not all responsibility for the problems we are having.

     

    I have no problems with my blue ray player. my ipad2 or my android phone only my Apple TV2 and this wasn't a problem until I upgrded to 4.4.3.

  • Earnest Rutherford Level 1 Level 1 (0 points)

    while i appreciate your unsolicited and candid take on my "tome" (although diatribe would have impressed me more)

    it's self depricating to show it was incoherent for you. Whether or not my long winded nature is well met, you prove yourself to be at the very least biased (or perhaps too rushed) when you make a summary judgement on what I can demonstrate with any debate in return that my findings are sound based on THE FACTS AT HAND.

     

    Sure it is possible that netflix has multiple points of access to the same resource but nothing I have crossed supports that supposition.  Further to complain in a forum about it's participants or their posting style is like complaining about the unhealthy nature of the menu at burger king.. you just look like a whiny ***...

    but then again you are a moderator so it's no surprise to me you are all self, ego, ID and nothing beyond that when interacting with the remainder of the race... either way, I know what I am talking about and I have yards of technical experience to back up my claims. Your explanaition would be plausible if this was customer wide for netflix subscribers.

     

    the fact that it's local to atv users.... well you just show me that you don't need the facts in the case, you're too busy being right.

     

    this was approximately your length of posting so hopefully it's not the longest you've seen. btw if that is the longest you don't get arund much.....

  • RobertJ Level 4 Level 4 (1,190 points)

    What can I say,

     

    Netfix, support supervisor, told me they had server configuration issues during the holidays and wasn't sure they had them all fixed yet.

     


  • Earnest Rutherford Level 1 Level 1 (0 points)

    Fair enough but inarguably, the $9/hr netflix employee you are putting all of your chips in, does not work for apple.

    Also they stated "holidays" which is a conflict because if you read this thread in it's entirety clearly this cropped up well before "holidays" and would suggest the problem we are speaking of in this thread is not related to the one you are pointing out.  Whether or not they did have/are having issues with their servers, it's certainly not unreasonable at this point to say it is conclusive the firmware upgrade on an atv breaks the netflix client. It is also conclusive that no other devices are having this issue.  I am only asking for something more to support your claim other than "I talked to a guy who answers the calls for netflix" because frankly, and no offense to anyone in a call center (did myself at hp for 6 years) but sometimes there are some genuine crack heads taking those calls and lies are not hard to be told. 

    Or, then if your helpdesk assistant is correct & their servers are all whacky, why does my ps3, ipad, iphone, samsung bluray all work perfectly fine with netflix? (and my pc)  I am fine with you presuming its a server issue and me sticking to my findings, nothing personal or emo here, just hoping I can get more than someone's word... facts go far w/ me.

  • Digitalclips Level 1 Level 1 (0 points)

    What is weird is all my issues have cleared up.  Latest Apple TV 2, latest softewate updates ... Netflix working perfectly.  I did have a few issues last November but not now.  So I am curious how there is a problem for some and not others, it's not as if they can be running weird extensions or anything as with a computer.  Did you try erasing the ATV2 and starting over?

  • Earnest Rutherford Level 1 Level 1 (0 points)

    No I am running 4.4.2 That was my fix. It wants me to take an update but I haven't b/c I was afraid it would break netflix again.  It sounds like their latest release  (perhaps the one you have) works? is it 4.4.3?

    Maybe there was a corrupt push back then? who really knows but somehow apple resolved it possibly. I will try when I get home and post my findings here.

  • Goodblessings Calculating status...

    I had this problem too and seem to have resolved it.

    In Apple TV settings the default location was set to Cupertino (US).

    By changing this setting to Auto, it correctly identified me as London.

    After this, and a reboot of AppleTV (unplug, leave a while, replug in)

    Netflix has been completely stable.

    Hope this helps.

    M

  • William Dalzell Level 1 Level 1 (15 points)

    My problem seems to have resolved itself also. When I read that it seemed to be fixed I reactivated my Netflix account and, although we have only tried a few TV series we had been watching, they played without the unavailable message or reverting to series 1, episode 1, or any other strange behavior.

  • ABassCube Calculating status...

    Wow, it's been a few pages since I commented on this thread, and I can't believe this is still an issue. This has to be the longest running consistent bug I've ever seen with an Apple product.

     

    I still can not ever go into the episode list for Buffy the Vampire Slayer. I have found a work-around--as a few people posted awhile ago, if you navigate to the show (i.e. in the Recently Watched page, or the Instant Queue) and just press the Play button on the Apple Remote, it will automatically play the next episode you were up to just fine. If you, for example, start watching the episode you want on another Netflix device, like an iPhone or on netflix.com on your Mac, it will remember the episode you're up to, and when you press Play on the ATV, it will automatically play the episode flawlessly. You can then keep doing this to just play all the episodes in order. However, this is a rather annoying workaround, as it prevents you from going into the list and picking a different episode out of sequence, or of seeing any episode descriptions.

     

    Again, this issue is definitely not consistent; for some people it fixed itself eventually, possibly after applying 4.4.4, or for certain problem shows it just fixed itself automatically. I was having this problem with several other shows, but all the others fixed themselves after awhile. Occasionally I'll still get the "Netflix is currently unavailable" message for a non-Buffy series, but usually if I just back out and go back into it, it'll be fine. I'm baffled as to why with this one single series, I can not ever access the series/episode list, and have never been able to since mid-November. I have read almost this entire thread, and from what I can see, I'm the only one who has had this long a consistent issue with one show.

     

    Can anyone else verify whether they have a show--whether or not it's Buffy--that has consistently given that error message when trying to go into the series list, for more than a few weeks solid? It's also very strange that the problem shows seem to differ for each person--although there seem to be a few that consistently have issues for many people, such, South Park, 24, Top Gear, Star Trek, etc. As far as I've seen though, I'm still the only one that's reported issues with Buffy.

     

    The problem definitely seems to be related to accessing the season/episode list for a series, since pressing Play on the show itself will automatically play the next episode just fine, at least for me. Since it seemed to start affecting people right after the 4.4.3 update, but also comments from Netflix customer service saying they've been having server issues, it seems to be a bit of both Apple's and Netflix's problem. It has been widely said that ATV uses different servers than all other Netflix-ready devices, so it's clearly something to do with how the ATV communicates with Netflix.

     

     

    Unlike many others I have not tried downgrading to 4.4.2, but since it's only that one show and I have figured out a somewhat acceptable workaround, I don't think it's worth it and will just wait for an update that will fix it (hopefully coming soon, Apple!) But it's still interesting to read other people's experiences. We need to keep this thread going until Apple and/or Netflix fix the issue!

     

    Adam

  • RobertJ Level 4 Level 4 (1,190 points)

    I was looking into this out of curiosity and came up with the following information and thought I would post it here.

     

    • Netflix has no servers. They run their entire non DVD world from the cloud using Amazon Web Services Elastic Compute Cloud (Amazon EC2).

    • EC2 gives them the ability to ramp up capacity on weekends and evenings and ramp it down during weekday days.

    • EC2 also makes it easy to move their services out of the US. The main constraints are licensing content in other countries and unique DRM techniques.

    • Netflix doesn't have a different "virtual server" for ATV. Netflix uses HTML5 and a custom Netflix port of WebKit to support over four hundred devices. In the case of Apple, they (Apple) builds the UI themselves. However, Netflix builds most of the UI software for the majority of the devices.

    • There is an excellent article here http://functionsource.com/post/netflix-feature that goes into more detail.

     

    This is a high level view of the Netflix architecture on AWS EC2.

     

    Screen Shot 2012-01-16 at 12.38.32 PM.png

     

     

    As to the issue which is the subject of this thread, perhaps this quote from the above article offers an idea,

     

    "Rather than attempt to distribute their custom runtime on iOS devices [OS for ATV], Netflix has opted to make use of iOS’ own embeddable WebKit instance".

     

    So it is plausible that Netflix was the source of the issue which was ultimately resolved (for many) as Netflix fixed the bug(s) and pushed the software to their various instances on AWS EC2.

  • brbjmich2 Calculating status...

    Adam,

    Thanks for your full problem description and history. I have had exactly the same experiece for the same length of time except for the show. My problem is with One Tree Hill. Your workaround is working well for me. i appreciate it.

    Beth

1 ... 9 10 11 12 13 ... 15 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.