Skip navigation

FCP X not showing Music, SFX or Still picture library

364 Views 5 Replies Latest reply: Jan 18, 2012 5:07 PM by Hisham RSS
Rileyroo2SA Calculating status...
Currently Being Moderated
Jan 16, 2012 10:20 PM

Although I have both iTunes and IPhoto operating fine FCPX is not showing either to allow me to select directly from them. Neither icon in the effects window (bottom right) shows anything other than in one case 'Photos' and in the other "Music and Sound". A work-around for the photos has been to import them as an event but that is messy - there are enough events already! BTW I have the latest FTPX version running and am using Tiger 10.7.2. I have also tried running FCPX with the other two programs both open and closed...  nada!

Final Cut Pro X, Mac OS X (10.7.2)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.