Skip navigation

Safari 5.1.2 continuing lack of pdf display

2587 Views 23 Replies Latest reply: Feb 6, 2012 11:47 PM by haibo RSS
  • Linc Davis Level 10 Level 10 (108,150 points)
    Currently Being Moderated
    Dec 1, 2011 6:37 AM (in response to jwainwright)

    After that hack, you'll no longer be able to view any QuickTime content, such as videos, in Safari.

  • mthopkn Calculating status...
    Currently Being Moderated
    Dec 1, 2011 7:45 AM (in response to jwainwright)

    I updated to Safari 5.1.2 yesterday, and my .pdf plug-in quit working. After reading these posts I removed the quick-time plug-in and .pdf is working again. I hope Apple addresses this soon, as I need both plug-ins.

  • Linc Davis Level 10 Level 10 (108,150 points)
    Currently Being Moderated
    Dec 1, 2011 7:48 AM (in response to jwainwright)

    There's a finite number of configuration files in your home folder that could be causing the issue. I don't know which one it is. It's certainly an Apple-installed file, not a third-party file. In your place I would dump the file "Library/Preferences/QuickTime Preferences," and if that didn't help (after a logout), I'd be combing through my preference files with a property-list editor such as PrefSetter (free) until I found the right key/value combination to reset. However, that troubleshooting technique is too difficult to be recommended on this site. What I usually suggest instead in this kind of situation is the following crude substitute:

     

     

    First, back up all data if you haven't already done so. No matter what happens, you should be able to restore your system to the state it was in at the time of that backup.

     

    In the Finder, hold down the option key and select Go > Library from the menu bar (Lion) or otherwise open the Library folder of your home folder (pre-Lion.) From the Library folder, move the entire contents of the subfolder Caches (not the folder itself) to the Trash, then log out and log back in. Empty the Trash. Test.

     

    If the problem is not solved, open the Library folder again and move the entire contents of the subfolder Preferences (not the folder itself) to the Desktop. Log out and log back in. The account will then be pretty much in a clean state. Test. If you can still reproduce the problem, then put the Preferences folder contents back, replacing any that were created in their place, log out, and log in again.

     

    If you can't reproduce the problem in the clean state, then start putting things back in the Preferences folder piecemeal, starting with items that seem unrelated to the issue. I can’t be more specific. After each group of items, repeat the log out/log in cycle and test. At some point, the problem may reappear, in which case you know that something in the last batch of files you restored is at fault. If it never reappears, the problem is solved.

     

    This will be a very time-consuming process, but that’s the best I can do in this setting.

  • giantELF Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 17, 2012 12:45 PM (in response to jwainwright)

    I had the same issue.  Something Linc said did give me an idea. 

     

    I went into the Library folder from the Macintosh HD.  Inside the internet plugins I saw a file with Adobe PDF viewer in the title.  (I trashed it before copying the name...sorry).  I restarted Safari and now it works.

     

    This plugin was not in the library folder that is accessed via the home folder.

     

    Check it out. 

  • Charles Buckheit Calculating status...
    Currently Being Moderated
    Jan 19, 2012 7:55 PM (in response to jwainwright)

    Plugin stuff didn't work for me. Here is something else to try...enable the Debug menu. I did it with cocktail but it can be done using

     

        defaults write com.apple.Safari IncludeDebugMenu 1

     

    Open the debug menu and make sure things like 'Enable full page acceleration' and 'Enable Canvas accelerated drawing' are not checked. You may need to restart safari at this point. Now try to open a pdf link.

     

    And yeah if you have to know, I was tinkering with them about a week ago, so my problem was completely my own damm fault!

  • haibo Calculating status...
    Currently Being Moderated
    Feb 6, 2012 11:47 PM (in response to Charles Buckheit)

    Thank you Charles! That solved my problem!

     

    I never installed Adobe Reader on my Mac and the Safari opened PDF files perfectly before I played around the "Debug" menu few weeks ago. After unchecking the "Enable Full Page Accelerated Drawing" and "Enable Canvas Accelerated Drawing"  Safari loves PDF files again!

     

    Just like Charles, that was my own fault. I even didn't know what the two options mean when I checked them!

     

    By the way, you can check "Show Develope menu in menu bar" in Safari's Advanced Preferences to have the "Debug" menu showing in the menu bar.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.