Skip navigation

Remove attachments in Mail

33582 Views 80 Replies Latest reply: Nov 14, 2013 8:40 AM by prof tedje RSS
  • Pierre Igot Calculating status...
    Currently Being Moderated
    Dec 5, 2011 5:37 AM (in response to tinoberlin)

    Here's another workaround for this very annoying bug: export the sent messages to a .mbox file and then reimport them. You can then remove the attachments:

     

    http://www.betalogue.com/2011/12/05/lionmail-removeattachments/

  • Pierre Igot Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 5, 2011 10:02 AM (in response to tinoberlin)

    What do you mean by "marking"?

  • Pierre Igot Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 6, 2011 7:24 AM (in response to tinoberlin)

    I cannot reproduce this fix on my machine. No matter how and where I select the messages, Remove Attachments is disabled.

     

    The difference is clear when you examine the actual mailbox folders and e-mail files in the Finder: for the sent messages, there is no "Attachments" folder next to the "Messages" folder. The "Attachments" folder should be there for messages containing attachments and contain copies of the attachments in folders whose names match the file names of the corresponding e-mail message files (.emlx).

     

    For example, if an e-mail file's name is 143354.emlx and is enclosed in a folder called "Messages" inside the numerical hierarchy that Mail uses internally to organize its files (in the ~/Library/Mail folder), then next to that "Messages" folder there should be an "Attachments" folder containing a folder named "143354" which in turn contains a copy of the extracted attachment (inside yet more numbered folders).

     

    With the sent messages I have, no matter where I put them, the enclosing mailbox folder in the Finder only contains a "Messages" folder with the message file(s). There is no "Attachments" folder with folders with the corresponding names. So somehow Mail has failed to "extract" the attachments and recognize them as such.

     

    The only fix that works for me so far is to export and then reimport the sent messages using the .mbox file format. After that, Mail clearly "sees" the attachments, has the paperclip icon in the message list and has "Attachments" folders inside the mailbox folders for the reimported messages.

  • 750 H2C Calculating status...
    Currently Being Moderated
    Dec 14, 2011 12:16 AM (in response to tinoberlin)

    Pierre Igot's export/import workaround did the trick for me. Many thanks, Pierre.

    But I wouldn't call it a solution to the problem. I'm waiting for a fix, Apple.

  • Bulchand Calculating status...
    Currently Being Moderated
    Jan 16, 2012 1:34 AM (in response to tinoberlin)

    I have tried all the options and none really work.

    I created a Smart Mailbox with the sent emails, and tried to delete the attachments once they have been put in another folder, but they keep on appearing again.

     

    What I do now is that when I send an email with an attachment, I BCC myself, then I delete the email sent, and when I recieve the email I had BCC myself, I delete the attachments and then move the email to the appropiate folder.

     

    Not a solution at all, but fairly clean process and when in the folder the rest of the data is on the email.

  • Pierre Igot Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jan 17, 2012 2:01 PM (in response to tinoberlin)

    It must be because the 2012 mailbox folder itself was created with Mail 5, whereas the 2010 and 2011 mailbox folders themselves were created by a previous version of Mail.

     

    I can reproduce this too, by moving e-mails to a mailbox folder created BEFORE I upgraded to Lion/Mail 5!

     

    The reason Apple seems to have a hard time reproducing the problem (although they are obviously not trying very hard, based on the number of reports here) might be that there is something problematic with the way Mail 5 indexes mailboxes, and it only occurs in certain combinations of circumstances.

     

    Thanks for the new information.

     

    Pierre Igot

     

    ---
    LATEXT: Literature, music, and visuals / Littérature, musique et graphisme

    BETALOGUE: Blog

    FAUX AMIS : Site sur les faux amis anglais-français

    261RIVERSIDE: Our current house, for sale

     

    < Links Edited By Host >

  • Pierre Igot Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jan 17, 2012 2:16 PM (in response to Pierre Igot)

    Can't edit my post anymore. Something about the URLs in my signature that Apple didn't like .

     

    Sadly, I was mistaken. The workaround does NOT work for me. It might still be something about the Mail version that created the mailbox folder. But it does not fix the problem for me. Do you have a POP or IMAP account?

     

    Pierre

  • Ernie Stamper Level 8 Level 8 (37,455 points)
    Currently Being Moderated
    Jan 17, 2012 2:59 PM (in response to tinoberlin)

    I have not had a chance to further investigate this, as I must primarily work in Snow Leopard for my work flow.

     

    However, I can confirm that attachments are stored with the message content,  and anything in an Attachments folder is redundant.  In versions of Mail prior to SL, only IMAP accounts generated the Attachments folder, but then it became part of POP accounts as well -- but again a redundant storage location.

     

    In earlier tests, I established that any message sent from Mail in Snow Leopard on an IMAP account, would in Lion be amenable to removing the attachments in a single message.  Very curious behavior.

     

    Ernie

  • gvml Calculating status...
    Currently Being Moderated
    Jan 18, 2012 3:46 AM (in response to tinoberlin)

    tinoberlin FabeRox and others, just a support mail. Glad I found this discussion and to know I ‘m not the only one with this very annoying problem of not being able to remove attachments from sent messages since using Lion.

    I also came across the ‘solution’ of Bulchand BCCing myself and remove the attachment from the incoming mail.

    Hope Apple will fix this soon!

  • Maikell Calculating status...
    Currently Being Moderated
    Feb 3, 2012 12:24 AM (in response to gvml)

    Yesterday I did a clean install of OSX Lion (10.7.2) on one of my MacPro's internal hard drives where there had never been any other OSX installed previously. Booted from this drive and more or less "for fun" set up Mail (two IMAP accounts - MobileMe and Macbay [German provider]) and let the application fetch all messages (received AND sent) from the corresponding servers (more than 2,000 messages in total). Believe it or not: "Remove attachments" was not greyed out after this and I am able to delete attachments from any sent mail now - no matter which account, no matter if message had been sent in 2012, 2011 or 2010 (or even 2009 in my case).

     

    Not sure if this information will be helpful for all you guys suffering from this weird problem. Hope it will.

     

    Regards from Germany.

  • Maikell Level 1 Level 1 (30 points)
    Currently Being Moderated
    Feb 3, 2012 10:11 AM (in response to Maikell)

    One more thing I find interesting...

     

    After I did what I explained above, I switched back to my main boot drive (Lion 10.7.2, upgraded from SL 10.6.8) with my "regular" Mail application. Guess what: All the attachments I had removed are now gone here as well.

     

    HTH.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.