Skip navigation

My iPhoto won't load.

2395 Views 5 Replies Latest reply: Jul 18, 2012 5:04 AM by Terence Devlin RSS
tfriedberg Calculating status...
Currently Being Moderated
Jan 17, 2012 3:24 PM

I have version 9.1.  When I open iPhoto a wheel just keeps spinning round, and when I try to use the commands in the bottom right corner (Create and Add To) it force quits telling me that there was an error.

iPhoto '11, Mac OS X (10.7.2)
  • Terence Devlin Level 10 Level 10 (121,665 points)
    Currently Being Moderated
    Jan 17, 2012 3:49 PM (in response to tfriedberg)

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Rebuild iPhoto Library Database from automatic backup.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. This will create a new library based on data in the albumdata.xml file. Not everything will be brought over - no slideshows, books or calendars, for instance - but it should get all your albums and keywords back.

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. .

     

    Regards

     

    TD

  • FCKatoch Calculating status...
    Currently Being Moderated
    Apr 22, 2012 1:05 AM (in response to Terence Devlin)

    Thanks a bunch buddy !! The option 2 worked for me..

  • succ Calculating status...
    Currently Being Moderated
    Jul 18, 2012 4:27 AM (in response to tfriedberg)

    hi. both suggestion did not work for me so sad. it says my iphoto is version 9.1.. dont know what to do..

  • Terence Devlin Level 10 Level 10 (121,665 points)
    Currently Being Moderated
    Jul 18, 2012 5:04 AM (in response to succ)

    As a Test:

     

     

    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'

     

     

    Import a few pics into this new, blank library. Is the Problem repeated there?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.