Skip navigation

iChat screen sharing and video not working on MacBook but works on Mac pro

10781 Views 64 Replies Latest reply: Feb 15, 2012 11:30 AM by Ralph Johns (UK) RSS
1 2 3 ... 5 Previous Next
rbatsungolf Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 16, 2012 7:30 PM

I have a MacBook and MacBook pro. Both have the lion os 10.7.2. I can use iChat on the MacBook pro for screen sharing, video chat, and text chatting, with others remote to me. However, I can only do texting with the MacBook.  I can do screen sharing via Finder between my MacBook and MacBook pro. I can do FaceTime between both systems. I can also do FaceTime between the MacBook and anyone remotely.

 

I also tried installing teamviewer on the MacBook, and on a remote MacBook..... And I get the same results where I cannot share the screen, from the one that has not been working.

 

I have checked the settings under system preference and made sure screen sharing was enabled. I have checked under iChat under video to make sure screen sharing was checked.

 

The macbook that is having this problem is configured for AIM for iChat

 

 

I have run out of ideas. Any suggestions on what I might try?

 

Thanks

MacBook, Mac OS X (10.7.2)
  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)

    Hi,

     

    Common cause.

    The default Login port for an AIM login in iChat before iChat 6 in Lion was port 5190  (although we have been long recommending people  changed to port 443)

     

    This is only for Logging in and Text Chatting.

     

    File Transfers will resort to port 5190 on the UDP Protocol (the Login used the TCP Protocol)

     

    AV Chats send a Visible Invite on port 5678 and then move to port 16402 (as first choice in Leopard/iChat 4 and above)

     

    Using Port Forwarding in your routing device may only allow one IP (Computer) to have access to the ports that have been set up.

    If you device has it it is better to Use UPnP.

     

    Less common

    However you list several things that seems to exclude that:-

    1) Face Time (which uses similar ports) works on both computers.

    2) Screen Sharing works on at least one computer (Suggest that you are not using Port Forwarding).

     

    Your routing device should list the DNS servers it is getting from your ISP
    Copy these across to your System Preferences > Network > Advanced Button > DNS tab

     

    If this does not work add some Public DNS servers such as Google's 8.8.8.8 and 8.8.4.4

     

     

     

     


    9:11 PM      Tuesday; January 17, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)

    Hi,

     

    A Netgear Modem (and router with WIFi) would normally have an IP of 192.168.0.1

    You can confirm this in the same System Preferences > Network > Advanced Button > TCP/IP tab un the "router IP" line.

     

    If you then type that number into a Web Browser, like you would apple.com, then you will get asked for a USer ID and Password.

    Try admin and admin (in lower case for each).

     

    You will be shown a Status page.

    Down the left should be a menu

    If it lists UPnP then check that page has UPnP enabled.

    Then go to the WAN SET UP page.

    In here it will list either DOS or SPI - check the wording but turn It Off.

    On the same page is Ping Blocking (normally the last Item) - Again check the wording and set it so it is Allow Pings to be Accepted/responded to.  (iChat sends Pings to confirm where the Visible Invite went to is the same place that is replying).

     

    If you tell me the exact model I can be more precise.


    7:51 PM      Wednesday; January 18, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)

    Hi,

     

    I would check the router is not isolating the ports to on IP (Computer)

     

    From earlier:-

    Using Port Forwarding in your routing device may only allow one IP (Computer) to have access to the ports that have been set up.

    If you device has it it is better to Use UPnP.

     

    A PRAM reset can be helpful in some circumstances and you will not lost anything by trying it.  (I would not have suggested it though).

     

    If the Netgear is doing UPnP and another computer can Video Chat then it suggests the settings in the WAN page and th UPnP page are OK

     

    I would check your Mother's Mac's Firewall

    If ON then go to the Advanced Button and make sure "Allow Signed Software" is enabled.

    Then make sure iChat is in the List.

    System Preferences

     


    Reinstalling with Lion is a little different to earlier versions of the OS.

    Did you create an Install Disk if you upgraded to Lion via the App Store ?

    Or have you got a Time Machine Back up at all (from a time when you know it works).

     

     

     

     


    8:03 PM      Thursday; January 19, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Gary Kissler Level 1 Level 1 (5 points)

    Ralph,

     

    I have followed your advice regarding the issues people are having with iChat insofar as screen sharing is concerned. I have this problem and have been working at this for some time now. I have turned to the tech reps from Apple and from Netgear but no one has been able to resolve the problem. Since you seem to be well-versed in this area, I am hoping you can help.

     

    Let me first lay out the "ecosystem" and some of the steps that have been taken so far:

     

    1. I have two computers (MacPro and MacBook Pro) that are both running Lion 10.7.2 and both running iChat 6.0.1.

     

    2. The Netgear router model is: WNDR3700.

     

    3. The firewall for both Macs is turned on and in the advanced area iChat is listed as being "allowed."

     

    4. In iChat, under the video options, "Screen Sharing Allowed" is checked.

     

    5. In System Preferences, "Screen Sharing" is checked and this is for "All Users" at present.

     

    6. There are two separate AIM accounts being used for iChat purposes.

     

    7. In iChat preferences, each AIM account is "Enabled" under "Account Information" and the "Server Settings" show the Server as "api.oscar.aol.com" and the Port is "443" and "Use SSL" is checked.

     

    Basically, we have found that the instant messaging function works but neither the screen sharing or video chat works. Specifically, when screen sharing is attempted, the computer being asked to share its screen will show that a request is being made. But the requesting computer shows no response when the other computer signals approval for screen sharing.

     

    I have had the Netgear technical representative and the AppleCare representative working with me on this and, unfortunately, all of the suggestions have failed. Let me lay out their basic solution components:

     

    A. The AppleCare person used remote access to check the system to ensure there were no conflicting applications getting in the way and to double-check the settings mentioned above. As this process went on, I was given a list of ports that iChat would need to have open.

     

    B. The Netgear representative, working with the AppleCare representatve, used remote access to program router to do port forwarding for several ports. I have a screen shot that shows these settings and I have put the protocols in red as these are not shown on the router screen.

     

    Port Forwarding Info.jpg

    C. The router is set for UPnP to be on.

     

    D. The router WAN Setup shows that the "Respond to Ping on Internet Port" is not checked, the NAT Filtering is "Open," and the "Disable SIP ALG" is checked.

     

    As the days have gone on, there have been several suggestions by various discussion groups about what to try. Unfortunately, none have worked. I even contacted the ISP to change the MAC address for the router so I could bypass it and see if the problem persisted. It did.

     

    There have been suggestions about using a different server for AOL and unchecking the SSL box and even disabling imagent via the activity monitor application. Again, nothing seems to work.

     

    You can probably tell from the detail above that a lot of ground has been covered. I apologize for the detail but felt this might help to short-circuit some of the more obvious ideas that have been already tried.

     

    If you can offer something that we need to be paying closer attention to, I would sincerely appreciate it.

     

    Thanks.

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)

    Hi,

     

    Port Forwarding and UPnP are different ways of allowing the ports.

     

    The Control with Port Forwarding is with the router.

    For UPnP it is more with the app (Like the Mac Firewall the App tells the router which ports to Open)

     

    This means they can conflict in some devices.

    I would disable the Port Forwarding as the Screen Sharing uses a random Port and you cannot Forward it.

     


    The WAN set up Page should look like this

    Screen Shot 2012-01-24 at 21.38.16

     


    You may have DOS where this emulator show SPI but the box must be set to turn it Off  (wording may vary)

    The router needs to Respond to Internet Pings so in this case it also need to be ticked to allow this.

     


    Side note:

    If all those ports are for iChat the guy does not know what he is talking about.

     

    iChat 3 ports

    Basically these 5060, 5190, 5220, 5222, 5223, 5297, 5298, 5353, 5678, 16384-16403

     

    iChat 4 (And upwards) Changes

    They become these 5060, 5190, 5220, 5222, 5223, 5297, 5298, 5353, 5678, 16384-16403  16939-1402

     

    Apple iChat Server doc:- Ports

    Server Admin 10.6 Help: Opening Firewall Ports for the iChat Service
    Uploaded with Skitch!

     

    You don't really need to uise the Server ones.

    Such things as 7777 are for server to  server File transfers.

     

    So...

    Use UPnP only

    Respond to Pings

    Block SPI or DOS.

     

     

     


    9:55 PM      Tuesday; January 24, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Gary Kissler Level 1 Level 1 (5 points)

    Ralph,

     

    Okay, let me try to respond to your suggestions. I will attach screen shots to show what was done. Let's start with the port forwarding. You suggested I turn this off. I deleted all of the "services" as denoted by Netgear and shown in my earlier posting. The settings now look like this.

     

    Port Forwarding.jpg

     

    You should see that all of the "services" are deleted and I am assuming this means that port forwarding is no longer "on."

     

    Next you suggested that I only use UPnP. Here is a screen shot of those settings.

     

    UPnP.jpg

    There is a "Portmap Table" showing and I am not sure if this should be emptied or not. But I wanted you to see the setup here so you could comment.

     

    Finally, you recommended a change in the settings for the WAN and here is a screen shot for this.

     

    WAN Setup.jpg

    You suggested that I block SPI or DOS and, as you can see from the first line, I have disabled what Netgear calls "DoS Protection." Further I have also checked the box related to receiving a ping. And note that NAT Filtering is "open" and I have disabled "SIP ALG."

     

    Unfortunately, having done all this, I am still unable to request screen sharing and get a repsonse back.

     

    While I understand your suggestions regarding the router, note, as indicated in the earlier post, that I took the laptop to a local business to use their wireless network so I could test this issue outside of our home network. Also, as I indicated, I asked the ISP to give a MAC address to the laptop outside of the router so I could see if the issue was somehow related to router settings. In neither instance did this result in success. Given this, I'm not sure why you thought I should return to the router for the solution.

     

    The Apple people appear to be stumped by this and again used something called "Capture Data" to obtain the system information while attempting to use iChat on my computer. I have sent them files, based on this test, but have not heard back yet.

     

    Let me also comment on your point regarding which ports iChat requires. This has been more than a little frustrating as I have had contradicting information from the AppleCare people. One person gave the list of ports you saw in the earlier posting. The next one said that not all of these would be needed (as you said, yourself). The first person also said that I could not "test" iChat screen sharing with another computer on the home network as this would require the same port to be used by both computers. The second AppleCare person disagreed and said that iChat would just move to another port that was not being used.

     

    In short, this has about run the course for people offering advice that is, at best, contradictory, and--above all--not leading to a solution.

     

    So, I am sorry to keep pestering you about this but I can't seem to figure out what needs to be done to resolve the issue. Please also note in my earlier posting that I listed the "ecosystem" and all of the settings I could think of that are outside of the router domain.

     

    Hoping you can see something here that I am missing. Thanks.

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)

    Ok,

     

    I will list the ports in greater detail and point out when iChat uses them.

     

    AIM Login and 1-1 Text Chatting

    iChat version 1  through 5 will Log in to the AIM server on port 5190 (TCP Protocol) by default.

    Since iChat 2 we have been posting here that the AIM servers allow a Login on almost any port and have been suggesting port 443.

     

    This is used by both Web Browsers for secure Login to some sites and by the Mail app with some mail servers.

    It is also below port 1024  (most domestic routers have the ports above this figure closed)  In some campus situations using port 443 will normally allow at least Login and Text chatting.

     

    iChat 6 uses port 443 by default.

     

     

    File Transfers (AIM)

    When doing File Transfers with AIM Buddies iChat will move to using Port 5190 on the UDP Protocol.

    This cannot be changed.  (This invokes the little Message about Starting Direct IM in an open Chat)

    It also uses this port for Pics-in-chats, dropping Files on a Buddy's name with out a Chat or sending other files that are not pics.

     

    In the case of Port Forwarding some devices don't like port 5190 being forwarded "twice" which is another reason for moving the login and Text chat port.

     

    Jabber Logins

    No matter what Jabber server you use ichat will use one of two ports (5222 and 5223)

    Which one it uses is dependent on whether it needs and is using an SSL Login or not.

    SSL Logins use port 5223 and NON SSL one use 5222 (ticking or Unticking the SSL box on a Jabber account will automatically change the port).

     

    Google Talk is the exception in that it allow a Login on port 443 as well.

     

    The First Apple Doc I linked you to says iChat uses port 5220 in Jabber.

    I run Little Snitch and have never seen any version of iChat use this port at any time.

     

    Bonjour

    Any Mac to Mac Connection or Mac to any Bonjour able peripheral will be on port 5353.

    This is normally opened (Preset) in the Mac Firewall for the Finder/System side of Sharing.

    iChat needs and uses two other ports  (5297 UDP and 5298 on both TCP and UDP)

    As they an LAN Side connections the router would normally pass them.

    At iChat 3 there were issues with the Mac Firewall (it included UDP set up and the preset in the firewall only listed them and TCP so we had people add all the iChat ports  (you had to manually enter them in Tiger)

     

     

    A/V Chats

    No matter which Buddy List you start from iChat will do A/V chats the same way.

     

    The Visible Invite you or your Buddy sends is on port 5678 (UDP)

    In iChat 3 and earlier iChat then moves to port 5060 to send the SIP Connection Process invite behind the scenes  (SIP = Session Initiation Protocol)

    Port 5060 is one of 4 ports internationally agreed for SIP (How VoIP phones connect) (5060-5063).

    Although ISPs were not supposed to block Through traffic many started blocking End users  and then Charging them to open these ports (Many ISP were telecom companies that were losing long distant Telephone calls monies).

     

    The SIP process then in iChat 3 contacts a server run by Apple for this purpose (Snatmap.mac.com to give it it's full name).

    This acts like a old fashioned telephone operator connecting the call.

    SIP is a text based process.

    Your end "Calls" the operator.

    The Operator "Calls" Buddy.

    Buddy Accepts

    iChat then negotiates the ports to be used.

    In iChat 2 and 3 it uses 4 ports (vid in Vid out, Audio In and Audio Out) from "the group of 20" starting at the bottom (16384 to 16387 normally)

    Three and 4 way chats uses more ports (which is why 20 are set aside)

     

    In iChat 4 Apple realised the issue with the 5060 port and changed the way iChat worked

    Since then it has Sent the invite on Port 5678 but then moved to port 16402 (it starts at the top of a smaller group of 20)

    All Video and Audio traffic is also now on one port  (so no need for 20 ports and iChat now lists 10).

     

    NOTES so Far.

    File Sharing during a Chat converts the Chat to Direct IM for AIM Logins

    This is Peer-to-Peer in AIM

     

    A/V Chats are Peer-To-Peer and you can actually log out of the Buddy list and continue the chat. (The exception is using iChat 6's  AIM Video relay option)

     

    Screen Sharing

    Screen Sharing is an Audio Chat with a VNC connection along side.

    Both bits have to wok to avoid the Pop-up to send to Apple and the Log that contains.

     

    The Audio part is on port 16402 and the VNC part is random. (So random it is different every time you do it)

    The reason it is classed as an Audio Chat+ is so the AppleScript for Auto Accept can  filter out Screen Sharing connection and Not Auto Accept them.

     

    This does have a knock on effect as far as your Router is concerned as already mentioned earlier.

    You cannot Forward or Trigger the random Port so you have to use UPnP in your router to open the ports.

     

     

    NOTES

    Jabber File sharing may possibly be on port 1080 as listed in the Server Article I linked you to (I have also seen it written about in other stuff I have come across)

    However Little Snitch does not seem to confirm this either.

     

    Most time it will be peer-to-peer like the AIM connections for this.

    However some Jabber servers do not seem to allow this and have this Jabber65 Proxy set up which passes things Server to Server in between it leaving your end and arriving at a Buddy.

    This on  Port 7777 but you do not need to open this port (unless you are running a Jabber server)

     

    I have yet to test File Transfers using a Yahoo Buddy List in iChat 6.

     

    AppleCare and Geniuses.

    Previously I have been contacted by Geniuses in Stores asking to test customer's iChat.

     

    They and the Applecare people have details about Apple wants an designed the App to work.
    What they don't have is the knowledge about what it takes to set it up in the "real world".

    There are literally thousands of Makes and Models of routers.

     

    Some like the Thomson-Alcatel brand state they are SIP/VoIP ready but this means the router strips out all SIP Data trying to send it to a Phone.

    Early models of Alcatels can get around this with a tweak. Later models can't.

     

    Motorola devices tend not to have UPnP.

     

    Apple Base Stations have Port Mapping Protocol instead of UPnP and this needs setting up.

     

    The Zyxel range definitely does not like the dual use of port 5190 and does much better using UPnP (You almost certainly have to do your AIM login on port 443 with these).

     

     

     

    1. I have two computers (MacPro and MacBook Pro) that are both running Lion 10.7.2 and both running iChat 6.0.1.  <<-- Fine

     

    2. The Netgear router model is: WNDR3700.    <<<<---  With any Brand there are exceptions and I do wonder about this one

     

    3. The firewall for both Macs is turned on and in the advanced area iChat is listed as being "allowed."  <<<<---- Fine

     

    4. In iChat, under the video options, "Screen Sharing Allowed" is checked.                                        <<<<<---- Fine

     

    5. In System Preferences, "Screen Sharing" is checked and this is for "All Users" at present.               <<<<<---- Not Required

     

    6. There are two separate AIM accounts being used for iChat purposes.                                            <<<<<----  OK

     

    7. In iChat preferences, each AIM account is "Enabled" under "Account Information" and the "Server Settings" show the Server as "api.oscar.aol.com" and the Port is "443" and "Use SSL" is checked.                                <<<<---- As it should be

     

     

    From this and the other info in the first port it was only the router set up that seem to throw some light on a possible cause (Port Forwarding and UPnP conflict)

    If just doing Port Forwarding the ports listed would have covered things (Except the Screen Sharing's random port)

     

    Regarding your latest post.

    I have  table similar to that on my Sagem 2504Fast Modem/router combined device and it too seems to list a different port on the external side on occasions.

     

    I would try the router with the Disable SIP ALG unticked (so it is not disabled). If the Help info on the right gives any info about what this Netgear version does it would be helpful.

    Some are like the Thomson-Alcatels I was talking about in that it points the SIP data to a specific place (Possibly a Phone socket on the device)

    Others seem to provide an "boost"  to enable SIP to work and don't seem to get in the way of iChat.

     

    Try adding the Names in Table 1 from this page and see if you can Video to those.

    There are 6 names in total (I am actually only seeing one on Line as I type)

     

     

     

     


    9:19 PM      Wednesday; January 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Gary Kissler Level 1 Level 1 (5 points)

    Ralph,

     

    Thank you for the background regarding the ports used by iChat. It appears to me that, as the application and operation system software have evolved, this whole area has undergone several changes. With that said, I am trying to make sure I am taking full advantage of the current status. But these efforts are failing.

     

    I have done exactly what you recommended with regard to the Netgear router setting. Then I opened up iChat and attempted to use the "test buddies." The list of available entities included only two that were online and offered the video capability.

     

    In neither case, however, did I get a response.

     

    You asked if the information on the right side of the screen in the Netgear setup window would give some indication what the router would do in terms of where it points SIP data. I am attaching a screen shot of the WAN Setup Help text. I cannot see anything here that would help answer your question.

     

    WAN Setup Help.jpg

    Any further suggestions you could give would be greatly appreciated.

    Thanks.

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)

    Hi,

     

    It does not say where it point it to but it does say this:-

     

    iChat screen sharing and video not...: Apple Support Communities

     

    As they say themselves it may be better turned Off.

     

    Defcom, one of the other regular poster may have a better idea than I do on which Netgears are not as good as the majority.

    I will email him to have look at this thread and see if he knows anything.

     

     

     

     


    10:05 PM      Thursday; January 26, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Defcom(UK) Level 6 Level 6 (15,310 points)

    What version is the netgear as there are 3, v1, v2 or v3

     

    and what is the firmware version.

     

    Also what modem do you have ie: cable or DSL.

1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.