3 Replies Latest reply: Jan 18, 2012 9:30 AM by taylorfromca
zphatkid Level 1 Level 1 (0 points)

My hard drive crashed on Friday and I replaced it with a new one yesterday. The person at Simply Mac told me to restore my files from Time Machine by first installing Snow Leopard on the new hard drive and then using Migration Assistant. I did this, but some of my stuff didn't come back from Time Machine.

 

The problem though is when I enter Time Machine and go to my most recent backup it says I don't have permission to access my files. The only folder it gives me permission to is the Applications folder. All the rest have a red circle with a white bar on them. This is the same problem if I go even further back in my backup history.

 

I've read some articles about people getting an error in Time Machine which includes their mac address in the error code. I don't get an actual error, just a notification that I don't have permission to access the files. Also when I go to view the info on the folder it says I'm not the owner and lists two users, one is "_unknown" (who has read and write privileges) and the other is "everyone" who has no access. These are both grayed out and it won't let me add or change any of the settings in this area.


MacBook, Mac OS X (10.6.7)
  • 1. Re: I have no permission in Time Machine.
    rachaelroo Level 1 Level 1 (0 points)

    I had your exact same problem.  In finder, I was able to open up the info for the folder I apparently had no permission to view, and on the lower right hand corner, I unlocked the lock, inputting my administrator password to make changes.  On the lower left hand corner, I then clicked the + sign, which gave me an option to add a new user.  All the users on my computer were listed, and I was able to add myself, and then change the privilege to give me access.  Lock the lock back, and it worked!

     

    Unfortunately, it wouldn't let me take individual files from the folder, showing I still had no permission, until I downloaded the whole folder from my backup storage to my hard drive.  I just dragged everything to my desktop.

  • 2. Re: I have no permission in Time Machine.
    rachaelroo Level 1 Level 1 (0 points)

    Actually, if you restart Finder, the red error icon will go away, then you can access individual files.

  • 3. Re: I have no permission in Time Machine.
    taylorfromca Level 1 Level 1 (0 points)

    This works! Thanks RachaelRoo! You saved me. Although I dont think you need to restart finder. Just close the window you are working in and open a new finder window. Thanks Again!