Skip navigation

App Store says Xcode is installed but it isn't, so I can't install XCode

2022 Views 9 Replies Latest reply: Apr 10, 2012 2:36 PM by roens RSS
Rich Cook Calculating status...
Currently Being Moderated
Aug 6, 2011 10:20 AM

What can I say.  I tried to install XCode but it did not finish.  Now the App Store thinks XCode is installed.  I need XCode for MacPorts to work.  Does anyone know how I can tell the App Store XCode is not installed? 

Mac Pro, Mac OS X (10.7)
  • Eric Ross Level 6 Level 6 (11,650 points)

    Open the App store then hold down your option key and click purchases. 

  • Eric Ross Level 6 Level 6 (11,650 points)

    Check your Applications folder for the installer. 

  • Eric Ross Level 6 Level 6 (11,650 points)

    Welcome,

  • Doug Guillot Level 1 Level 1 (0 points)

    I'm having a similar problem. Xcode was installed, opened an old project. It caused XCode 4 to crash, so I uninstalled it. Used the DevTools uninstaller in the folder via terminal. I try to download from the App-Store, it says it can't because it is already installed. I downloaded the file from the ADC site, tried to install it, and it says that it can't install it on the drive because it already exists. I can't find any reference to where it's looking to determine if it exists, but there is something somewhere. Any ideas?

  • tonycurzonprice Calculating status...

    I have the same problem as Doug ...

  • roens Calculating status...

    "Me too"

     

    Yet another individual in the same boat. ***, Apple?! Why must getting software be so obscure & complicated? What happened to: go to website, download thing, install thing?

     

    1. I had Xcode 4.1 installed. Wanted to install (yet another) package with MacPorts, but got complaint that Xcode 4.1 is inadequate.
    2. So I go to App Store & tell it to install current Xcode…
      1. This, BTW, left me with nearly zero feedback that something was going on. Only because I have a menubar widget showing network bandwidth did I know it was downloading.
    3. while waiting (who knows how long it was to be), I had to sleep my computer to take it with me to work.
    4. Upon waking my computer, App Store tells me Xcode is installed. Great!
    5. Back to MacPorts to install that package: it tells me that Xcode 4.1 is too old. ***!?
    6. Then things get messy & I end up clicking on the circle-X "button" next to XCode in the "Purchases" section of App Store, thinking that'll allow me to install it…
      1. that's a dead end
    7. I then try entirely removing "/Developer" & "/Applications/Install Xcode.app"
      1. another dead end
    8. Trying all combinations of holding any/all keyboard modifiers (option/control/shift/command) while clicking on "Purchases" in App Store did nothing different than not holding any.
    9. Now I'm left with no Xcode & no way to install it with App Store
      1. whee! this is a fine pit I find myself in now.

     

    What a lovely user experience! Please, may I have more?! <grumble> <fume>

     

    In the end, I did resort to my "what happened to…" thought.

     

    Problem Solved:

    1. Go to http://connect.apple.com/ & login with your (free) dev account.
    2. Locate the current version of Xcode (4.3.2 for Lion) & download the dmg
    3. Install like a normal person. (copy the Xcode.app from the mounted disk image to Applications)

     

    After a bit of cleanup (things like "/usr/bin/xcodebuild -version" were trying to access things that used to exist), I've again got a working install of Xcode.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.