7 Replies Latest reply: Jan 20, 2012 1:10 PM by Web dude
Web dude Level 1 Level 1 (0 points)
I can't access iTunes Store on G4 running OSX Leopard. It's telling me I need Safari 4.0.3 in order to have access to iTunes and I have the latest version.

G4 AGP (500Dual), PowerMac 8600, Mac OS X (10.5.7), Mac lover