Skip navigation

iMessage Caller ID

25209 Views 42 Replies Latest reply: Dec 30, 2012 12:04 PM by lizzyb2511 RSS
  • bediddleby Level 1 Level 1 (35 points)
    Currently Being Moderated
    Dec 13, 2011 11:17 AM (in response to psp3492)

    Thanks for the post. You say to turn on iMessage and Facetime, then reboot, then turn them on. Did you mean to turn them OFF before the hard reset? The activation is never not successful. It always is. Still doesn't work.

     

    I'm sure it's unrelated, but after that, all my Music and Video content is gone from the phone, even though it shows as being there when I look at the phone via iTunes. Man, this just keeps getting better! Did they subcontract the iOS 5 work to the WinMobile team?

  • psp3492 Calculating status...
    Currently Being Moderated
    Dec 13, 2011 2:14 PM (in response to bediddleby)

    Just go to the apple store they will give new phone.

  • theodorostz Calculating status...
    Currently Being Moderated
    Dec 14, 2011 6:22 AM (in response to psp3492)

    go to myapple id (https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/ )-> manage account ->  phone numbers ->  at write your  country code, leave blank the area code and at phone type your phone number. For me (greece)  is 030 - (blank)- 69...etc. then go to your iphone to settings and Store. apple id and view apple id. tap at billing address  scroll down and add (or should be) your phone number. that worked for me.

  • bediddleby Level 1 Level 1 (35 points)
    Currently Being Moderated
    Dec 14, 2011 6:33 AM (in response to psp3492)

    I sucked it up and did a restore-as-new (I'm still setting up all the apps, etc., what a painful process.) So far, the issue is resolved; I'm back to correctly having my phone number be the Caller ID in iMessages. If I end up with another problem that requires restoration, I will definitely insist on a new phone. This is only one of four major 'bugs' I dealt with this week. All of them resulted in getting to an Apple Sr. Advisor who had no easy answers. I'm hoping they were all related to s/w glitches that should be resolved now.

  • theodorostz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 14, 2011 6:43 AM (in response to bediddleby)

    if there is an error at your account then whatever you are gonna do it will not fix the verification. add or correct your phone number at your apple id

  • bediddleby Level 1 Level 1 (35 points)
    Currently Being Moderated
    Dec 14, 2011 6:48 AM (in response to theodorostz)

    I don't believe the problem is with the account; it worked up until two days ago, and it works again now with no changes to my Apple ID.

  • John P. Level 4 Level 4 (1,145 points)
    Currently Being Moderated
    Dec 15, 2011 8:13 AM (in response to Mike R)

    I am noticing this issue, I have posted about it here: https://discussions.apple.com/message/17009080

     

    I suggest submitting feedback to Apple: http://www.apple.com/feedback

     

    The more feedback that is submitted, the more the issue gains attention.

  • dminthetron Calculating status...
    Currently Being Moderated
    Dec 18, 2011 11:28 PM (in response to theodorostz)

    Ok, my problem is that my email address displayed to recipients as the sender rather than my name or phone number.  I too was at the point of frustration, about to peel 5 carrots, weave the peelings between my toes whilst standing on my head, repeating the 10 commandments and looking at 4s anticipating a miracle fix...  So thanks to theodorostz, I tried several "fix" solutions mentioned on this thread and others from friends with 4s' and his is the ONLY ONE THAT HAS WORKED:

    "go to myapple id (https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/ )-> manage account ->  phone numbers ->  at write your  country code, leave blank the area code and at phone type your phone number. For me (greece)  is 030 - (blank)- 69...etc. then go to your iphone to settings and Store. apple id and view apple id. tap at billing address  scroll down and add (or should be) your phone number. that worked for me."

    In between last night and today to check that fix has worked, I sync't my 4s a couple of times, made sure the info was consistent when logging into apple id from pc and phone.  I don't know where I looked but I could find the phone number manage option much easier from the 4s menu than from my mac browser....  My billing address phone number had no international code attached so not sure if this in combination with the daytime ph #, but whilst in there, I changed all of this info as theodorostz recommended and today, success!

    I have found also that when my friends insert my contact details into their iphone, they must insert the international code in the same format that I have edited my apple id.  eg One friend had no international code saved to my cell svc provider code and # - i received imsg ok, but my replies to him kept coming up with my email address as the default sender rather than my contact name or cell #.  Another imsg showed for my work colleague today as the +64... number, but only because I was not in his contact list.  I saved my contact details to the received imsg phone number and imsg instantly updated to show my name.  So think the apple id needs to correspond to how your recipients enter your contact details.  The only way you can check this I guess is by entering it yourself or explaining they need to do the +64 or whatever thing, which is great if the person next to you has an iphone to test all these possibilities.

    I have had another tekkie suggest that I should check my email and internet settings as a last resort, see what I can tweak in there, since imsg sends via email effectively, But since changing my apple id, I have not had to look into this avenue (thanks again theodorostz).

    Thanks to everyone for all of their suggestions but especially theodorostz as this one was really doing my head in.  Seriously.  But the logic that it had to come from and align with the core of the matrix (apple id) made sense to this complete teknophobe.

    ok.  now to enable siri.  Wish me luck!I

  • dminthetron Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2011 11:34 PM (in response to dminthetron)

    Oh can I also say that the only other thing I changed was:

     

    Settings - Messages - Receive at [showing for me 2 locations after theodorostz fix solution - one email, one cell] - Caller ID - and I unchecked my email and checked my cell phone.

     

    Must also note that in that Settings - Messages - Receive at - Email - deleting my email address was shadowed out, so that simply wasnt an option for me.  I only changed the caller id from email to cell.  So maybe all these things in conjunction have helped.

  • theodorostz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 19, 2011 3:25 AM (in response to dminthetron)

    Glad to help. As for the same format, with the int code, that must have your number at apple Id and your friend's contact list, I haven't checked this but if you change the location at the iMessage I think it should dO the trick no matter how your friend got your number.

  • Herrmanndo Calculating status...
    Currently Being Moderated
    Jan 20, 2012 9:42 PM (in response to Mike R)

    To everyone having problems with the caller ID showing up as email rather than phone number: Go to Settings>Messages>Turn On iMessage> Recieve At> click on your apple id and sign out (DO NOT SIGN BACK IN!!!!). From here on the only recieving adress is your phone number.

     

    hope that helps you guys out.

  • bediddleby Level 1 Level 1 (35 points)
    Currently Being Moderated
    Jan 21, 2012 5:03 AM (in response to Herrmanndo)

    Herrmanndo wrote:

     

    Go to Settings>Messages>Turn On iMessage> Recieve At> click on your apple id and sign out (DO NOT SIGN BACK IN!!!!). From here on the only recieving adress is your phone number.

    Thanks. My daughter's iPhone 4 starting doing the same thing out of the blue and your workaround helped. Obviously it's not working as Apple intended, but this is better than people getting texts from my Apple ID.

  • lizzyb2511 Calculating status...
    Currently Being Moderated
    Dec 30, 2012 12:04 PM (in response to Mike R)

    Yes, it works!!  I found this fix in another thread by Rygel XXV.

     

     

    This is my solution to get my phone number showing:

     

    1) On my iPhone, sign out of Apple ID.  Do this by going to (Settings->Messages->Receive At).

     

    2) Tap on your Apple ID (top of the page) if it is highlighted and you will get a number of choices including "Sign Out."

     

    3) Tap "Sign Out."  (Note you can sign back in if you eventually decide you want to use your email address for iMessage.  I did read somewhere in this thread that if your iMessage recipient adds your email address to his/her contacts, then your name will show up.  That could be an alternative solution.)

     

    That did it for me.  Now my iMessage shows up again with my phone number.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.