7 Replies Latest reply: May 20, 2012 5:53 AM by brockap3
Joaqu’n Rodrigo Garza PŽrez Level 1 Level 1 (60 points)

Is anyone else experiencing this? I've read in these and the macrumors forums that some people has problems using minidisplay port to DVI adapters, but minidisplay port to VGA adapters work fine.

 

I've tested several displays (DELL, Samsung, LG), using both apple adapters MDP-DVI and MDP-VGA, connected to my 2009 iMac, 2010 MacPro though Mini display ports and to a 2011 MacMini through a Thunderbolt port, and in every case they work as they are supposed to, instant recognition, output video clear and bright, etc... but my MBP late 2011 can't connect to any display or projector. MBP doesn't "detect" any attached display, and the displays also state things like "VGA-PC Not Connected" or "DVI No Signal" or "No Signal Check Connection"

 

And yes i've tried the usual tricks, rebooted, OS is up to date... i've changed from Intel HD integrated card to the ATI RADEON discrete card and viceversa and still no video output.

 

Soooo i am assuming the thunderbolt port is either dead or there is something obviously wrong with the video- output... i don't have a thunderbolt cable to test the port using the MBP or the macmini as target disk.

 

Any Comments???

  • 1. Re: Late 2011 MBP 15": Thunderbolt port doesn't send video signal
    cmelbourne91 Level 1 Level 1 (35 points)

    it may be a simple problem of 'mirror imaging' once you connect through the thunderbolt connection, go into settings, into displays and have a look round, there should be a selection for mirror image, make sure this box is checked and it might solve your problem. it seems that some macs have it as factory settings and some dont.

  • 2. Re: Late 2011 MBP 15": Thunderbolt port doesn't send video signal
    Joaqu’n Rodrigo Garza PŽrez Level 1 Level 1 (60 points)

    Thanks for your input cmelbourne91, i have seen your suggestion in other posts, but please understand my MBP is NOT recognizing any display, and any of my displays is receiving a signal from my MBP using either adapter (MDP-DVI or MDP-VGA).

    It is not that i'm seeing the background picture in the external displays... the option you mention comes in the tab "arrangement" which appears only and only if and when your computer has detected a new external display, and there you can either mirror your sceen into a projector or an external display or expand your desktop to other displays.

    When i click on "Detect Displays" nothing happens....

  • 3. Re: Late 2011 MBP 15": Thunderbolt port doesn't send video signal
    cmelbourne91 Level 1 Level 1 (35 points)

    There may be a few solutions to overcome this. because Macs work so you shouldnt need to detect them, they should be automatic.

    make sure your monitor and screen are both on when plugging in your cable, and also go to settings, and change your resolution to something low, for example, 720x480...

    this worked for my tutor.

    another problem some people have is the actual HDMI cable, some people find its better to actually use a shorter HDMI cable, so instead of a 10m one, use a 5m one.

     

    As a last resort, i would sugest you reset your PRAM, now i dont really know enough about this, so it would do to get a bit more information for it.

    http://support.apple.com/kb/HT1895#

     

    Hope this helps.

  • 4. Re: Late 2011 MBP 15": Thunderbolt port doesn't send video signal
    Joaqu’n Rodrigo Garza PŽrez Level 1 Level 1 (60 points)

    thanks again for your help.. already had tried the NVRAM resetting and the "common tricks" to connect to external displays... and i'm not using HDMI, late 2011 MBPs don't have HDMI ports, and my adapters aren't MDP-HDMI.

  • 5. Re: Late 2011 MBP 15": Thunderbolt port doesn't send video signal
    brockap3 Level 1 Level 1 (0 points)

    J~

     

    cmelbourne91 was suggesting HDMI because many of the MDP/Thunderbolt to DVI adapters come with an additional DVI to HDMI (not Apple's) and you likely won't find any MDP to HDMI becuase of something weird with one of the Apple or HDMI related patents and the type of cable/jack/plug required for it.

     

    As for my computer (15" MBP mid 2010), it almost seems as if I have your problem but intermittently. When connected to an external monitor or projector, the thing will project just fine, but then after some time (and no movement of the computer, cables, or screen) the connection quits. Sometimes it comes back on, sometimes it does not, but it basically registers as if there is no external display.

     

    Any additional info on this?

  • 6. Re: Late 2011 MBP 15": Thunderbolt port doesn't send video signal
    Joaqu’n Rodrigo Garza PŽrez Level 1 Level 1 (60 points)

    Oh in the end they replaced theMotherboard, it was a faulty port... It wasunder warranty and was hassle free...

    Cheers

  • 7. Re: Late 2011 MBP 15": Thunderbolt port doesn't send video signal
    brockap3 Level 1 Level 1 (0 points)

    J~

     

    Kind of funny here, I just brought my computer into the apple store and they replaced the motherboard too I love applecare (mine is a mid 2010 15" with minidisplay port).

     

    So folks, test the port with multiple adapters, multiple projectors (both of which work with another computer, preferrably a mac) then if still not working and clearing the SMC and PRAM doesn't work, make sure your warranty is in tact and head on over to the apple store.

     

    Good Luck.  ~Brock