Skip navigation

Continuous error about Connection Failed

99709 Views 83 Replies Latest reply: Feb 23, 2014 6:55 AM by rav1972 RSS
  • sKurt Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2011 6:25 AM (in response to biergoat)
    This fixed mine as well, problems? The items I had in my startup/login didn't - mostly.

    Since I renamed the items in preferences of course they no longer show up so I have to re-input the login items. Not too bad as it did 'fix' the pop up window at every startup.
    MacBook, Mac OS X (10.4.9)
  • alphonsekarr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 27, 2011 10:09 AM (in response to kevin_alan)
    Another gotcha to watch out for is Microsoft Office for Mac's Remote Desktop Connection. After seeing some mentions of Network Magic, I killed RDC and my error message went away. Interestingly, the error was being thrown from two different Macs, even though RDC was installed on only one of them.
    Macbook Air, Mac OS X (10.6.7)
  • cm2splunk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 11, 2011 12:11 PM (in response to kevin_alan)
    Or if the server name and IP are correct, then most likely server you are talking to is not currently running samba. On the server: ps aux | grep smb. Check chkconfig levels. Manually start up samba daemon: /etc/init.d/smb start or what have you. At least this is what my issue turned out to be when my users started complaining about getting this error after a power outage.
    macbook pro, Mac OS X (10.6.6)
  • ameldrum1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 12, 2011 2:46 PM (in response to cm2splunk)

    I was getting this error message at startup on my Macbook Pro - "Connection Failed.  There was an error connecting to the server XXXXXX.  Check the server name or IP address, and then try again..."

     

    The straightforward fix for me was to go to System Preference/Accounts/Login items and remove an external HDD that is attached to my Airport Extreme router.  Just check these login items for anything that might be searching for the server in question and remove it from this login items list.

     

    Cheers.

  • Cary Gersh Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 18, 2011 6:09 AM (in response to rhino_harley)

    My problem was exactly as you described, but I didn't connect the dots relating it to a recent attempt to view a PDF on a decommissioned server. After I deleted Adobe Synchronizer from the login items, the problem went away.

  • mandyvan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2011 4:04 PM (in response to kevin_alan)

    I recently got this same error when trying to connect to a shared printer on my Windows Vista machine from the Mac mini recently upgraded to Lion.

     

    What worked for me was clicking the "Connect As..." button on the top right of the finder window after selecting the name of the computer (under Shared).  I put in a Registered User for a username and password from the Vista PC.  No matter how hard I click the checkbox for "Remember this password in my keychain" it does not for very long and sometimes I forget that Connect As button is there, it's so elusive.

     

    Mandy

    Hello, I'm a Mac... and I'm a PC...  I'm a both.

  • schafty Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2011 5:41 AM (in response to kevin_alan)

    My wife had this error for two years and none of the solutions above worked.  I started having this error a week ago, and stumbled across a solution somewhat by serendipity. 

     

    What led to it was the fact that in both cases the error began when we connected to a different new wifi transmitter while visiting, coincidentally enough, different grandchildren on different continents. The solution amounted to clearing completely the Location list.

     

    Here's the step-by-step solution that worked for both machines.

    1) Open Network in System Preferences

    2) At the top of the dialog box you will see " Location " Click on the name next to it or the up/down arrow to get a drop menu of prior locations.  The current location will be at the top of the list.

    3) At the bottom of the list is "Edit Locations". Click on that. You get a "Locations" box with a list of names, and at the bottom, +, – , and gear icons.

    4) Starting at the bottom of that list of locations, select a name, then click on the – , until there is only one location, the current one, left.

    5) Click on the + to get a new location, and make sure you are connected to the new location (to connect to the new location you may have to Renew DHCP Lease or event go through the Connection failed rigamarole you are by now so familar with)

    6) Go back to the Locations box. Click on Edit Lactions, select the penultimate location (the only one that was left after step 4 and eliminate it by clicking – icon .

    7) Restart

     

    The downside to this solution is you will loose easy connection in prior locations, and you will have to reenter the passwords for those as you revisit those locations.  But this is a trivial price to pay for resolving this error.

     

    Final note: it may be possible to do this in fewer steps, but this is exactly what worked for me, and now, thank God, I have no way to check an alternate procedure.

  • Stickybeak Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 3, 2011 12:19 AM (in response to schafty)

    This did not work for me.

    I have a vpn and I access my files using go to server

    The problem has only emerged since I upgraded to Lion...

  • hearmeout Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2011 4:08 AM (in response to Stickybeak)

    go to system preferences, network, accounts, look for "network account server" and click on "join", click on "open directory utility" and enable "active directory"

  • hearmeout Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2011 4:22 AM (in response to hearmeout)

    guys, it's a stupid dns issue.  i'm not sure if it's on the router or somewhere in computer but if you change the dns info in network then it will fix it.  so for example, i change mines from 10.0.1.1 to 8.8.8.8 (using google's dns but it doesn't have to be)

  • hearmeout Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2011 4:31 AM (in response to hearmeout)

    stupid macs.  all of my changes that i've done so far works only for a moment and then macs become stupid again.  macs are dumb machines!!

  • Machwa Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 23, 2011 8:17 PM (in response to Stickybeak)

    Sticky,

     

    Same here. I only got it once I upgraded to Lion. I get it wheter I'm connected to the Internet or not. I even disconnected everything from my iMac excpet for the power cord.

     

    I still got the message.

     

    So frustrating.

  • David Keppler Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 25, 2011 1:36 AM (in response to kevin_alan)

    Not sure if it will help anyone but I had the same problem and solved it by going to the Go option on the Finder menu and selecting Connect to Server. On the top line of the dialog box is a button to drop down a list of recently connected Servers, at the bottom is a clear option. Clicking this (and making sure I did not have the servers in the start at loging preference) solved the problem.

  • larsfromhaslum Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 25, 2011 6:43 AM (in response to kevin_alan)

    None of the solutions help me and my problem, so now I am contacting my system administrator, hope he can help me. ****, thats me! so what do I do now Apple?

  • PBRDesign Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2012 10:07 AM (in response to bjames008)

    I had the same issue.  When I opened iPhoto, or Media from within Keynote, I would get the connection error message.  I opened Finder, went to my Pictures folder and right clicked on iPhoto Library and selected Show Package Contents.  Then I double clicked the Originals folder.  From here you have to open each folder, one at a time, and look at the icon to the left of the photo name.  If you see a little diagonal arrow in the bottom left corner of the icon, move that photo to the trash.  Do that for each of the photos that have that arrow on the icon.  These are not actual photos, they are links to photos that are on a server that iPhoto is looking for.

     

    You might want to make note of the photo names to see if you can find them on another computer or device somewhere and bring them back into iPhoto.  Oh yeah, do this with iPhoto closed.  After trashing these links, iPhoto should open without the error message.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.