Skip navigation

iPhoto search not working

1214 Views 5 Replies Latest reply: Jan 24, 2012 10:53 PM by Terence Devlin RSS
Nathan Jones2 Calculating status...
Currently Being Moderated
Dec 19, 2010 4:27 PM
I can search for IMG, but not for the full picture title IMG_0152. It seems completely random which photos are searchable and which are not.

Also, as I am having to view the package contents to check the photos (they are still searchable in Spotlight), some photos are in the iPhoto library that do not appear in iPhoto itself. I have tried alt/command and recover orphaned photos, but this does not reimport them.

The situation is a total nightmare because I cannot fully search in iPhoto, so it is extremely hard to establish which photos are showing and which are not.

Actually, this is getting even more confusing… iPhoto is only registering 1,488 photos, but in iPhoto '09 I recently passed the 10,000 mark. Thankfully the library appears to be the same size, but they are not added into iPhoto.

So, anyone know what is wrong with the search and perhaps I should make a new post, but does anybody know how to actually show all the photos that are clearly there within the library package?
MacBook (Black), Mac OS X (10.6.5)
  • Old Toad Level 10 Level 10 (113,290 points)
    Currently Being Moderated
    Dec 19, 2010 8:56 PM (in response to Nathan Jones2)
    It works OK for me. Backup the library and try the two fixes below in order as needed:



    Fix #1


    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your User/Library/Preferences folder.

    2 - delete iPhoto's cache files that are located in the User/Library/Application Support/Caches/com.apple.iPhoto folder.

    3 - reboot, launch iPhoto and try again.




    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding the the Option key. You'll also have to reset the iPhoto's various preferences.


    Fix #2

    Launch iPhoto with the Command+Option keys depressed and follow the instructions to rebuild the library. Select options #1, #2 and #6.



    Click to view full size



    Happy Holidays
    3Ghz iMac, 4G RAM, 1TB HD; MBP 2.16 Ghz 2G RAM; 1.5TB/160GB HDs;, Mac OS X (10.6.5), Canon:i850/8600F, Epson R280; 4G Nano, 30G Video iPod; iPad 3G
  • Old Toad Level 10 Level 10 (113,290 points)
    Currently Being Moderated
    Dec 19, 2010 9:09 PM (in response to Nathan Jones2)
    Create a new test library, add a few photos and check out the search function there. If it doesn't work then a reinstall of iPhoto is indicated. If it does work then it's your library that's the culprit.

    If it's your library then there just one fix left to try to get it working right and that's rebuilding the library with iPhoto Library Manager as follows:

    Rebuild the library using iPhoto Library Manager as follows:




    Using iPhoto Library Manager to Rebuild Your iPhoto Library


    1 -Download iPhoto Library Manager and launch.

    2 -Click on the Add Library button, navigate to your User/Pictures folder and select your iPhoto Library folder.

    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File->Rebuild Library menu option

    4 - In the next window name the new library and select the location you want it to be placed.

    5 - Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.
    3Ghz iMac, 4G RAM, 1TB HD; MBP 2.16 Ghz 2G RAM; 1.5TB/160GB HDs;, Mac OS X (10.6.5), Canon:i850/8600F, Epson R280; 4G Nano, 30G Video iPod; iPad 3G
  • james k.frommemphis Calculating status...
    Currently Being Moderated
    Jan 24, 2012 5:02 PM (in response to Nathan Jones2)

    On 3-31-2011 and 4-1-2011 I did basic re-installs.  Case No. 212858279.  iphoto help worked both times until I ran my updates.  Then nothing.  I do not have internet at home, so using WIFY else where,  iphoto help would work??  I had to be on line.  I have already tried moving files from library preferences and nothing.

     

    My last advisor was Robert Abbot, Case No.213616973.  Research was done.  I was told it was a bug.  Since then, no correction or updates have ran.  I was also told that we would have to be on the internet for iphoto help to work since most people were connected.  Well, not always and I would like to have access to iphoto help during those times.  So apparently Apple  has no intention of making any changes or updates  as of this date.

     

    If anyone got iphoto help working by moving files out of library, preferences, you are lucky.

  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Jan 24, 2012 10:53 PM (in response to james k.frommemphis)

    James

     

    This forum is for Users to talk to other Users. You're not talking to Apple here and frankly, as we have no context, we have no way of making sense of your post.

     

     

    Regards

     

     

    TD

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.