Skip navigation

Why do iMessage texts repeat twice?

108373 Views 38 Replies Latest reply: Apr 10, 2014 1:27 PM by MacThijss RSS
  • jefish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2011 11:33 AM (in response to NFH.)

    Same.  Has been 'Never' since I got the phone.  This was never an issue with my iPhone4 with iOS5, and still isn't. My SO uses my old phone, and I've gone through every setting I can find to make sure they all match my 4S.  I get dual alerts, she doesn't.

  • stephen.bradley Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jan 23, 2012 7:39 PM (in response to p0l4rchris)

    I still haven't found an answer to this, but if anyone else is troubleshooting: for me this happens only with text messages. If it's an iMessage, it obeys the "never repeat" setting. If it's a straight up text from a non-iDevice, it repeats.

     

    Also happens on my sister's iPhone, same deal, text messages only.

     

    Still looking for a solution.

  • AMC7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 24, 2012 8:17 PM (in response to p0l4rchris)

    I have the same problem.

     

    I got your text, I ignored it.

     

    Dont remind me!

  • stephen.bradley Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jan 25, 2012 5:13 AM (in response to p0l4rchris)

    Ok, this probably isn't a universal fix, but it worked for my sister and I - at least, it's worked for the last 24 hours.

     

    Settings -> Notifications -> Messages, turn off notification center

    Settings -> Messages, turn off iMessage

    Reboot the phone

    Turn Message notifications back on, then turn iMessage back on, in that order.

     

    So far, no repeats.

  • AndrewC13 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 25, 2012 2:41 PM (in response to p0l4rchris)

    Hey guys if you just turn the banner off for the notifications that will do it. when it comes up on the front screen it alerts and when the banner comes across after unlocking it goes off. it took me a whole to figure it out but its a sure fix.

    Settings>Notifications>Messages>Alert Style>None

  • jbloyd9 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 27, 2012 12:52 PM (in response to apstoronto)

    I'm having the same issue. ATT couldn't fix and Apple wants to charge me $30 to tell me how to fix it. Have you figured it out yet?

  • robozak Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 27, 2012 3:36 PM (in response to jbloyd9)

    It is incrdedibly annoying.  After trying Settings/Notifications/Messages/Repeat Alert and set to never, the nasty thing came back again.  I activated and deactivated the Repeat Alert setting and have not had any problems since.  I hope this helps.

     


  • eternalshadows Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2012 9:53 AM (in response to p0l4rchris)

    I have found a relatively good work around for this but it still shouldn't have to be done.  If you go to Settings->Sounds and disable vibration in the "Ringer and Alerts" section it stopped it.  My phone was going off 4 times for every text I got and this has stopped the problem for the last 2 weeks.  Hopefully apple fixes this soon as it is an obvious software bug.

  • lephunk Level 1 Level 1 (65 points)
    Currently Being Moderated
    Feb 3, 2012 4:22 PM (in response to stephen.bradley)

    "Ok, this probably isn't a universal fix, but it worked for my sister and I - at least, it's worked for the last 24 hours.

     

    Settings -> Notifications -> Messages, turn off notification center

    Settings -> Messages, turn off iMessage

    Reboot the phone

    Turn Message notifications back on, then turn iMessage back on, in that order."

     

     

    nice. worked for me. thanks!

  • [V] /-\\ \'][\' \'][\' Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 19, 2012 4:57 PM (in response to stephen.bradley)

    By reboot, you mean hold down both the Lock and Home buttons for like 5-10 seconds, right?

  • itskiranr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 23, 2012 12:33 AM (in response to p0l4rchris)

    I bought my 4S from UK and now I am in India. It was working alright through this time and starts giving this issue since last week. I have double alert on messages and the apps like fring and Meebo. It is really annoying. If I restart the device it will be ok for 2-3 hours and again same story. I think we have to wait for the new IOS update to release

  • darkstar203 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 25, 2012 4:12 AM (in response to robozak)

    Iphone 4S OS 5.1, this is soo effing annoying....

     

    what robozak said fixed it for me

     

    Fixed - go to Settings/Notifications/Messages/Repeat Alert and set it to never.  This will stop the dual alerts

  • stephen.bradley Level 1 Level 1 (20 points)
    Currently Being Moderated
    Mar 25, 2012 4:55 AM (in response to darkstar203)

    I just want to point out, for others that will find this thread later: this is not a bug.

     

    If your Repeat Alert setting is set to 1 or higher, you're going to hear the notification more than once: First, the initial, then again as many times as you told it to repeat. That's why the setting is called "REPEAT" alert...it repeats it. That's why setting it to "none" makes it stop.

     

    The problem many of us were having was that the alert was repeating 1 or more times, even with the setting at "none", that's why there's all the advise about turning things on and off and rebooting. Which, at least for me, did fix the problem.

  • iderythought Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2012 7:27 AM (in response to p0l4rchris)

    I am also being alerted twice after receiving a text and not reading it immediately.  I have my repeat alert settings set to "never."  I know for sure that I am alerted twice when receiving a text via the standard text messaging system, but I can't recall if I am alerted twice when I receive a text message via iMessage.

    More Reviews: How to transfer iMessage files from iPhone to Mac

  • tomaish89 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2012 8:16 PM (in response to p0l4rchris)

    This is happening to me as well, i tried to reset the phone and alerts were proper and again after fews days it started alerting twice.. I had this issue with the 5.0 OS and now in 6.0.1 as well..!

     

    Apple any fix for this.. bcoz this is really annoying..!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.