Skip navigation

Invisible Filter in "Places" View: How to clear it?

2344 Views 11 Replies Latest reply: Feb 10, 2013 11:59 AM by craiglonie RSS
léonie Level 8 Level 8 (46,350 points)
Currently Being Moderated
Jan 25, 2012 4:51 AM

Hello all,

all of a sudden I am having trouble with the "Places" View (from the Toolbar, not from the Inspector).

placesempty.png

When I display any folder, project, or the Photos View, and select "Places" from the Toolbar, the map is empty and only the images without geotags are displayed in the Filmstrip; the result is exactly as if an invisible Filter were applied, that selects only the videos and images without geotags, whereas the Places View from the Library displays all 20000 images correctly. All visible filters all thru the folder hierarchie are cleared;I tried several variations of Frank Caggiano's neat trick to clear invisible filters in Photos View (Correct AnswerRe: Photos not showing up in search), but the double double reverse Caggiano does not seem to help here. Neither did trashing preferences, rebooting, switching libraries, repairing permission, nor repairing the library.

BTW: the problem is the same with all libraries - old and new - in my user account on this MBP;

 

Any suggestions, before I go to the trouble of reinstalling Aperture or Lion?

 

Regards

Léonie

P.S.: the trouble the poster has in this thread looks very similar to me, but I did not want to hijack the thread: Aperture and Places does not work

 

Aperture 3.2.2

MacBook Pro, Mac OS X (10.7.2), 2.53 GHz Intel Core 2 Duo 8 GB 13''
  • fibot Calculating status...
    Currently Being Moderated
    Jan 25, 2012 6:36 AM (in response to léonie)

    Thank, but theres no plist to trash att all???

     

    Bildschirmfoto 2012-01-25 um 15.29.35.png

    Bildschirmfoto 2012-01-25 um 15.29.13.png

     

    got never any problems like this with apple. I'm feeling like using windows. somethings totally out of work and there seems to be no reason.

  • fibot Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 25, 2012 6:58 AM (in response to léonie)

    **** ya! It works. So I try to reconstruct what happended.

     

    As the first Startup of Aperture, it asked me If I want that apple sent my data to apple to get the Geoinformation. I confirmed no. Because of that I got no access to the map. First start up of Aperture was long time ago and I forget about doing this. And I think there was no possibility to change this first answer in any option menu. Now I deleted the com.apple.Aperture.plist in my the library of my home directory. By the next startup of Aperture it asked me again if Iwant that apple sent data for the geoinformation. I said yes and now maps are working. Thanks a lot!!!!!

  • 1 Open Loop Level 2 Level 2 (350 points)
    Currently Being Moderated
    Jan 25, 2012 7:23 AM (in response to léonie)

    Is fibot's experience correct? If you answer no to sending data to Apple when you first launch Aperture, the only way change this is to trash preferences?

     

    Or is this controlled by Preferences > Advanced > Look up places automatically?

  • 1 Open Loop Level 2 Level 2 (350 points)
    Currently Being Moderated
    Jan 25, 2012 8:03 AM (in response to léonie)

    When you answer Yes, do you know what gets sent to Apple? What is the feature for?

  • Mr Endo Level 3 Level 3 (990 points)
    Currently Being Moderated
    Jan 25, 2012 10:40 AM (in response to fibot)

    Tobi,

     

    It sounds like you solved the problem that Leonie and I were trying to help you with in your question.  If that is the case, it would be good to go back to that question and mark it as answered, and also write a new reply with a link to this thread.

  • craiglonie Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 10, 2013 11:59 AM (in response to léonie)

    Hi Leonie im probably being thick but i dont know how to open my user prefereces pane to delete the plist can you show me where it is

     

    how do i find the "GO" menu

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.