Skip navigation

Home sharing will not show up in iTunes?

294230 Views 151 Replies Latest reply: Mar 28, 2014 4:25 PM by Vick M. RSS
  • nbaker17 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2012 1:29 PM (in response to sledordie)

    Exact same problem with me. Home Share just disappears after I hit "Done". I've tried to turn off home share and turn it back on. Doesn't work. I've tried to reboot iTunes AND the computer for both machines. Doesn't work. I've tried to reset the router. Doesn't work. Both machines have the latest iTunes installed. Still doesn't work. Why?!?! Please help!

  • natie55 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2012 8:20 PM (in response to sledordie)

    same thing going on with me its fusterating. i try to turn of home sharing for both computers then turn on for both computers. it showed up the first time then it went away. i hope apple fixs this problem bc im trying to update my computer and i dont want to worry about this problem?!? any help would be wonderful! thanks

  • mracole Level 4 Level 4 (1,075 points)
    Currently Being Moderated
    Jan 25, 2012 10:36 AM (in response to natie55)

    Having just had this occur for the first time, the solution was:

     

    a.  To confirm that if Home Sharing is working correctly but no other shared libraries are on-line the SHARED element of the left panel does not appear;

     

    b.  Ensuring that Home Sharing is correctly enabled on each machine and bringing all on-line immediately restored the SHARED area, listing each library as the settings were confirmed.

     

    Now all is restored ... provided that the computers can see each other on the network it does work well.  You do need to both set the Edit Preference and Advanced Turn On/Off sharing options correctly.

     

    Hope this is helpful - it surprised me that no SHARED area was shown unless other computers were correctly configured to share.  On my network is looked as though one iTunes client was behaving differently from another.

  • bigbear1994 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 28, 2012 8:38 PM (in response to mracole)

    Thanks: Resetting Netgear router resolved the problem.

  • DLABMAN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 31, 2012 6:57 PM (in response to mracole)

    I followed your advice but Home share still will not work.  I've checked everything on both computers and all share libraries are checked, it says Status on no uses connected on both computers.  I have a belkin router that i turned off and back on ( both computers are connected to the internet on this same router) still no home sharing.  It seems apple has a problem they wont fix, we shouldn't have to jump through hoops to make this work.  Please advise if you can or if anyone else can help i sure would appreciate it, thanks.

  • spenderson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 6, 2012 1:13 AM (in response to DLABMAN)

    If you are using a PC, make sure that you have selected your network as a "Home Network" in the Network and Sharing Center.  If a "Public Network" is selected then your PC will not enable sharing and thus not allow iTunes to share data with your devices over the network.

  • Spazmodo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 13, 2012 9:14 AM (in response to DLABMAN)

    Apple just refuses to properly support non Mac users. This is ridiculous. I've tried everything in this thread plus many other things. It doesn't work right.

     

    I have 2 systems both running Windows 7

    They can see each other

    Home Network on both connections and HomeGroup enabled on both systems

    Reset router

    Disabled and reenabled Home Sharing on both (interesting note:the home sharing icon shows up on both systems when it is reenabled but as soon as I click the "done" button it disappears)

     

    Come on Apple...get it together. Oh and while your at it fix the stupid AppleSyncNotifier.exe error. A NOOB IT support guy can write a script that can copy two dll's but you guys can't? Please....

  • Kathy Nell Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 13, 2012 9:50 AM (in response to nbaker17)

    turn off your firewall on both computers you are sharing,

     

    this worked for me, firewall prevents the sharing

     

    also make sure when you are using home sharing that you use the same account to turn on sharing on each machine,

     

    since i was trying to get music from my husband's machine, i turned on his home sharing with his mac account and then turned on my computer's home sharing with his account ( name and password)

     

    after you do this the computer you want to get the music from will appear in your own iTunes, make sure the icon is a small house and not the CD stack with a music icon

     

    kathy

  • Spazmodo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 13, 2012 9:52 AM (in response to Kathy Nell)

    Tried all of this Kathy and it didn't work. I also downloaded the Remote App to my iPhone and it doesn't see either of them. I can share my music through the HomeGroup settings either direction between my two computers but not with iTunes. Would be cool to control my music with the Remote App..

  • Sandancer Level 1 Level 1 (20 points)
    Currently Being Moderated
    Feb 14, 2012 12:27 AM (in response to Spazmodo)

    Appple dooes not support mac users when it comes to home sharing. In the apple forums alone, there are thousands of people with macs and windows pc's , who have been having problems with home sharing for months now and they do nothing. I now use my apple tv2 as a paperweight until (if) they ever come with a solution. The problem is iTunes server. I have reverted to a DNLA server. It streams everything from iTunes perfectly. Steve was correct in saying that the ATV2 is magical, but thats when it is working.

    Kind regards

  • JayJaz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 26, 2012 5:24 PM (in response to sledordie)

    Go to Edit in iTunes. Check on the Preferences, and make sure HomeSharing is checked.

  • justalexander Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 28, 2012 7:51 AM (in response to sledordie)

    So I have been dealing with this issue for hours.  The icon for home sharing would simply dissapear every time I log in with my Apple ID, adn try turning it on.  I've tried, resetting my router, resetting computers, adjusting my Microsoft firewall settings through control panel.  No luck.  I was about to give up, until I remembered that I have McAfee Internet Security software, which is firewall/anti-virus bundled software.  I just went into the McAfee settings, under "set connection type".  It's default setting was under "untrusted network", which in effect does not allow computers on the same network to communicate with one another.  I changed that setting to "Trusted Network", which now allows the computers to communicate.  I relaunched iTunes on both computers, as well as iPhone Remote software, and everything FINALLY works!  It was simply the McAfee firewall/anit-virus software blocking things and not an Apple issue.  I'm sure Symantec/Norton has a similar firewall option for those using that software on their computers.  Hope this helps with people running this type of software in the background.

  • burningthedays Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2012 11:06 PM (in response to justalexander)

    Sorry justalexander, that isn't it either.... I went to my Norton security and networks were already unblocked.  I tried turning the firewall off completely and restarting iTunes... turning home sharing off and on... NOTHING.  It's a major gaff from apple and I hope they fix it quick.  I obviously have it set up correct because the sharing opens on my ipad when I open itunes on my computer, and I have access to the songs in my computer, but home share doesn't show up on my computer, so I can't see my ipad.  I've read and tried everything here to no avail.  As I said, the PC and the ipad are both signed into same ID and the sharing shows up fine and works fine on my ipad.  I can see all songs from the PC, but home share just doesn't show up on the PC at all.  APPLE>>> HELP!

  • SeanMesservey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2012 12:32 AM (in response to sledordie)

    Both of your computors that you want with Home Sharing has to be up to date both having the same update. Both Having Itunes 10

  • burningthedays Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2012 10:02 AM (in response to SeanMesservey)

    Both are up to date.  I just updated iTunes on my PC a day or two ago, and did the iPad latest version 5.1 or whatever the new one is a couple days ago also.  Home share still disappears when I click done when turning on home share on the PC

1 2 3 4 ... 11 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.