13 Replies Latest reply: Jan 9, 2013 8:15 AM by pattyfrompriest river
eddienegrete Level 1 Level 1 (0 points)

I can not match up all of my music in iMatch.

  • 1. Re: iMatch is not matching all of my music
    KeithJenner Level 4 Level 4 (1,020 points)

    If you are saying that some of your music is being uploaded rather than matched then that is what we would expect.

     

    A matching rate of 80-90% is pretty good at the moment, but it does depend on how mainstream your collection is.

     

    There will be a number of tracks that don't match which you may expect to. There are lots of discussions here about that.

  • 2. Re: iMatch is not matching all of my music
    eddienegrete Level 1 Level 1 (0 points)

    Nope. All of my iTunes purchased music is uploaded to iCloud through iMatch in my iTunes except all of my music that was uploaded thru Cd's or from Amazon. They have been waiting in the cloud image on my iTunes since December 2011! They are all in AAC and MP3 format.

     

    Your turn....

  • 3. Re: iMatch is not matching all of my music
    Michael Allbritton Level 6 Level 6 (16,710 points)

    Sounds like you need to turn on the iCloud Status column in the iTunes browser so you can see the status of the tracks. Pull down View > View options and select the box for iCloud Status.

     

    BTW, music purchased from the iTunes store will, generally, not be "uploaded" since it is purchased from the store. It will be categorized as "purchased" and not count against the 25K track limit. The majority of music in your library purchased from Amazon, ripped from CDs, or from other sources will me "matched" which are also not uploaded files. Any tracks which are not "purchased" or "matched" will be "uploaded" (which you will be able to see after you enable the iCloud Status column).

     

    As Keith said, this behavior is to be expected. Most people experience an 80-90% successful "match" rate with the remainer of their music being "uploaded." If you are expecting a 100% success rate you will be disappointed.

  • 4. Re: iMatch is not matching all of my music
    KeithJenner Level 4 Level 4 (1,020 points)

    eddienegrete wrote:

     

    Your turn....

    For what?

     

    When you say your purchased music is uploaded, can I just clarify that it's iCloud status is not actually "purchased", which is what I would expect. If they are actually uploaded then something is probably wrong there, unless they were purchased using a different Apple ID.

     

    As for your CD's and Amazon purchases, have none of them matched or uploaded at all? If so, what trouble shooting have you done so far? Obviously that is very wrong, but it's difficult to tell exactly what the problem is.

  • 5. Re: iMatch is not matching all of my music
    mracole Level 4 Level 4 (1,075 points)

    Suggest in your main Music library view you turn on:

     

    a.  iCloud Status

     

    b.  iCloud Download

     

    c.  Kind

     

    By looking at these for each Song you can see exactly what is really happening.

     

    If it looks truly odd, past a screen shot into this thread via the camera icon and we can work through any apparent issues.

     

    For recent iTunes purchases you should expect them to be recognised as 'purchased', recent high quality digital sources will usually match, older digital and lesser sources will often be uploaded.

  • 6. Re: iMatch is not matching all of my music
    laxwyo Level 1 Level 1 (0 points)

    I think 700 out of my 3700 had to be uploaded.  Since only a few hundred were purchased from Itunes store, that's pretty good.  Only annoying thing is some of the songs from the same CD I ripped wouldn't get matched and had to be uploaded.  Happened a lot with my Pink Floyd Cd's.  Why would "Welcome to the Machine" get matched and "Wish You Were Here" and "Have a Cigar" not get matched?  Same CD, ripped at the same time.  Same with some of my Stone Sour.  A lot of the songs uploaded just wasn't in their library. 

     

    I wish there was a way to try and rematch songs that have been uploaded. It would be in Apple's best interest if they weren't having to upload music that was in their library. 

  • 7. Re: iMatch is not matching all of my music
    Michael Allbritton Level 6 Level 6 (16,710 points)

    laxwyo wrote:

     

    Happened a lot with my Pink Floyd Cd's.  Why would "Welcome to the Machine" get matched and "Wish You Were Here" and "Have a Cigar" not get matched?  Same CD, ripped at the same time.  Same with some of my Stone Sour.  A lot of the songs uploaded just wasn't in their library. 

    The reason you're seeing this behavior is probably because you have the older CD masters of the Pink Floyd albums. They released new masters in 2011 and the albums on the store are those masters. I bought the boxed set and every track but two matched for me. Don't know why those 2 didn't match, but I don't really worry about it.

  • 8. Re: iMatch is not matching all of my music
    laxwyo Level 1 Level 1 (0 points)

    I'm not sure they even had Pink Floyd before they released the new masters.  It wasn't that long ago that I saw "The Wall- Remastered"  and if I remember right, that was the first time I saw Pink Floyd in Itunes.

     

    You're right, my CD's have to be 15yrs old or so.  I was really hoping to get a lot of my older CD's matched.  Heck, my wife and I thought that the $25 would pay for itself by upgrading our music.  But there's the rub.  It's Apple's whole schtick, getting your current music library upgraded to a better quality.  I noticed that my older CD's when ripped, even at a higher bit rate sounded terrible and quieter than more recent music downloaded or ripped.  I thought that ripped songs, if they were in the Itunes Library would definitely get matched and most have, but slightly dissappointed that I'm not getting 100% of ripped music in my collection (that is in the Itunes Store Library).  I'd put it at 95% of the songs Apple has in their library are getting matched. 

  • 9. Re: iMatch is not matching all of my music
    Michael Allbritton Level 6 Level 6 (16,710 points)

    A 95% match rate is really good.

     

    You're right about Pink Floyd, they weren't on the store for several months before the re-masters were released. FYI, they had won a lawsuit against their record label and removed all their albums from digital distribution, then when the re-masters were released the albums were added back into the iTunes Store.

  • 10. Re: iMatch is not matching all of my music
    captfantastic Level 1 Level 1 (0 points)

    I was hoping that the recent iTunes Update that was supposed to help iTunes Match recognition results and cause more tracks to match would do something but I still have 7000 sitting in "waiting".

  • 11. Re: iMatch is not matching all of my music
    pattyfrompriest river Level 1 Level 1 (0 points)

    So when you say "waiting", will this remain until iTunes iMatch brings them (older version) in or do we have to end up buying the newer through ITunes? I am frustrated as I have the whole Bible I ripped off and bought the whole set so I can have on all my devices to listen to during my workouts. Now all in waiting except for 12 chapters in the New Testament. So what now? Never have it on my devices or turn off iMatch of what I spent $24.99 for to have all across my devices? Anyone have a good answer? Hummmm

  • 12. Re: iMatch is not matching all of my music
    Michael Allbritton Level 6 Level 6 (16,710 points)

    iTunes Match is not intended for audiobooks. If you've ripped an audiobook you need to set the Media Kind as "audiobook" and sync it via USB to your iOS device.

     

    1. Turn off iTunes Match.

    2. Highlight all the tracks of the audiobook in the iTunes library and pull down File > Get Info > Options.

    3. Change Media Kind to "audiobook."

    4. Click OK.

    5. Re-enable iTunes Match.

     

    Now you will be able to sync the audiobook to the iOS device via USB.

  • 13. Re: iMatch is not matching all of my music
    pattyfrompriest river Level 1 Level 1 (0 points)

    Cool! I will try this and let you know. Thank you so much!