6 Replies Latest reply: Jan 16, 2013 5:50 PM by Nu3te
Robert Saunders1 Level 1 Level 1 (75 points)

I can't open iTunes, dialogue says I need QuickTime 7.5.5, but when I download the upgrade it won't install over my QuickTime Pro 7.2.1. How do I upgrade QT so it'll be compatible with my iTunes?

 

-Rob


PowerMac, Mac OS X (10.5.8), 3.5 GB RAM, 150GB HD, 232GB SD