Skip navigation

Windows 7 x64 with boot camp 4.0 - "unsupported model"

57629 Views 21 Replies Latest reply: Feb 2, 2014 6:02 AM by kevlam3 RSS
  • l008com Calculating status...

    Is there another way to do this?

    My mouse only has one button. Control clicking won't work until AFTER I install the bootcamp drivers. There must be some other way to run this command as an administrator?

  • l008com Level 1 Level 1 (35 points)

    Nevermind I found it. The trick was to use the arrow keys to select CMD from the search results, and choose it by hitting control shift enter, instead of just enter. BootCamp is installing as we speak.

  • dave169 Calculating status...

    So I came across this issue installing Windows 7 Home Premium on my more than capable MacPro 1,1.

     

    I couldn't get the execute command in "elevated privilege" mode previously stated to work from the command line or from "right-clicking".

     

    The trick is to click on Start, type in the "Search programs and files" box, type "cmd" and then hit "ctrl+shift+return".  This executes the command prompt in Elevated privileges mode, and then run your msiexec /i command.

  • Jaygyver Calculating status...

    You know, I was wondering if you were to insert your computers Boot Rom Version profile into the ""<key>DARequiredROMVersions</key>"" description in the .plist file in Boot Camp Assistant, like you would for the MBA hack as it were for the un-dimming of the "Create a Windows install disk" option if it would install normally?

     

    Heres the link.

     

    Oh buggers, I was thinking of something else.

     

    Message was edited by: Jaygyver

  • tim4791 Calculating status...

    Thanks Judah87. I did need to change the command to cd Drivers\Apple and omit WindowsSupport. Working great now!

  • Kreynor Level 1 Level 1 (0 points)

    I love you.

    I was in the exact situation and I know very little about Windows. Thanks.

  • kevlam3 Level 1 Level 1 (0 points)

    I had the same problem too with my Unibody Macbook late 2008 model with Windows 7 64bit.

    I tried troubleshooting compatibility and all that and it still wont run.

     

    The way i got around it was:

    1) Copy the BootCamp data onto my desktop

    2) to basically disable UAC (User Account Control) setting in control panel to "never notify" and make sure you are in administrator account, then restart windows.

    3) I then navigate BootCamp\Drivers\Apple\BootCamp.msi -> and run the installer. Voila! everything installs.

     

    BTW, I used Boot Camp 4 downloaded from Apple website. Not sure if it works running BootCamp from pendrive.

     

    Hope that helps

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.