Skip navigation

trackpad won't connect with bluetooth

33055 Views 40 Replies Latest reply: Apr 2, 2014 10:46 AM by mattalex RSS
1 2 3 Previous Next
lsb Calculating status...
Currently Being Moderated
Jan 30, 2012 12:01 PM

Hello,

 

I upgraded to Mac OSX Lion some months ago and my trackpad connected without a problem.  In the past week, my trackpad has been losing connection with the computer when it is sleeping.  I have tried the trackpad with my laptop and it works fine, so I know it is an iMac/trackpad issue.  I have also reset the PRAM to no avail.

 

Anyone have any ideas how to resolve this issue?  The computer simply does not discover the trackpad.

 

Thanks.

lsb

iMac, Mac OS X (10.3.x)
  • 6ITManagement Level 1 Level 1 (115 points)
    Currently Being Moderated
    Jan 31, 2012 3:16 AM (in response to lsb)

    Turn the bluetooth on your computer off and back on. Also turn the trackpad off and on, it's not much of a solution, but the small things often fix huge problems!

  • 6ITManagement Level 1 Level 1 (115 points)
    Currently Being Moderated
    Jan 31, 2012 8:54 AM (in response to lsb)

    Hmm... Do other bluetooth devices connect to the iMac?

  • 6ITManagement Level 1 Level 1 (115 points)
    Currently Being Moderated
    Jan 31, 2012 10:18 AM (in response to lsb)

    Well, it kind of means that there really is something wrong with the iMac's bluetooth, and not just with the connection with your trackpad. Unfortunately I can not find any 'special' options in the bluetooth settings.

    However you could try this:

    • Open "System Preferences"
    • Select the "Bluetooth" pane
    • Find your trackpad (it should say "Not Connected" underneath the name)
    • Select the trackpad and press the little "-" and confirm by clicking on "Remove"
    • Now, turn your bluetooth off and back on again, just in case

    Please let me know whether this works or not.

  • 6ITManagement Level 1 Level 1 (115 points)
    Currently Being Moderated
    Feb 1, 2012 3:52 AM (in response to lsb)

    There probably is some solution that involves some terminal-magic, but since I only know a few Terminal commands, I'm afraid you'll have to wait for a Terminal-wizard to reply to this post. You could also try contacting Apple and see what they have to say.

  • 6ITManagement Level 1 Level 1 (115 points)
    Currently Being Moderated
    Feb 1, 2012 10:14 AM (in response to lsb)

    You're very welcome! Please let me know what Apple says about the issue though, thanks.

  • Greatestever1 Calculating status...
    Currently Being Moderated
    Jul 4, 2012 7:50 PM (in response to lsb)

    Did u ever solve proble with trackpad?

  • JWPNJ Calculating status...
    Currently Being Moderated
    Jul 14, 2012 12:32 PM (in response to lsb)

    Any other solutions here?  I'm having the exact same problem.  My trackpad is connected to my iMac.  Went to the Apple store and tested the Trackpad and it worked fine.  Bluetooth keyboard works fine.

  • GMWDesign702 Calculating status...
    Currently Being Moderated
    Jul 23, 2012 11:14 AM (in response to lsb)

    Check to make sure your trackpad is not connected to another Mac in the area of your current Mac you're having the issue with. 

     

    In my experience the trackpad will not connect to a new device if it's currently connected to another device.

  • joeman42 Calculating status...
    Currently Being Moderated
    Aug 2, 2012 11:37 AM (in response to lsb)

    My new Macbook Pro (which was migrated from my older Mac Pro tower) failed to discover and connect to my trackpad this morning (despite having connected yesterday), so I used the Apple Developer tool called "Bluetooth Explorer.app", found and deleted the trackpad from the Device Cache, and walked through the Setup Trackpad steps in System Preferences. That seemed to work.

     

    I realize that not everybody has knowledge of or access to the (free!) Dev Tools at Apple, but if you know your way around developer.apple.com you can often find some interesting tidbits. Well worth signing up for (https://developer.apple.com/downloads/index.action?name=for%20Xcode%20-# Download "Hardware IO Tools for Xcode")

     

    I'm not sure why caching a device would prevent re-connection -- I've got a theory that it's something to do with Migration Assistant or upgrading from 10.7 to 10.8 -- the device is recognized as cached but the cached info is out of date or has metadata applicable only either to the older computer or 10.7.

     

    My other theory is that perhaps when the device lost connection that it did not get "put away" correctly. I also noted that prior to my removing from the cache, that the Bluetooth Explorer was unable to pull down the device's SDP record (error 0x4). The SDP record are how Bluetooth devices tell the host computer what capabilities they support, and I think the OS caches these.

     

    Joe K.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.