Skip navigation

Sounds doesn't come out of thunderbolt display

5189 Views 13 Replies Latest reply: Jan 8, 2014 11:50 PM by KwakaZX14 RSS
kelfaij Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 1, 2012 11:37 AM

Hi everyone,

 

I am experiencing an issue.

The sound doesn't come out of the thunderbolt display when connected to my macbook air i7 256GO. It was working ok before (but I was still experiencing the isssue time to time but unpluging and repluging was fixing the issue - not anymore). The sound still comes out of the macbook air speakers.

I tried a reset SMC and PRAM but no change.

 

I would like to avoid the pain to reinstall everything just to check if it is not a software issue. any other test I should do beofre calling the support ???

Appart from that the USBs and firewire and the camera work fine.

 

Thanks in advance.

  • Designer Gav UK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2012 12:21 AM (in response to kelfaij)

    I'm about to scour Discussions to find somewhere to post my problem - which is related to yours!

     

    I've noticed that my Thunderbolt sometimes refuses to produce sound and when checking in System Preferences>Sound everything is 'greyed' out from Sound Effects to Display Audio, with a blank where usually there is a Device For Output.

    I also noticed Safari niggles and I had to literally open Finder from the Dock to make it visual on Thunderbolt.

     

    On Restarting everything reverted back to what it should be.

     

    The only reason I found for these problems was sometimes when my OSX Lion Macbook was booted it took ages to open, with a progression bar visible, and even longer to open Thunderbolt.

    Other times is booted fast and straight to Thunderbolt, no problems.

     

    Anyone else getting the same grief?

  • mkatz Calculating status...
    Currently Being Moderated
    Feb 2, 2012 7:27 PM (in response to kelfaij)

    I have a similar issue I need help with. I can't get the sound to come out of my Thunderbolt display because when I go to preferences > sound > output my only option is Internal Speakers, so the sound only comes out my my Air. There is no option for the Display Speakers. Any idea how I make that option available?

  • Designer Gav UK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 22, 2012 1:41 AM (in response to kelfaij)

    But why should we have to do all this when Apple claim TD works "seemless" with a laptop???

     

    I'm now at the stage of booting the MBP independently, then either re-booting or sending it to sleep THEN plugging in my TD!

  • Hansman67 Calculating status...
    Currently Being Moderated
    Jun 16, 2012 7:22 AM (in response to kelfaij)

    Go to systempreferences, sound, select USB.  Problem should be solved

  • riaandelange Calculating status...
    Currently Being Moderated
    Jun 19, 2012 12:46 PM (in response to Hansman67)

    USB option is not there *******. Did you read the original post?

  • Designer Gav UK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 19, 2012 2:39 PM (in response to Hansman67)

    Don't talk daft Hansman67 - that's one of the core problems.

     

    Some people are finding that sound options are 'greyed out' when selecting TB sound (USB to you) - even using volume keys on the keypad just shows the 'no sound/mute' sign.

     

    Luckily when I plug MBP to TB and boot up now everything runs fine - that's without any new OSX update, any change to my routine, even without kicking my MBP around the floor!

     

    Curiouser and curiouser.

  • tallmanjack Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 10, 2012 9:10 AM (in response to kelfaij)

    Try this.

    Shut-down everything and unplug the power-supply of the thunderbolt screen - leave it unplugged for 30 seconds. Plug-in again and restart.

     

    It worked for me.

     

    Best wishes

  • jj7q Calculating status...
    Currently Being Moderated
    Jan 4, 2013 2:21 PM (in response to Hansman67)

    >Go to systempreferences, sound, select USB.  Problem should be solved


    Yes!!!!  This resolved the problem.

     

    Thanks

  • Todd_Billiar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 11, 2013 2:46 PM (in response to kelfaij)

    My mistake was over-looking the defaulted Mute on setting.  Selecting USB and clearing the mute optiuon resolved the issue for me.

  • KwakaZX14 Calculating status...
    Currently Being Moderated
    Jan 8, 2014 11:50 PM (in response to Hansman67)

    >>Go to systempreferences, sound, select USB.  Problem should be solved

     

     

    Thanks that worked for me. The only thing I would add is that you need to choose the "Output" tab in the Syspref, Sound panel before you can select the "Display Speakers - USB" option.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.