Skip navigation

IMessage won't activate my phone number

168182 Views 96 Replies Latest reply: Jan 15, 2014 11:39 AM by Radiotron RSS
1 2 3 ... 7 Previous Next
Kelsey12 Calculating status...
Currently Being Moderated
Feb 1, 2012 1:52 PM

My iPhone 4 has been working perfectly up untill yesterday.

My iMessages stopped working from my phone number and started sending from my email address.

It says my phone number is waiting on activation


I have tried everything..

Resetting network settings

Turning iMessages on and off

Resetting my phone

Checked my phone number in settings>phone

Called apple who were as of no help


I have an iPad too I don't know if that has anything to do with it..

  • razmee209 Level 7 Level 7 (21,310 points)
    Currently Being Moderated
    Feb 1, 2012 2:06 PM (in response to Kelsey12)

    look in this link and see if it helps out


  • azriel550 Calculating status...
    Currently Being Moderated
    Feb 1, 2012 7:16 PM (in response to Kelsey12)

    I have the same problem.  All I did was turn iMessage off and then back on and now it fails to verify the phone number.  Still works off of the email address in my apple id but that's not good enough.  It's was working fine since the day iOS 5 was released.


    I've read countless forums and tried a thousand things but nothing seems to solve this problem.  Here's a list of the things I've tried:


    • Checked Settings > Phone > My Number and changed it from having the + country code to without and back
    • Reset Network Settings
    • Reset All Settings
    • Ensured Date and Time is set to auto
    • Ensured that Settings > Mail, Contacts & Calendars > My Info points to my card (and have deleted the card completely and re-added it)
    • Ensured my card in contacts has my phone number under the iPhone category
    • Restored the OS entirely and recovered from a backup
    • Added, to the DNS settings of my wifi connection
    • Tried activate via 3G instead of wifi
    • Removed sim card, inserted and rebooted
    • Rebooted a thousand times
    • Toggled all options under Settings > Messages back and forth, several times (including signing in and out of apple id)
    • Removed and added my phone number to my Apple Id account via web interface
    • Changed my Apple ID password
    • Tried disabling and re-enabling FaceTime (which doesn't seem to authorise now either)


    And there are probably more things I've tried than this that don't come to mind right now.


    My last resort was to walk into the store I bought the phone from where they said "er....... what er..... yeah probably an apple problem just er.... wait for a patch" without even attempting to offer any kind of troubleshooting advice whatsoever.  There is no Apple store in my city either so no genius bar to go to.


    HELP!  Apple? Anyone?

  • Defiled Level 2 Level 2 (385 points)
    Currently Being Moderated
    Feb 1, 2012 7:18 PM (in response to azriel550)

    You stated restored the OS entirely and recovered from a backup.


    Have you tried Restoring the device and setting up as new, not restoring from a backup?

  • azriel550 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2012 7:22 PM (in response to Defiled)

    No I haven't.  I was really hoping that I wouldn't have to do that as it's a real pain to have to go though and tweak everything the way I want it. 


    It's seeming increasingly likely that I will have to do that but I wanted to make sure I'd exhausted every other option first because if that doesn't work, then I'll have to waste even more time setting everything back up.


    It puzzles me to no end why and how this happened in the first place and was hopeful Apple may have another solution.

  • Defiled Level 2 Level 2 (385 points)
    Currently Being Moderated
    Feb 1, 2012 7:27 PM (in response to azriel550)

    Have you tried toggleing auto date and time off and on?

  • azriel550 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2012 7:29 PM (in response to Defiled)

    Yes. Several times.


    I appreciate your suggestions though.

  • azriel550 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2012 8:04 PM (in response to Kelsey12)



    Funny you mention that, I'm with Telstra too!  My sister (who's with Vodafone) had the same problem after going overseas and once we fixed her Settings > Phone > My Number entry (which had changed to an overseas number), it activated right away!


    I have read a number of posts that say that the activation process is handled behind the scenes by sending a text message to the carrier which then responds but I don't know if that's actually what happens or if it only happens with certain carriers.  To test this theory I went to two Telstra shops this morning.  Both were useless and didn't take any interest in the problem, although the second said that I wasn't the first customer to come in with the problem today.


    I'm in Adelaide so no Genius bar to go to.  Please let us know how you go!

  • I3lue Calculating status...
    Currently Being Moderated
    Feb 2, 2012 2:37 AM (in response to Kelsey12)

    I'm with Telstra too!

    I switched mine off yesterday and only just thought to turn it back on, and no matter what I try, it just WILL NOT come back on, and it is frustrating me like you wouldn't believe.

  • I3lue Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2012 2:52 AM (in response to Kelsey12)

    I'd say so, I'm about ready to rip out an abusive call to either apple support or Telstra.


    Neither of them are any help with any other problems with ANYTHING I've needed.

    So if they're unable to help with this, all sorts of things are going to hit the fan lol.

  • Antman1984 Calculating status...
    Currently Being Moderated
    Feb 2, 2012 2:04 PM (in response to Kelsey12)

    I'm having this exact issue...


    Was running an iPhone 3GS with iOS 5.0.1 and iMessages were working fine.


    Two days ago bought a second hand iPhone 4 from a friend. Did a full factory reset on it so I could start with a clean phone.


    Cannot get iMessages to work... it sits there saying "Waiting for Activation"


    It will work via my Apple ID, but not my phone number.


    I've tried everything listed in this thread plus a few things I found on google not listed here.


    Rang Apple Support and they talked me through a number of things to try... after a 45 min call they escallated me and that person said "the iMessage server is down at the moment".

    Um, really? Wouldn't they have known about that sooner?

    Why would it still work for a friend who already has iMessages set up under his phone number, yet I cannot "activate" my number with iMessage?




    For what it's worth, I'm with Telstra in Adelaide, SA.

1 2 3 ... 7 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.