Skip navigation

How do I delete duplicate songs from my iphone 4s

38877 Views 14 Replies Latest reply: Feb 23, 2013 10:34 AM by mdwalke RSS
wsh72 Calculating status...
Currently Being Moderated
Feb 2, 2012 7:14 AM

I have tried re-syncing with my iTunes on my PC and it doesn't work.  Just says "syncing" and quickly goes through the steps, and everything on the iphone is still the same.  I can delete albums from my collection on my PC and they delete from the iphone, but the duplicate songs are not showing up on the PC and they are in the phone and I can't see any way to get rid of them without deleting the whole album from my collection.

iPhone 4S
  • Stema001 Level 1 Level 1 (110 points)
    Currently Being Moderated
    Feb 2, 2012 7:16 AM (in response to wsh72)

    Try to delete them manually from your iPhone. Swip to the left on your iPhone. I had this bug also. One time.^^

  • Ingo2711 Level 6 Level 6 (16,815 points)
    Currently Being Moderated
    Feb 2, 2012 7:20 AM (in response to wsh72)

    Swipe over them from left to right and hit delete.

    You duplicate songs will show up in iTunes on the PC, if you choose File->show duplicates

  • Stema001 Level 1 Level 1 (110 points)
    Currently Being Moderated
    Feb 2, 2012 7:27 AM (in response to wsh72)

    You could go in iTunes to the iTunes Store and select "Bought Articles".

     

    Then you have the possibility to select your music download and press on the "X", which appears if you swip over a titel. If you press the "X" iTunes asks you if you want to hide this song.

  • Stema001 Level 1 Level 1 (110 points)
    Currently Being Moderated
    Feb 2, 2012 7:31 AM (in response to wsh72)

    If you have duplicates in your iTunes library, just try to delete them right in your library. Does this work?

  • Stema001 Level 1 Level 1 (110 points)
    Currently Being Moderated
    Feb 2, 2012 7:42 AM (in response to wsh72)

    Are you using iTunes Match? If yes probably the "hide song thing" could work.

     

    You could go in iTunes to the iTunes Store and select "Bought Articles".

     

    Then you have the possibility to select your music download and press on the "X", which appears if you swip over a titel. If you press the "X" iTunes asks you if you want to hide this song.

  • prewittj1 Calculating status...
    Currently Being Moderated
    May 1, 2012 7:58 AM (in response to wsh72)

    Did you ever get this fixed?  I have the same issue.  I have a duplicate of every song on my iphone4 when I click "songs" -shows 2 of every song.  I recently got a new laptop and during the process of switching everything over I created all these duplicates on my iphone.  The itunes library on the computer dosn't show any duplicates and my playlists on my phone are fine.  if I try to manually delete the songs directly on my phone, when I re-sync, they just come right back.  When I plug my phone in to sync and remove all my music, the duplicates are all gone but it still shows each song under "songs" without it's duplicate on my iphone. 

     

    A guy at the genius bar the other day told me he thought my phone is still acting like it is syching with my old computer and recommended doing some sort of backup and restore but I haven't tried that yet as I don't want to make more problems if that isn't gonna resolve it. 

     

    Let me know if you've have any luck and what steps you took??

  • Bwh1969 Calculating status...
    Currently Being Moderated
    May 29, 2012 5:13 PM (in response to prewittj1)

    I just had this happen when I wanted "normalized" music on my iPhone because I am no satisfied with sound check.  All my songs still had different volumes. I turned off the cloud on my phone and added music with USB. I turned the cloud back on and I got the duplicate issue. Here is what I did to fix it:

    Turn off Match on phone

    Update match in iTunes from the "store" menu (see below for why this might be REALLY important.

    Connect phone

    Check "manually manage" in iTunes from the first tab when you click your phone in the left pane

    Open the "tree" for you iPhone in iTunes by clicking the triangle.

    Select "music" in that tree.

    Delete all the Music from the phone.

    Sync it.

    Eject phone.

     

    Turn match back on and download music via the iPhone but this takes a while.

     

    or I just reconnected it, then went to the music tab for the phone ticked the sync option and checked the playlists I wanted. I synced it. I then made sure "manually manage" was checked in first tab, then went into the left pane and deleted the playlists. This leaves the music on the iPhone but not the playlists. I ejected and turned on match on the phone. 

     

    My guess is there is a glitch where identical playlists from the cloud seemed to conflict with the ones physically on the phone and / or iTunes match could not match the physical files on the phone.  It seems my metadata for the files "seemed" different than the ones in the cloud.  Running RealPlay gain on my library is suspect for my issue so if something happened on your computer that changed the data about your files even without you knowing, this might be the issue. It is merely a hypothesis but it seems logical. Resyncing match then putting the newly understood match on the phone seems to resolve my issue.

  • chakram5 Calculating status...
    Currently Being Moderated
    Jun 22, 2012 3:43 PM (in response to Bwh1969)

    Thanks--that helped me.
    I had adjusted the "ablum artists" and "genre" of many of the songs in my iTunes library. Becuase of this, I guess that seemed like "new songs' to my iPhone becuase I had duplicate copies of many of my songs on my iPhone (but NO duplicate songs showed in iTunes). I did the "manually manage" thing you suggested (but also had to manually delete every single artist from the Music app on my iPhone as well). This way, it was like I was starting over (with no songs on my iPhone at all), and then when I synced, all the songs from iTunes re-filled my phone and no duplicates were present!

  • Paul Reid Calculating status...
    Currently Being Moderated
    Jul 21, 2012 2:12 PM (in response to wsh72)

    Hi,

     

    My duplicate song issue happened with a compilation album I made up of individual tracks and I ended up with 2 compilation albums called "Paul's Mixtape". I looked further into it and I noticed one of the compilations had 18 tracks in it and the other had 19. I went to iTunes on my laptop and noticed that this one song that was different had the check box "Part of a compilation" ticked but the rest of the tracks didn't. I went through the rest of the tracks and checked the box in them all now I don't have and duplicate tracks.

     

    I don't know if this will help you but it might be an idea to select all of the tracks in the album and make sure all the generic fields like "Album" are the same for all. Then go through each individual track and make sure all of the areas like "Part of a compilation" are all identical too.

     

    I hope this makes sense and helps resolve this pain of an issue for you !!

  • mdwalke Calculating status...
    Currently Being Moderated
    Feb 23, 2013 10:34 AM (in response to wsh72)

    Thanks for this thread I have had this problem on my phone.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.